Package Details: prismlauncher-bin 8.3-1

Git Clone URL: https://aur.archlinux.org/prismlauncher-bin.git (read-only, click to copy)
Package Base: prismlauncher-bin
Description: Minecraft launcher with ability to manage multiple instances.
Upstream URL: https://prismlauncher.org
Licenses: GPL3
Conflicts: prismlauncher
Provides: prismlauncher
Submitter: Scrumplex
Maintainer: Scrumplex (txtsd, g3tchoo)
Last Packager: txtsd
Votes: 31
Popularity: 0.86
First Submitted: 2022-10-18 06:45 (UTC)
Last Updated: 2024-05-22 02:28 (UTC)

Dependencies (13)

Required by (2)

Sources (1)

Pinned Comments

Scrumplex commented on 2023-05-13 05:40 (UTC) (edited on 2023-05-13 05:41 (UTC) by Scrumplex)

Prism Launcher binaries work fine on every other platform, from what we can tell. The change that caused this incompatibility was made by the package maintainers of Qt 6 on Arch Linux. Commit

We have an issue tracking this upstream here, but honestly your best bet is to use prismlauncher instead. Alternatively you could pull the builds from chaotic-aur.

Latest Comments

captainbanaynays commented on 2023-06-08 20:08 (UTC)

Error on running the installed binary (v7.0):

warning: direct reference to protected function `_ZNK19QStyledItemDelegate15initStyleOptionEP20QStyleOptionViewItemRK11QModelIndex' in `/usr/lib/libQt6Widgets.so.6' may break pointer equality
prismlauncher: _ZNK19QStyledItemDelegate15initStyleOptionEP20QStyleOptionViewItemRK11QModelIndex: /usr/lib/libQt6Widgets.so.6: error due to GNU_PROPERTY_1_NEEDED_INDIRECT_EXTERN_ACCESS

trainzkid commented on 2023-05-13 11:02 (UTC) (edited on 2023-05-13 11:04 (UTC) by trainzkid)

Looks like, according to the issue open on your GitHub, using prismlauncher-qt5-bin also works. I haven't tested it myself but having another alternative is always good. Thank you for your transparency, @Scrumplex.

Edit: is there an issue open for this with QT6 on their GitHub or wherever?

Scrumplex commented on 2023-05-13 05:40 (UTC) (edited on 2023-05-13 05:41 (UTC) by Scrumplex)

Prism Launcher binaries work fine on every other platform, from what we can tell. The change that caused this incompatibility was made by the package maintainers of Qt 6 on Arch Linux. Commit

We have an issue tracking this upstream here, but honestly your best bet is to use prismlauncher instead. Alternatively you could pull the builds from chaotic-aur.

bbaovanc commented on 2023-05-13 00:15 (UTC)

@Scrumplex can you update the package? The error that @trainzkid mentioned has been going on for more a month now, and it's been flagged close to that long.

Hsky commented on 2023-04-15 19:00 (UTC)

Had the same problem that trainzkid had but building from the non bin package worked.

trainzkid commented on 2023-04-13 03:01 (UTC)

This fails to run with a qt-related error:

warning: direct reference to protected function_ZNK19QStyledItemDelegate15initStyleOptionEP20QStyleOptionViewItemRK11QModelIndex' in /usr/lib/libQt6Widgets.so.6' may break pointer equality prismlauncher: _ZNK19QStyledItemDelegate15initStyleOptionEP20QStyleOptionViewItemRK11QModelIndex: /usr/lib/libQt6Widgets.so.6: error due to GNU_PROPERTY_1_NEEDED_INDIRECT_EXTERN_ACCESS

Should I take this to prism's github instead?

txtsd commented on 2022-10-18 11:53 (UTC)

We haven't made a release yet, so that's expected. We're working toward a release though, don't worry!

Darkuss commented on 2022-10-18 11:51 (UTC)

This package can't be downloaded since the URL https://github.com/PlaceholderMC/PlaceholderMC/releases/download/1.4.2/PlaceholderMC-Linux-Qt6-1.4.2.tar.gz points to nothing