Package Details: private-internet-access-vpn 3.3.3-10

Git Clone URL: https://aur.archlinux.org/private-internet-access-vpn.git (read-only)
Package Base: private-internet-access-vpn
Description: Installs VPN profiles for Private Internet Access Service
Upstream URL: https://www.privateinternetaccess.com/
Keywords: connman networkmanager openvpn python vpn
Licenses: GPL
Submitter: flamusdiu
Maintainer: flamusdiu
Last Packager: flamusdiu
Votes: 84
Popularity: 1.030274
First Submitted: 2014-08-14 01:22
Last Updated: 2019-04-23 02:50

Pinned Comments

flamusdiu commented on 2016-10-01 10:56

Dev version -> https://aur.archlinux.org/packages/private-internet-access-vpn-dev/

You can submit issues on Github -> https://github.com/flamusdiu/python-pia

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

Cavsfan commented on 2017-04-14 18:03

@flamusdiu: do you know of any reason why Thunderbird cannot send mail while connected to the VPN? It will receive but, not send. Also my conkys do not work with weather and news sites. I cannot figure it out. I have opened tickets with PIA https://www.privateinternetaccess.com/ but, I do not think Linux is their forte. They added my outgoing SMTP server to their whitelist but, it still doesn't work and I don't even know why they should have to add it to a whitelist. In Windows 10 it works a dream but, in Arch and Xubuntu I have the exact same problem.
Thanks for all of your efforts

flamusdiu commented on 2017-04-13 20:14

@chappjc: I never tried -- but seems like that works to. I doubt there would be any issues with it.

chappjc commented on 2017-04-13 17:19

Can the zip files use HTTPS instead of HTTP? They are less likely to be blocked that way, but worse the zips can download with junk contents if a firewall wants to when using http.

flamusdiu commented on 2017-04-06 20:25

@Solstice: Oops, I didn't realize that. ha! Thanks for pointing it out. I'll have to see about fixing it through docker since I am not home atm.

solstice commented on 2017-04-05 21:43

There is a typo. Systemd files should be in /usr/lib/systemd/system not in /usr/lib/system/systemd

the patch to the PKGBUILD
--- PKGBUILD 2016-10-16 02:39:08.000000000 +0200
+++ PKGBUILD.new 2017-04-05 23:39:35.878484391 +0200
@@ -64,8 +64,8 @@
package() {
cd "${srcdir}"

- install -D -m 644 restart.conf "${pkgdir}/usr/lib/system/openvpn@.service.d/restart.conf"
- install -D -m 755 vpn.sh "${pkgdir}/usr/lib/system/systemd/system-sleep/vpn.sh"
+ install -D -m 644 restart.conf "${pkgdir}/usr/lib/systemd/openvpn@.service.d/restart.conf"
+ install -D -m 755 vpn.sh "${pkgdir}/usr/lib/systemd/system/system-sleep/vpn.sh"
install -D -m 644 pia.8.gz "${pkgdir}/usr/share/man/man8/pia.8.gz"


zachoooo commented on 2017-03-26 00:03

Awesome package! Thank you so much!

flamusdiu commented on 2017-03-06 01:57

@meticulo, the PKGBUILD file has the exact checksums of the files to build the package by. This is used to ensure proper building of the package when files are downloaded.

meticulo commented on 2017-03-05 03:51

@flamusdiu: I used the command you suggested, and the install was a success, but I was hasty and neglected to clone the package. The checksums in the now working PKGBUILD are included below. Forgive my lack of understanding -- would you be willing to explain what this problem was all about? I'm a little daft about these AUR packages. I use the command: cower -vdfu to check for updates and overwrite old stuff. Might that be the source of the problem? Thanks!

sha256sums=('c7c21e690a836fb42adae0addce45ea97a25d12ffd03d9fde04392933c33f36d'
'1f57eb735141b767f19d653ffa434ffa2d1108c2a5b74fe61c72542056360c77'
'9d28e1883d5f2e1b017789c051c6377b1e97ed86f72f84f3ca33b15a909947c7'
'4322a2a4bc3e206c6ab7e1df87a8805032b76c177c1ed9dd3501260ed32ccb30'
'797dbdb6e3aadc86f97262e26d61cf4847caf85dda4b7a97cac59088cb912b27'
'246fc4dc3218f56b4c70014df6801b10fc2a573d6545962b7fce05f16908c54e'
'7f4a5ee1fb8ea4d0e69ed2a8217c575cf335f21e90082f6e423c769eca4a7a46'
'dd15ff9d020d6779c51bff560c8571b462cc7ca3f4d2a92b8103056be4b2e0fd'
'SKIP'
'SKIP')

flamusdiu commented on 2017-03-05 02:31

@meticulo: whoops. you can clone the package and run updpkgsums.

Update: I just did this and got the same check sums. I wonder if something is wrong when you download it. If you do the command above, post the checksums for me if you get it to install afterwards.

meticulo commented on 2017-03-04 03:06

@flamusdiu: Thank you for actively developing this package! Very useful! I have been using and updating for awhile, but I have not been able to upgrade lately due to the following errors (below) following the command: makepkg -sci. Would you kindly explain how I can correct these invalid files and install the new build? Thanks again!

==> Validating source files with sha256sums...
openvpn-ip-lport.zip ... FAILED
openvpn.zip ... FAILED
openvpn-strong.zip ... FAILED