Package Details: private-internet-access-vpn 3.3.3-10

Git Clone URL: https://aur.archlinux.org/private-internet-access-vpn.git (read-only)
Package Base: private-internet-access-vpn
Description: Installs VPN profiles for Private Internet Access Service
Upstream URL: https://www.privateinternetaccess.com/
Keywords: connman networkmanager openvpn python vpn
Licenses: GPL
Submitter: flamusdiu
Maintainer: flamusdiu
Last Packager: flamusdiu
Votes: 84
Popularity: 0.931285
First Submitted: 2014-08-14 01:22
Last Updated: 2019-04-23 02:50

Pinned Comments

flamusdiu commented on 2016-10-01 10:56

Dev version -> https://aur.archlinux.org/packages/private-internet-access-vpn-dev/

You can submit issues on Github -> https://github.com/flamusdiu/python-pia

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

machfour commented on 2017-05-13 09:07

The checksums don't match anymore...
==> Validating source files with sha256sums...
openvpn-ip-lport.zip ... FAILED
openvpn.zip ... FAILED
openvpn-strong.zip ... FAILED
login-example.conf ... Passed
pia-example.conf ... Passed
restart.conf ... Passed
vpn.sh ... Passed
pia.8.gz ... Passed
python-pia ... Skipped
openvpn-update-resolv-conf ... Skipped
==> ERROR: One or more files did not pass the validity check!

Cavsfan commented on 2017-05-12 16:31

@newbOnArch, I always have used an alias and just enter 'upd' in terminal:
#get all updates even from the AUR
alias upd='yaourt -Syua'

Works a treat.

newbOnArch commented on 2017-05-11 21:19

@flamusdiu I just had trouble updating through pacaur -Syu, while validating source files openvpn-ip-lport.zip, openvpn.zip, and openvpn-strong.zip they all failed. Then I ran through yaourt -Syu --aur everything passed and now I'm updated. I believe there might be fault with pacaur -Syu when you try to update. I'm not sure but I would request you to look into it. Here is my Ghostbin link:
https://ghostbin.com/paste/exncf I have posted troubles while updating and how it just updated.

flamusdiu commented on 2017-04-30 16:31

@chmeresmoreira: Actually, I am extracting ONLY the certificates PIA uses. That line extracts the configs that I use to build which end-points PIA uses. They are not copied outside the building process. I used to copy and stop doing that a long time ago to give the options of different ports and strong encryption.

Under [configure] section, you can add "strong_encryption=true" to use the strong encryption stuff. *Note: Looks like I forgot to update the Wiki. Oops. =P

Anonymous comment on 2017-04-29 23:36

@flamusdiu

Hey, why didn't you chose the strongest and more secure config files?
In this line: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=private-internet-access-vpn#n53
you are extracting the default config files with the default security level, maybe you could add an option to ask during the installation process what security level to user wants.

Anyway, thank you for maintaining this package!

Cavsfan commented on 2017-04-16 17:43

My ISP is Spectrum, formerly Brighthouse. It seems that Charter has merged with Time Warner Cable and Bright House Networks to form Spectrum. More monopolies. :(

But, my problem is probably not related to Arch and this package because it does the exact same thing on Xubuntu and there is an installer for Debian based systems https://www.privateinternetaccess.com/installer/download_installer_linux
There is an applet in the top panel that lets you connect, etc.

It does the exact same in Xubuntu as it does in Arch: receives but, does not send email from the same ISP that works good on Windows 10. The conky also behaves the same way: no weather info when PIA is running. But, I never tried conky in Windows and have no interest it it. I have a ticket opened for Linux so, maybe the problem is on their end.

Yes, he wrote this: https://aur.archlinux.org/packages/conky-cairo/

flamusdiu commented on 2017-04-15 20:46

@Cavsfan: flagged due to the zips ... I need to get docker running to fix it. Stuck with a Win Laptop atm and away for work. ::cries::

Wait, he wrote conky-cairo?? Whoa, it's been a while but I have used that before.

It's very dam odd that your ISP doesn't work with PIA. Which ISP is it?

Cavsfan commented on 2017-04-15 15:10

@flamusdiu: I tried a bunch of different locations if that is what you meant and they all do the same: they don't work any better. How come it says this package is flagged out of date as of 2017-04-13?

Cavsfan commented on 2017-04-14 20:12

@flamusdiu: Actually all I think I've tried is Florida. I guess I should try some more and see if that works. I never thought about it.

The Conky is Conkywx from a friend who is an amazing programmer Paramvir Likhar. He writes it in perl, lua and a few other things. Here is his site: http://foreverquest.blogspot.com/

I am part of his testing group and before the next version is released (version 6.0 now) we test it for months until it is perfect. This conky has actual scrolling text. It takes a movie to show it; a picture doesn't cut it. He also wrote his own conky for Arch which in the AUR called conky-cairo. I can run 13 conkys and the CPU usage is about 15-20%.

I am currently using http://www.usnews.com/rss/news for my news but, any site that has an RSS feed can be used.

I'll try some different sites and report back. I use Thunderbird with the same setup and ISP as in my Linux distros. So, that is why I didn't get it either.
Thanks!

flamusdiu commented on 2017-04-14 18:56

@Cavsfan: that's strange. I use the same configurations that should be used on Windows. What VPN endpoints have you tried?

As for Conky: what sites?