Package Details: purple-skypeweb-git 1.7.r18.g8b29d7b-1

Git Clone URL: https://aur.archlinux.org/purple-skypeweb-git.git (read-only, click to copy)
Package Base: purple-skypeweb-git
Description: SkypeWeb Plugin for Pidgin
Upstream URL: https://github.com/EionRobb/skype4pidgin/tree/master/skypeweb
Licenses: GPL3
Conflicts: purple-skypeweb, skype4pidgin
Provides: purple-skypeweb
Submitter: deboeckj
Maintainer: arnottcr (Thaodan)
Last Packager: Thaodan
Votes: 372
Popularity: 0.001992
First Submitted: 2015-05-26 16:52 (UTC)
Last Updated: 2022-07-09 10:38 (UTC)

Latest Comments

TheChickenMan commented on 2017-09-23 19:52 (UTC)

This version DOES work with individual app passwords and two-factor authentication for skype with pidgin. I had been suffering through the "Magic T value" error with version 1.4 in the main repositories for months now. Thanks a bunch.

stativ commented on 2017-03-23 08:50 (UTC)

Two suggestions: * license should be GPL3 instead of GPLv3 * the package should not be arch=('any'), because it packages architecture-dependent library.

arnottcr commented on 2016-11-25 09:57 (UTC)

I use this with weechat+bitlbee, so I cannot speak to Pidgin version support.

GordonGR commented on 2016-11-23 18:49 (UTC)

Does this work for Pidgin 3?

cwtopel commented on 2016-07-07 15:58 (UTC)

@doblerone - Simply uninstall/reinstall this package. Your issue was fixed here: https://github.com/EionRobb/skype4pidgin/commit/72f0b003252d0c827e9fa5dcb31005ef4a51b036

doblerone commented on 2016-07-04 08:00 (UTC)

I'm getting "Failed getting Skype Token". I recently installed pidgin 2.11 and clone purple-skypeweb-git 1.1-2. I tried also a passwd change without success. Any ideas?

kiotoze commented on 2016-07-02 09:19 (UTC)

@axolotl After pidgin update to 2.11.0 the packages community/purple-skypeweb and aur/purple-skypeweb-git does not work anymore. I should remove package aur/purple-skypeweb-git and install it again to fetch new changes from git. Now it works with 2.11.0 Maybe it a good sign to increase version to allow refresh automatically to other users?

justin8 commented on 2016-05-22 22:42 (UTC)

You can have all your chat messages in the one program still like all other IM platforms, just you have a skype icon in your tray as well

treeshateorcs commented on 2016-05-21 23:41 (UTC)

so it depends on skype, it uses skype as a backend and launches skype in the background. what is the purpose of this?

shilkovsky commented on 2016-01-20 09:32 (UTC)

Hi! I have an error while installing this package. The error is as follows: -> Загрузка skype_icons_empathy.tar.xz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:00:29 --:--:-- 0 curl: (60) SSL certificate problem: self signed certificate in certificate chain More details here: http://curl.haxx.se/docs/sslcerts.html I have tried to open a link https://repo.dray.be/package-files/skype_icons_empathy.tar.xz in a chrome browser, chromium shows NET::ERR_CERT_COMMON_NAME_INVALID

deboeckj commented on 2016-01-03 18:11 (UTC)

I am disowning this since I dont want to maintain a git version while there is a versioned release now...

arnottcr commented on 2015-12-16 06:31 (UTC)

I want to build this on my armv6h, and can do so if I add armv6h to the arch variable, or change it to any. I am not sure what makes more sense, it is a compiled package, so any architecture that supports gcc should be supported, but if you prefer, I can confirm that it builds on armv6h. As well, since this is a git/development version can you add conflicts and provides variables so that it will interact sanely with my non-development package: https://aur.archlinux.org/packages/purple-skypeweb

commented on 2015-11-15 13:36 (UTC)

Finally make a 1.0 https://github.com/EionRobb/skype4pidgin/releases

seal20 commented on 2015-09-14 09:59 (UTC)

This package conflicts with skype4pidgin-git because they provide the same icons. There may be a way to be able to co install them though by checking if the icons exists or not. ==> Installing package purple-skypeweb-git with pacman -U... loading packages... resolving dependencies... looking for conflicting packages... Packages (1) purple-skypeweb-git-20150914-1 Total Installed Size: 0.18 MiB :: Proceed with installation? [Y/n] Y (1/1) checking keys in keyring [#####################################] 100% (1/1) checking package integrity [#####################################] 100% (1/1) loading package files [#####################################] 100% (1/1) checking for file conflicts [#####################################] 100% error: failed to commit transaction (conflicting files) purple-skypeweb-git: /usr/share/pixmaps/pidgin/emotes/skype/theme exists in filesystem purple-skypeweb-git: /usr/share/pixmaps/pidgin/protocols/16/skype.png exists in filesystem purple-skypeweb-git: /usr/share/pixmaps/pidgin/protocols/22/skype.png exists in filesystem purple-skypeweb-git: /usr/share/pixmaps/pidgin/protocols/48/skype.png exists in filesystem Errors occurred, no packages were upgraded. ==> WARNING: Failed to install built package(s). :: nettoyage de purple-skypeweb-git sauté

justin8 commented on 2015-07-19 07:30 (UTC)

Oops, if it isn't working in the mean time; use this until I can update it: https://repo.dray.be/package-files/skype_icons_empathy.tar.xz

justin8 commented on 2015-07-19 07:29 (UTC)

The source should have changed. When I do a git pull it has. The srcinfo didn't get updated for some reason. I'm on a work trip for a few weeks and away from my Arch boxes, so I'll hve to fix that then :(

quiq commented on 2015-07-18 19:49 (UTC)

The copy.com link has been taken down again. "Removed for violations of our terms of service"

deboeckj commented on 2015-07-09 22:08 (UTC)

Thx for infor added it as make dependency

Bonster commented on 2015-07-09 03:45 (UTC)

oh you have to install "pkg-config" package then it works now

Bonster commented on 2015-07-09 03:09 (UTC)

Dead? ==> Starting pkgver()... fatal: No names found, cannot describe anything. ==> Starting build()... make: pkg-config: Command not found make: pkg-config: Command not found gcc -Wall -I. -g -O2 -fPIC -pipe skypeweb_connection.c skypeweb_contacts.c skypeweb_login.c skypeweb_messages.c skypeweb_util.c libskypeweb.c -o libskypeweb.so -shared In file included from skypeweb_connection.h:22:0, from skypeweb_connection.c:19: libskypeweb.h:25:18: fatal error: glib.h: No such file or directory compilation terminated. In file included from skypeweb_contacts.h:22:0, from skypeweb_contacts.c:20: libskypeweb.h:25:18: fatal error: glib.h: No such file or directory compilation terminated. In file included from skypeweb_login.h:22:0, from skypeweb_login.c:19: libskypeweb.h:25:18: fatal error: glib.h: No such file or directory compilation terminated. In file included from skypeweb_messages.h:22:0, from skypeweb_messages.c:19: libskypeweb.h:25:18: fatal error: glib.h: No such file or directory compilation terminated. In file included from skypeweb_util.h:19:0, from skypeweb_util.c:19: libskypeweb.h:25:18: fatal error: glib.h: No such file or directory compilation terminated. In file included from libskypeweb.c:19:0: libskypeweb.h:25:18: fatal error: glib.h: No such file or directory compilation terminated. Makefile:42: recipe for target 'libskypeweb.so' failed make: *** [libskypeweb.so] Error 1 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build purple-skypeweb-git. ==> Restart building purple-skypeweb-git ? [y/N] ==> -------------------------------------------- ==>

ceri commented on 2015-07-04 22:32 (UTC)

Thanks, working well for me

justin8 commented on 2015-06-24 11:07 (UTC)

Sorry, I got an email from them today saying they removed a link for 'hosting malicious software' Apparently a tarball of jpgs and pngs for a linux package is malicious. I've updated it to a new link now.

buxner commented on 2015-06-24 10:09 (UTC)

The copy.com link has been taken down.

malah commented on 2015-05-28 14:45 (UTC)

Thanks for this package, I've tried it a week ago before you post it here, but at this time I've only tried to connect me with a Microsoft live/MSN account ... and it seems to only work with old Skype account :)

vorot93 commented on 2015-05-05 22:13 (UTC)

This package should depend on git, not subversion.

justin8 commented on 2015-04-01 03:25 (UTC)

Ah cool. Thanks for that. I've made skype4pidgin-git and waiting on this to be merged now.

Alien commented on 2015-03-31 15:33 (UTC)

skype4pidgin is no longer hosted on Google Code, but rather on GitHub: https://github.com/EionRobb/skype4pidgin

justin8 commented on 2015-03-29 01:10 (UTC)

Please do not mark VCS packages as out of date. by definition they can't be. If there is a problem with the package being built, make a comment on the package.

linuxJay commented on 2014-11-26 18:03 (UTC)

ok thanks

justin8 commented on 2014-11-25 23:39 (UTC)

It might be worth looking upstream for possible issues; the packaging seems fine, but I use neither skype or pidgin anymore sorry.

linuxJay commented on 2014-11-24 00:32 (UTC)

hmm doesn't seem to work for me anymore

roadnottaken commented on 2014-10-22 03:44 (UTC)

Works perfectly. Thanks!

justin8 commented on 2014-10-21 22:01 (UTC)

@roadnottaken: Give that a go. I added a prepare step to copy the skype heading and duplicate it as 'Skype (D-Bus)'.

justin8 commented on 2014-10-21 05:10 (UTC)

Hmm ok. I'll take a look when I get home from work this afternoon.

roadnottaken commented on 2014-10-21 04:59 (UTC)

Thanks for the update. skype4pidgin is a nice package and I'm glad to see it's alive and well. My only outstanding annoyance with it is that the skype icons aren't carried over to the skype-dbus theme. It looks like creating a [Skype (D-Bus)] heading in the theme file which duplicates all the definitions under the [Skype] heading should do the trick.

justin8 commented on 2014-10-21 03:57 (UTC)

I'm going to be requesting this gets merged in to the SVN version anyway, since there isn't really a seperate stable version for skype4pidgin; the latest pre-build .so files on the website even are just the latest committed build at pretty much all times, so maintaining 2 of them is a bit useless.

bezirg commented on 2014-10-20 10:09 (UTC)

Pidgin started recently to complain with: /usr/lib32/skype/skype: unrecognized option '--enable-dbus' /usr/lib32/skype/skype: unrecognized option '--use-session-dbus' After some seconds, pidgin exits and skype remains on the foreground. I switched from 653 to skype4pidgin-svn (664) and problem is fixed.

justin8 commented on 2014-10-17 12:21 (UTC)

This is an svn package, rebuilding it will use the latest revision and update the version when you run makepkg.

Alien commented on 2014-10-17 11:00 (UTC)

You should update the used revision in PKGBUILD to be 665, as it fixes a nasty Pidgin crash.

justin8 commented on 2014-09-21 06:36 (UTC)

@xlaits. Please try again now.

xlaits commented on 2014-09-20 21:41 (UTC)

I cannot seem to download skype_icons_empathy.tar.xz. ==> Making package: skype4pidgin-svn 664-1 (Sat Sep 20 17:35:15 EDT 2014) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Updating skype4pidgin-svn svn repo... Updating '.': At revision 664. -> Found Makefile.patch -> Downloading skype_icons_empathy.tar.xz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (22) The requested URL returned error: 404 Not Found ==> ERROR: Failure while downloading skype_icons_empathy.tar.xz Aborting...

justin8 commented on 2014-06-25 00:28 (UTC)

@psamim: I can't reproduce that issue you're having. Can you upload a copy of everything you're doing when building it?

psamim commented on 2014-06-24 09:41 (UTC)

I get the following: Summary of conflicts: Skipped paths: 1 can't find file to patch at input line 3 Perhaps you used the wrong -p or --strip option? The text leading up to this was: -------------------------- |--- Makefile.orig 2010-09-07 20:56:26.000000000 +0200 |+++ Makefile 2010-09-07 20:58:10.000000000 +0200 --------------------------

brcha commented on 2014-04-25 12:55 (UTC)

I've adopted the package and will update it if updating is needed. Also, I've removed empathy from dependencies since it is not a dependency. Instead I've added empathy and kde-telepathy as optional dependencies. Obviously, you do have to get some telepathy client so that this package would have any use, but there is no point in forcing people to install half of Gnome if they are using KDE.

mirandir commented on 2013-12-25 08:46 (UTC)

I don't use Skype anymore, so feel free to adopt this package.

mirandir commented on 2013-12-25 08:45 (UTC)

I don't use Skype anymore, so feel free to adopt this package.

ilpianista commented on 2013-11-28 16:46 (UTC)

Please put $srcdir and $pkgdir between double apixes

roadnottaken commented on 2013-11-22 19:39 (UTC)

Perfect, thanks, and that sed script is quite a bit cleaner than what I'd hacked together for the purpose.

tredaelli commented on 2013-11-21 11:50 (UTC)

@roadnottaken thanks, is it better now?

roadnottaken commented on 2013-10-12 21:23 (UTC)

I suggest using the following PKGBUILD, which installs default+skype as an additional theme, modified to work with both the X11 and DBUS variants of the skype protocol. https://dl.dropboxusercontent.com/s/3npr4qph94tekys/PKGBUILD

roadnottaken commented on 2013-09-09 20:46 (UTC)

The 'theme' file in the svn repository can coexist with the default theme. Please consider updating the PKGBUILD to install this into, e.g., /usr/share/pixmaps/pidgin/emotes/skype/ .

roadnottaken commented on 2013-08-21 05:16 (UTC)

The 'theme' file in the svn repository can coexist with the default theme. Please consider updating the PKGBUILD to install this to, e.g., /usr/share/pixmaps/pidgin/emotes/skype/ .

mirandir commented on 2013-06-24 06:43 (UTC)

Updated PKGBUILD and icons for Empathy 3.8.

mladoux commented on 2013-06-22 18:38 (UTC)

please update PKGBUILD with a package() function. Your current format is deprecated, and may not work for much longer.

shad0w73 commented on 2013-04-27 12:55 (UTC)

Fixed by using an alternative download mirror.

soupault commented on 2013-04-27 08:33 (UTC)

sources can't be downloaded

commented on 2012-12-20 18:55 (UTC)

It may sound ironic but, empathy is not needed, I use Kde IM Contacts as telepathy client and I was able to compile and install this plugin by removing empathy from the dependency list.

mirandir commented on 2012-12-19 08:25 (UTC)

@Nicoco : seems to work for me, but you are right, messages are still marked as unread in Skype.

Nicoco commented on 2012-12-12 00:39 (UTC)

Am I the only one experiencing trouble with this plugin ? Some of the messages aren't "sent" to empathy and I have to check skype window once in a while to be sure nobody tried to contact me. Also, until I reply to a message, it is marked as unread in skype. Am I doing something wrong ?

mirandir commented on 2012-12-11 21:33 (UTC)

Updated. Thanks !

simonluijk commented on 2012-12-11 20:11 (UTC)

Just installed at revision 646, had to remove patch to compile package. Everything seems good so far.

mirandir commented on 2012-06-27 17:23 (UTC)

Hello gesti. You are right, updated.

commented on 2012-06-27 14:18 (UTC)

Hello mirandir! Thanks for the package, just like you wrote: it did resolve the connection problem. The only hick-up was that it also depends on "subversion" CVS.

commented on 2012-05-30 18:05 (UTC)

I'm also getting a segfault.

mirandir commented on 2012-04-20 21:36 (UTC)

This package solves the problem of https://aur.archlinux.org/packages.php?ID=48677 (based on skype4pidgin-dbus-svn, adapted for Empathy)

mirandir commented on 2012-04-20 21:33 (UTC)

Ok, recompiling and using the svn version solves the problem. You have to use my new package skype4empathy-svn : https://aur.archlinux.org/packages.php?ID=58662

mirandir commented on 2012-04-10 18:18 (UTC)

I have the same problem. Don't know why, but it seems related to dbus.

Nicoco commented on 2012-04-10 09:29 (UTC)

While I don't think there were any skype or empathy updates recently, this plugin stopped working for me. Anyone else experiencing the same problem ?

donvla commented on 2012-03-25 17:20 (UTC)

Site seems to be offline. Use skype4pidgin-svn instead.

Synthead commented on 2011-12-12 18:58 (UTC)

Please add 'subversion' to the $makedepends array.

mirandir commented on 2011-10-17 22:39 (UTC)

tredaelli : probably, but my package have some empathy icons specific stuff.

tredaelli commented on 2011-10-17 11:32 (UTC)

That should work with Pidgin and Empathy => https://aur.archlinux.org/packages.php?ID=53217

tredaelli commented on 2011-10-17 11:31 (UTC)

If it crashes just use https://aur.archlinux.org/packages.php?ID=53217 and select Skype (D-Bus) as account-type in Pidgin

tredaelli commented on 2011-10-17 11:31 (UTC)

If it crashes just use https://aur.archlinux.org/packages.php?ID=53217 and select Skype (D-Bus) as account-type in Pidgin

mirandir commented on 2011-09-17 12:46 (UTC)

eion.robbmob.com is back.

mirandir commented on 2011-09-12 11:46 (UTC)

Nebulosa : I updated the PKGBUILD with an alternative location for skype4pidgin.deb.

Nebulosa commented on 2011-09-12 10:50 (UTC)

Does anybody have skype4pidgin.deb? eion.robbmob.com still not working.

mirandir commented on 2011-08-15 16:01 (UTC)

You are right, but this package installs some empathy-specific icons. A better solution would be to create a new package ("skype4telepathy-kde"). I don't use KDE, so i can't test this, feel free to create it ;). Alternatively, i can create a "generic" package "skype4telepathy", which would be in conflict with skype4empathy.

mxr commented on 2011-08-14 15:29 (UTC)

This should not depend on empathy. It is possible to use this together with kde's telepathy client. Installing empathy to gether with kde is not necessary.

kellerman commented on 2011-07-31 00:07 (UTC)

Actually I can confirm that this works for me now. Using skype from official repos with 32bit libs on Arch x86_64!

Shanto commented on 2011-04-07 19:42 (UTC)

Latest is dated 7 Apr 2011

Shanto commented on 2011-04-07 19:06 (UTC)

Checksums need update.

donvla commented on 2011-03-10 10:06 (UTC)

Go on and install "skype".

commented on 2011-03-10 08:30 (UTC)

==> Building and installing package ==> Install or build missing dependencies for skype4pidgin: Password: error: 'skype': could not find or read package ==> WARNING: Dependencies have been installed before the failure ==> Restart building skype4pidgin ? [y/N] ==> ------------------------------------- ==>

donvla commented on 2010-09-24 09:32 (UTC)

Perhaps you always ran "makepkg -r".

commented on 2010-09-24 09:04 (UTC)

Yup, that fixed it. I do find it odd, however, that I never had to have subversion installed before.

donvla commented on 2010-09-24 06:38 (UTC)

Hehe. You need "subversion" as it is obviously a svn package. I'll add it as "makedepends" next release.

commented on 2010-09-24 05:55 (UTC)

I get an error after the package build starts: ==> Starting build()... /tmp/yaourt-tmp-grant/aur-skype4pidgin-svn/./PKGBUILD: line 26: svn: command not found Aborting...

donvla commented on 2010-09-11 05:57 (UTC)

Hmm, no idea. I also use the svn version. The best way is to write the dev a mail.

anpieber commented on 2010-09-08 07:14 (UTC)

thank you very much :)

donvla commented on 2010-09-07 19:00 (UTC)

Fixed.

anpieber commented on 2010-09-07 18:27 (UTC)

same here :(

Liquen commented on 2010-08-26 17:11 (UTC)

Last update 26 Aug 2010

rider commented on 2010-08-09 09:44 (UTC)

Hi, I get following error : ... A skype4pidgin-read-only/po/skype4pidgin.pot A skype4pidgin-read-only/po/nb.po U skype4pidgin-read-only Checked out revision 589. ==> SVN checkout done or server timeout ==> Starting make... patching file Makefile Hunk #2 succeeded at 61 with fuzz 2 (offset 1 line). Hunk #3 FAILED at 78. 1 out of 3 hunks FAILED -- saving rejects to file Makefile.rej Aborting... ==> ERROR: Makepkg was unable to build skype4pidgin-svn. ==> Restart building skype4pidgin-svn ? [y/N] ==> ----------------------------------------- ==> On Arch64 and skype_32 allready installed. Janez

bklive commented on 2010-07-02 19:08 (UTC)

I tried to build this today and it said that the two libskype_dbus*.so files failed md5sum checks. So I updated my own PKGBUILD and added the correct md5sum (and just removed the x86_64 handling) and it works now. Probably need to update the PKGBUILD.

lpapp commented on 2010-06-20 13:13 (UTC)

Sorry, but this package is up-to-date, please use out-ot-date button in case if it's really out-of-date, check it more times, please!

kozaki commented on 2010-05-16 13:35 (UTC)

Thanks, well i just wanted to point out that has to edit PKGBUILD from: depends=('pidgin' 'skype') to: depends=('pidgin' 'bin32-skype') -- to compile skype4pidgin-svn on Arch x86_64. Not a big deal though ;) And pidgin now show an impressive choice of 16 differents IM to choose from!

donvla commented on 2010-05-16 11:52 (UTC)

Hello, "bin32-skype" provides skype. So this dep is correct.

kozaki commented on 2010-05-16 08:38 (UTC)

Hi, on a x86_64 system, i had to edit : the 'skype' dependancy to 'bin32-skype' as there was no 'skype' package.

commented on 2010-05-10 13:32 (UTC)

Well, I compiled it myself from the source (64bit) and now it's working.

commented on 2010-05-10 13:20 (UTC)

Except that it gets a segmentation fault now. And the dbus md5sums are out of date.

commented on 2010-05-10 13:14 (UTC)

Well, you can fire up a skype session running in XVFB and login with the --pipelogin command. Maybe not the most practical solution though. Anyway I've been scratching my head all day on how to get skype for finch, without noticing that this package exist. Thanks djszapi!

anpieber commented on 2010-04-06 09:05 (UTC)

lol, ok you're right :) svn version works!

toffyrn commented on 2010-04-06 08:52 (UTC)

for me it does not work well on both i686 and x86_64, however skype4pidgin-svn does... :)

anpieber commented on 2010-04-06 07:20 (UTC)

does this package work for anyone using a 64bit arch with the bin32-skype package from aur? For any reasons my pigdin tries endlessly to connect with skype, but never get it. Additionally, no error message is shown :(

lpapp commented on 2010-03-25 16:41 (UTC)

Please let me decide what I'd like to use ... I've talked about it with the author of this plugin, and he liked it and my familiars too, Welcome Troll, but I'd not like to feed you ... :-) Otherwise, it's very good to run skype in the background, and you can speak with your friends in written form via finch.

donvla commented on 2010-03-25 16:21 (UTC)

The problem with this package is that skype is still needed. As finch is a console app it doesn't make much sense to use this plugin, because skype as a X11 app has to be running...