Package Details: qutebrowser-git 3.0.0.r0.g4a031f4ea-1

Git Clone URL: (read-only, click to copy)
Package Base: qutebrowser-git
Description: A keyboard-driven, vim-like browser based on PyQt
Upstream URL:
Keywords: browser web webkit
Licenses: GPL
Conflicts: qutebrowser
Provides: qutebrowser
Submitter: The-Compiler
Maintainer: The-Compiler
Last Packager: The-Compiler
Votes: 90
Popularity: 0.38
First Submitted: 2014-11-11 21:47 (UTC)
Last Updated: 2023-08-18 15:20 (UTC)

Dependencies (19)

Required by (1)

Sources (1)

Latest Comments

1 2 3 4 Next › Last »

MeisBarry commented on 2023-07-24 14:58 (UTC) (edited on 2023-07-24 14:58 (UTC) by MeisBarry)

Today while updating I got this error:

==> Starting build()...
python: can't open file '/home/barry/.cache/yay/qutebrowser-git/src/qutebrowser/scripts/': [Errno 2] No such file or directory

In case anyone else encounters this, the solution is to wipe your local git repo and build from a fresh clone. For yay, that means running yay -S qutebrowser-git and selecting [A]ll when asked about cleanBuild.

WorMzy commented on 2023-07-23 21:45 (UTC) (edited on 2023-07-23 22:30 (UTC) by WorMzy)

I can't speak for yay, but if you use a SRCDEST, then the git config will be out-of-date since the master branch was retired in favour of main. Manifests as:

==> Extracting sources...
  -> Creating working copy of qutebrowser git repo...
Cloning into 'qutebrowser'...
warning: remote HEAD refers to nonexistent ref, unable to checkout

Simple fix:

sed -i 's:master:main:' "$SRCDEST/qutebrowser/HEAD"

The-Compiler commented on 2023-07-23 20:21 (UTC)

@raffaem Works fine for me with yay. Given the "Unable to read current working directory: No such file or directory", this sounds like an issue on your system.

raffaem commented on 2023-07-23 19:46 (UTC) (edited on 2023-07-23 19:46 (UTC) by raffaem)

It doesn't build anymore:

-> devel check for package failed:
'/usr/bin/git ls-remote HEAD' encountered an error:
fatal: Unable to read current working directory: No such file or directory

I have tried to delete the cache and re-build, same error message.

I'm using yay.

justinesmithies commented on 2023-05-03 18:43 (UTC) (edited on 2023-05-03 18:55 (UTC) by justinesmithies)

[ RESOLVED ] To fix delete the qutebrowser-git folder from your Paru or Yay .cache folder and reinstall qutebrowser-git after updating all Python packages.

Qutebrowser no longer runs after latest Arch Linux Python 3.11 updates. I get the following error:

Traceback (most recent call last):
  File "/usr/lib/python3.11/importlib/metadata/", line 563, in from_name
    return next(

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/qutebrowser", line 33, in <module>
    sys.exit(load_entry_point('qutebrowser==2.5.4', 'gui_scripts', 'qutebrowser')())
  File "/usr/bin/qutebrowser", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.11/importlib/metadata/", line 981, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.11/importlib/metadata/", line 565, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for qutebrowser

essa commented on 2023-04-28 22:25 (UTC)

holy mother this browser rocks !!!

The-Compiler commented on 2021-02-25 15:35 (UTC) (edited on 2021-02-25 15:35 (UTC) by The-Compiler)

@dbeattyspace FWIW it looks like you did "sudo pip install PyQt5" at some point - this is a really bad idea and can mess up things, as you've seen :)

Instead, consider using a virtualenv (or in the case of qutebrowser, it's script) if you need to install a package which isn't in the Arch repositories or AUR.

dbeattyspace commented on 2021-02-25 15:18 (UTC)

No packages own that directory on my system, but I figured out a workaround. I removed that directory sudo rm -rf /usr/lib/python3.9/site-packages/PyQt5 and then re-installed python-pyqt5 and now everything is working normally.

WorMzy commented on 2021-02-25 15:04 (UTC)

No issues here. What package (if any) owns /usr/lib/python3.9/site-packages/PyQt5/Qt/ on your system? It's not provided by any official package:

$ pacman -F /usr/lib/python3.9/site-packages/PyQt5/Qt/; echo $?

dbeattyspace commented on 2021-02-25 14:46 (UTC)

I'm unable to launch this morning getting the following error message. I've tried downgrading python-pyqt5, recompiling the package, and using the non-git version in the community repo but none of those has fixed the issue. Anyone having a similar error that has found a fix?

/usr/bin/python3: symbol lookup error: /usr/lib/python3.9/site-packages/PyQt5/Qt/plugins/platforms/../../lib/ undefined symbol: _ZdlPvm, version Qt_5