Package Details: qutebrowser-git 2.0.0.r2.gd3b8b525b-1

Git Clone URL: https://aur.archlinux.org/qutebrowser-git.git (read-only, click to copy)
Package Base: qutebrowser-git
Description: A keyboard-driven, vim-like browser based on PyQt5
Upstream URL: https://www.qutebrowser.org/
Keywords: browser web webkit
Licenses: GPL
Conflicts: qutebrowser
Provides: qutebrowser
Submitter: The-Compiler
Maintainer: The-Compiler
Last Packager: The-Compiler
Votes: 81
Popularity: 0.55
First Submitted: 2014-11-11 21:47 (UTC)
Last Updated: 2021-01-28 08:41 (UTC)

Dependencies (18)

Required by (1)

Sources (1)

Latest Comments

The-Compiler commented on 2021-02-25 15:35 (UTC) (edited on 2021-02-25 15:35 (UTC) by The-Compiler)

@dbeattyspace FWIW it looks like you did "sudo pip install PyQt5" at some point - this is a really bad idea and can mess up things, as you've seen :)

Instead, consider using a virtualenv (or in the case of qutebrowser, it's mkvenv.py script) if you need to install a package which isn't in the Arch repositories or AUR.

dbeattyspace commented on 2021-02-25 15:18 (UTC)

No packages own that directory on my system, but I figured out a workaround. I removed that directory sudo rm -rf /usr/lib/python3.9/site-packages/PyQt5 and then re-installed python-pyqt5 and now everything is working normally.

WorMzy commented on 2021-02-25 15:04 (UTC)

No issues here. What package (if any) owns /usr/lib/python3.9/site-packages/PyQt5/Qt/ on your system? It's not provided by any official package:

$ pacman -F /usr/lib/python3.9/site-packages/PyQt5/Qt/; echo $?
1

dbeattyspace commented on 2021-02-25 14:46 (UTC)

I'm unable to launch this morning getting the following error message. I've tried downgrading python-pyqt5, recompiling the package, and using the non-git version in the community repo but none of those has fixed the issue. Anyone having a similar error that has found a fix?

/usr/bin/python3: symbol lookup error: /usr/lib/python3.9/site-packages/PyQt5/Qt/plugins/platforms/../../lib/libQt5DBus.so.5: undefined symbol: _ZdlPvm, version Qt_5

The-Compiler commented on 2020-12-19 12:18 (UTC)

@andys8 The importlib_resources dependency is not needed with Python 3.9, which is what Archlinux ships with - given that the AUR is targeted at Archlinux (rather than Manjaro), you will need to install that dependency manually, if Manjaro didn't upgrade to Python 3.9 yet (something Archlinux did almost 6 weeks ago).

andys8 commented on 2020-12-19 12:03 (UTC) (edited on 2020-12-19 12:31 (UTC) by andys8)

The installation currently fails with "The 'importlib_resources>=1.1.0' distribution was not found and is required by qutebrowser".

See https://github.com/qutebrowser/qutebrowser/issues/5968

Update: Thanks @the-compiler, installed 'python-importlib_resources' manually and it'll work.

The-Compiler commented on 2019-02-15 17:03 (UTC)

Thanks everyone for your patience, and sorry for missing WorMzy's comment! I updated the PKGBUILD based on the [community] one, so it now has the new python-pyqtwebengine dependency, and uses qutebrowser's Makefile (which installs the scripts).

habarnam commented on 2019-02-13 08:11 (UTC)

Since Qt5.12 the QtWebEngine python bindings have been moved to their own package. Probably this should be reflected in the dependency list: python-pyqtwebengine

dojero commented on 2019-02-01 05:24 (UTC)

No response to WorMzy, but I second that request. dictcli.py is necessary to have spellchecker working. The workaround was to download the Arch package, extract it, and then pull dictcli.py from there. I don't think that should be necessary.

WorMzy commented on 2018-07-07 12:17 (UTC)

Please could $srcdir/qutebrowser/scripts/* be added to the package, or have these been omitted deliberately? (particularly interested in dictcli.py)

The-Compiler commented on 2017-09-18 08:16 (UTC)

@jasonwryan Looks like you don't have the newest PKGBUILD.

jasonwryan commented on 2017-09-18 07:18 (UTC)

The new desktop location fails for me: Installing qutebrowser script to /home/jason/Build/qutebrowser-git/pkg/qutebrowser-git/usr/bin install: cannot stat 'qutebrowser.desktop': No such file or directory ==> ERROR: A failure occurred in package(). Aborting... Deleting those lines from the PKGBUILD allows a successful build.

The-Compiler commented on 2017-07-03 04:44 (UTC)

@joemaro QtWebEngine will become the default backend with v1.0 somewhen later this year, at that point I agree it's a hard dependency. Before that, it's not, just like qt5-webengine isn't. Where do you see "you recommend the people to use the webengine backend on the startpage of the browser and call the old engine "legacy""? I recommend people to not use a legacy QtWebKit, but there's also a newer QtWebKit, and Archlinux has packaged that as qt5-webkit since recently.

joemaro commented on 2017-07-02 16:42 (UTC) (edited on 2017-07-02 16:42 (UTC) by joemaro)

python-opengl is imo a dependency: you recommend the people to use the webengine backend on the startpage of the browser and call the old engine "legacy" and then it won't run with webengine without having pyopengl installed.

The-Compiler commented on 2017-06-24 12:02 (UTC)

python-opengl is already listed as an optional dependency, just like qt5-webengine is.

cee commented on 2017-06-21 20:07 (UTC) (edited on 2017-06-21 20:09 (UTC) by cee)

qutebrowser did not run because of missing python-opengl. What speaks against ading `python-opengl` as a dependency?

mckean commented on 2017-06-21 12:20 (UTC)

I had an issue with pyopengl after the update and had to install it via pip. That doesn't seem entierely right, but it's working...

The-Compiler commented on 2017-03-15 19:31 (UTC)

buttcake: No - it's not required, and the scenario is too uncommon to even add it as an optional dependency.

buttcake commented on 2017-03-15 19:29 (UTC)

Shouldn't this require python-opengl as of https://github.com/qutebrowser/qutebrowser/commit/85fff35eefcd8d8855a77939a303afd702e3ed5b ?

The-Compiler commented on 2017-03-07 07:00 (UTC)

Sorry this took so long - but the repo URL is now up-to-date (not that it'd make any difference :P), the pkgver check for qt5-webkit is removed, and userscripts are installed so that ":spawn -u" works for the ones in the repo. As for the pkgver, I want to wait until v0.10.1 so I can test how to handle the tags correctly, see https://github.com/qutebrowser/qutebrowser/issues/2411

hero commented on 2017-02-17 07:43 (UTC)

I second lucc's request to change the pkgver(). From https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git you can see, that it is recommended to use the following for packages with tags: pkgver() { cd "$pkgname" # cutting off 'v' prefix that presents in the git tag git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' } This provides something in the likes of 0.9.0.r277.g79d22f250 I have not tested, if it demands to increment the pkgrel.

lucc commented on 2017-02-07 09:06 (UTC)

Could you use "git describe" in pkgver(). It has the advantage to include tag names into the output and hence the version number of aur/qutebrowser-git would better compare to the one of commuinty/qutebrowser. For comparison, I get these kinds of version strings from other packages (pacman -Q|grep -e '-git '): afew-git 1:0.242.b19a88f-1 i3pystatus-git 3.35.r179.g82555cb-1 mblaze-git r486.113445d-1 qutebrowser-git r11145.e487fe441-1 texlive-localmanager-git 0.5.1.r0.g6befd1e-1 vimpager-git 2.06.r337.ga7d18ce-1 zsh-history-substring-search-git 1:117.aae3388-1 It also seems that you would not even have to update (use) the epoch of the package as pacsort is happy to consider the new format I imagine a newer version. I tried this by updating the pkgver() like this (and some other variants): pkgver() { cd "$srcdir/qutebrowser" local ver=$(git describe) ver=${ver#v} ver=${ver/-/.r} ver=${ver/-g/.} printf %s "$ver" } then executed makepkg and finally ask pacsort what it considers the newest version: $ ls qute*xz|pacsort qutebrowser-git-r11138.52e386536-1-any.pkg.tar.xz qutebrowser-git-r11145.e487fe441-1-any.pkg.tar.xz qutebrowser-git-0.9.0.r183e487fe441-1-any.pkg.tar.xz qutebrowser-git-0.9.0.r183.e487fe441-1-any.pkg.tar.xz qutebrowser-git-0.9.0.183.ge487fe441-1-any.pkg.tar.xz (Please note that the 0.9.0 is due to issue #2284.)

Ambrevar commented on 2017-02-06 12:29 (UTC)

Currently it is not possible to use qutebrowser with the qt5-webkit-ng package because of the versioned dependency of qt5-webkit, forcing users to use the old insecure qt5-webkit package. Please remove the version from the dependency: qt5-webkit provides "qt5-webkit" as well.

shioyama commented on 2017-02-04 23:51 (UTC)

Please switch to the new official repository: https://github.com/qutebrowser/qutebrowser

lucc commented on 2017-02-02 09:47 (UTC)

Could you also install some things from the misc folder? Especially the userscripts, maybe to /usr/share/qutebrowser/userscripts. And maybe also the cheatsheet to some docs folder. I don't know if any of the other files would be interesting.

The-Compiler commented on 2016-06-07 07:31 (UTC)

@ainola Thanks for the heads-up, done!

ainola commented on 2016-06-07 03:38 (UTC)

Hi, The-Compiler! Pacman now automatically performs post-install hooks so you can safely remove the .install file entirely.