Package Details: qutebrowser-git 2.0.0.r2.gd3b8b525b-1

Git Clone URL: https://aur.archlinux.org/qutebrowser-git.git (read-only, click to copy)
Package Base: qutebrowser-git
Description: A keyboard-driven, vim-like browser based on PyQt5
Upstream URL: https://www.qutebrowser.org/
Keywords: browser web webkit
Licenses: GPL
Conflicts: qutebrowser
Provides: qutebrowser
Submitter: The-Compiler
Maintainer: The-Compiler
Last Packager: The-Compiler
Votes: 82
Popularity: 0.92
First Submitted: 2014-11-11 21:47
Last Updated: 2021-01-28 08:41

Dependencies (18)

Required by (1)

Sources (1)

Latest Comments

1 2 3 Next › Last »

The-Compiler commented on 2021-02-25 15:35

@dbeattyspace FWIW it looks like you did "sudo pip install PyQt5" at some point - this is a really bad idea and can mess up things, as you've seen :)

Instead, consider using a virtualenv (or in the case of qutebrowser, it's mkvenv.py script) if you need to install a package which isn't in the Arch repositories or AUR.

dbeattyspace commented on 2021-02-25 15:18

No packages own that directory on my system, but I figured out a workaround. I removed that directory sudo rm -rf /usr/lib/python3.9/site-packages/PyQt5 and then re-installed python-pyqt5 and now everything is working normally.

WorMzy commented on 2021-02-25 15:04

No issues here. What package (if any) owns /usr/lib/python3.9/site-packages/PyQt5/Qt/ on your system? It's not provided by any official package:

$ pacman -F /usr/lib/python3.9/site-packages/PyQt5/Qt/; echo $?
1

dbeattyspace commented on 2021-02-25 14:46

I'm unable to launch this morning getting the following error message. I've tried downgrading python-pyqt5, recompiling the package, and using the non-git version in the community repo but none of those has fixed the issue. Anyone having a similar error that has found a fix?

/usr/bin/python3: symbol lookup error: /usr/lib/python3.9/site-packages/PyQt5/Qt/plugins/platforms/../../lib/libQt5DBus.so.5: undefined symbol: _ZdlPvm, version Qt_5

The-Compiler commented on 2020-12-19 12:18

@andys8 The importlib_resources dependency is not needed with Python 3.9, which is what Archlinux ships with - given that the AUR is targeted at Archlinux (rather than Manjaro), you will need to install that dependency manually, if Manjaro didn't upgrade to Python 3.9 yet (something Archlinux did almost 6 weeks ago).

andys8 commented on 2020-12-19 12:03

The installation currently fails with "The 'importlib_resources>=1.1.0' distribution was not found and is required by qutebrowser".

See https://github.com/qutebrowser/qutebrowser/issues/5968

Update: Thanks @the-compiler, installed 'python-importlib_resources' manually and it'll work.

The-Compiler commented on 2019-02-15 17:03

Thanks everyone for your patience, and sorry for missing WorMzy's comment! I updated the PKGBUILD based on the [community] one, so it now has the new python-pyqtwebengine dependency, and uses qutebrowser's Makefile (which installs the scripts).

habarnam commented on 2019-02-13 08:11

Since Qt5.12 the QtWebEngine python bindings have been moved to their own package. Probably this should be reflected in the dependency list: python-pyqtwebengine

dojero commented on 2019-02-01 05:24

No response to WorMzy, but I second that request. dictcli.py is necessary to have spellchecker working. The workaround was to download the Arch package, extract it, and then pull dictcli.py from there. I don't think that should be necessary.

WorMzy commented on 2018-07-07 12:17

Please could $srcdir/qutebrowser/scripts/* be added to the package, or have these been omitted deliberately? (particularly interested in dictcli.py)