Package Details: relion-git r124.ce6420a-1

Git Clone URL: https://aur.archlinux.org/relion-git.git (read-only)
Package Base: relion-git
Description: REgularised LIkelihood OptimisatioN: employs an empirical Bayesian approach to refinement of 3D reconstructions or 2D class averages in electron cryo-microscopy
Upstream URL: https://github.com/3dem/relion
Licenses: GPL
Conflicts: relion, relion-git
Provides: relion-git
Submitter: joshinsilico
Maintainer: joshinsilico (jrdemasi)
Last Packager: joshinsilico
Votes: 0
Popularity: 0.000000
First Submitted: 2017-03-19 11:56
Last Updated: 2018-03-01 00:49

Latest Comments

jrdemasi commented on 2018-03-01 03:40

@joshinsilico - not to be a downer, but I still don't think this will work because gcc-7 doesn't actually work on Arch with the current CUDA drivers/package. If you manually specify gcc-6 in the way you had 5, and include gcc-6 as a makedep, it should be good.

joshinsilico commented on 2018-03-01 00:51

@jrdemasi Thank you for letting me know. I haven't used relion on arch linux in a while. The older version of the program only compiled using gcc5 so I introduced a workaround. I've updated the PKGBUILD.

jrdemasi commented on 2018-02-28 23:09

I can confirm that simply switching to gcc6 fixes the build process here (on a system that doesn't already have a working version of gcc5 from before it was broken).

jrdemasi commented on 2018-02-19 18:39

Is there a great reason you're building this with gcc5? I have successfully built this on several systems using gcc-6.x and 7.x, though not specifically on Arch. I would be happy to help test anyway I can, but it seems like gcc5 and some of its deps from the AUR have been gradually declining in terms of usability. (gcc5 does not build right now, for example, so on a new system I am unable to install relion-git as it's currently packaged). Thoughts? Can I be helpful in getting this bumped up to a newer version of gcc and such?