Package Details: cuda11.1 11.1.1-3

Git Clone URL: https://aur.archlinux.org/cuda11.1.git (read-only, click to copy)
Package Base: cuda11.1
Description: NVIDIA's GPU programming toolkit (version 11.1)
Upstream URL: https://developer.nvidia.com/cuda-zone
Licenses: custom:NVIDIA
Conflicts: cuda
Provides: cuda, cuda-sdk, cuda-toolkit
Replaces: cuda-sdk, cuda-static, cuda-toolkit
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 3
Popularity: 0.038780
First Submitted: 2021-02-06 23:38 (UTC)
Last Updated: 2023-06-20 02:36 (UTC)

Required by (388)

Sources (32)

Latest Comments

dbermond commented on 2023-12-01 16:09 (UTC)

@C0rn3j The AUR package cuda-11.1 is not pre-existant in relation to this one, as the package here was submitted firstly. The other AUR cuda packages have a wrong/non-compliant naming, as the convention for versioned packages in the official repositories is '<pkgname><version>', instead of '<pkgname>-<version>' (no hyphen between pkgname and the version). You can take a look, for example, in the gcc package: the current versioned package is gcc12, and not gcc-12. There are many other examples of this, like ffmpeg4.4, clang15, llvm15, and so on. Even in the cases where there is a major group of versioned packages, there is still no hyphen between the major name and the major version, like qt5-base and jdk11-openjdk. So, no action is required here in this package, since the versioned cuda 11.1 package that was firstly submitted is this one, and it conforms to the official repositories versioned packages naming standards.

C0rn3j commented on 2023-12-01 12:02 (UTC) (edited on 2023-12-01 12:04 (UTC) by C0rn3j)

What is the point of duplicating the pre-existing https://aur.archlinux.org/packages/cuda-11.1 ?

I see your package was first, wouldn't it be better to contact the existing maintainer of cuda-11.1 and merge the two packages together to be consistently named with other cuda versions in the AUR?

gilcu3 commented on 2023-11-06 16:07 (UTC)

@dbermond Got it, thank you for the lengthy explanation. I guess I will go on and install gcc10 hoping it won't break anything.

dbermond commented on 2023-11-06 15:59 (UTC)

@gilcu3 The package will build if we specify the latest version of gcc from the official repositories, but that's not the question. Each version of the cuda toolkit supports up until a specific version of gcc, and does not support later versions. When trying to compile cuda code with an unsupported gcc version, the compilation with fail. The gcc supported by cuda 11.1.1 is gcc 10, and this must be used. You can check it at the cuda 11.1.1 release notes, section 2.4.1 (CUDA Compilers). We cannot exchange the gcc version for a later one due the explained reason. Even the latest cuda usually does not support the latest gcc (for example, the current cuda 12.3.0 in the official repositories needs gcc 12, while latest gcc is at 13).

gilcu3 commented on 2023-11-04 11:10 (UTC)

@dbermond For the package builds correctly using gcc from the standard repo. Could you confirm this is not the case for you? If this is the case for everyone I think we should avoid adding gcc10 as a dependency.

dbermond commented on 2023-06-20 02:37 (UTC)

@raine Package updated, should be fine now.

raine commented on 2023-05-05 13:56 (UTC) (edited on 2023-05-05 13:58 (UTC) by raine)

After force installing with yay -S --mflags --skipinteg cuda-11.1, I get errors

RuntimeError: The current installed version of g++ (13.1.1) is greater than the maximum required version by CUDA 11.1. Please make sure to use an adequate version of g++ (>=5.0.0, <11.0).

seems like this package should install an older version of gcc and change /opt/cuda-11.1/bin/g++ and /opt/cuda-11.1/bin/gcc to appropriate versions, as done in for example in package which installs gcc8 and runs

ln -s /usr/bin/gcc-8 "${install_prefix}/bin/gcc" ln -s /usr/bin/g++-8 "${install_prefix}/bin/g++"

raine commented on 2023-05-05 13:47 (UTC)

Build fails due to failing checksums:

==> Validating source files with sha512sums... cuda_11.1.1_455.32.00_linux.run ... Passed cuda-findgllib_mk.diff ... Passed accinj64.pc ... Passed cublas.pc ... Passed cuda.pc ... Passed cudart.pc ... Passed cufft.pc ... Passed cufftw.pc ... Passed cuinj64.pc ... Passed curand.pc ... Passed cusolver.pc ... Passed cusparse.pc ... Passed nppc.pc ... Passed nppi.pc ... FAILED nppial.pc ... FAILED nppicc.pc ... FAILED nppicom.pc ... FAILED nppidei.pc ... FAILED nppif.pc ... FAILED nppig.pc ... FAILED nppim.pc ... FAILED nppist.pc ... Passed nppisu.pc ... Passed nppitc.pc ... Passed npps.pc ... Passed nvToolsExt.pc ... FAILED nvgraph.pc ... FAILED nvidia-ml.pc ... FAILED nvjpeg.pc ... FAILED nvrtc.pc ... FAILED ==> ERROR: One or more files did not pass the validity check!