Package Details: ros-melodic-roscpp 1.12.14-1

Git Clone URL: https://aur.archlinux.org/ros-melodic-roscpp.git (read-only)
Package Base: ros-melodic-roscpp
Description: ROS - roscpp is a C++ implementation of ROS.
Upstream URL: http://ros.org/wiki/roscpp
Licenses: BSD
Conflicts: ros-melodic-roscpp-git
Submitter: GPereira
Maintainer: bionade24
Last Packager: bionade24
Votes: 1
Popularity: 0.000210
First Submitted: 2018-02-24 12:19
Last Updated: 2019-05-11 11:45

Required by (205)

Sources (1)

Latest Comments

« First ‹ Previous 1 2

jwhendy commented on 2019-01-17 05:47

And ros-melodic-rosconsole-bridge threw an error about needing libboost_regex 1.69, so I wonder if some of these packages are just in between boost dependencies somehow? I'm not that familiar with how these are maintained... should I report this upstream?

jwhendy commented on 2019-01-17 05:37

I had to downgrade to boost and boost-libs 1.68.0-2 for this to work. libboost_signal.so moved from /usr/lib/boost/ to something in /usr/include/boost/signals[2]. This might be coupled with having to downgrade to cmake 3.12.3 to get ros-melodic-cpp-common to play along with something else as well.