Package Details: rstudio-server-git v1.2.1330.r1180.g655da0f077-1

Git Clone URL: https://aur.archlinux.org/rstudio-server-git.git (read-only)
Package Base: rstudio-server-git
Description: A new integrated development environment (IDE) for R programming language
Upstream URL: http://www.rstudio.org/
Licenses: AGPL3
Conflicts: rstudio-server
Submitter: None
Maintainer: hwkiller
Last Packager: hwkiller
Votes: 8
Popularity: 0.000005
First Submitted: 2012-08-02 13:07
Last Updated: 2019-08-07 22:05

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

petres commented on 2015-03-04 14:47

Its not working, in the git source there is no install-rmarkdown file.

pinkdroid271 commented on 2015-01-16 04:15

http://pastebin.com/0L9eRp1q

I updated the dependencies. I changed the cmake command so it will actually build. PAM works. /usr/lib/rstudio-server/www is the web-directory root, not /srv/rstudio. I could not get it to work with /srv/rstudio. The .install file needs to be updated to reflect that. Maybe a simple ln -s would work. Regardless it works for me.

pinkdroid271 commented on 2015-01-16 04:08

http://pastebin.com/0L9eRp1q

I updated the dependencies. I changed the cmake command so it will actually build. PAM works. /usr/lib/rstudio/www is the web-direcoty root, not /srv/rstudio. I could not get it to work with /srv/rstudio. The .install file needs to be updated to reflect that. Maybe a simple ln -s would work. Regardless it works for me.

tbleiker commented on 2014-12-18 15:53

I changed the PKGBUILD to run ./dependencies/common/install-common instead of the dependencies directly. However, I got the following error:

...
./boost/iterator/iterator_adaptor.hpp:224:7: Anmerkung: bei Substitution des Makros »BOOST_STATIC_ASSERT«
BOOST_STATIC_ASSERT((is_convertible<Tr1, Tr2>::value));
^
gcc.compile.c++ bin.v2/libs/wave/build/gcc-4.9.2/release/link-static/threading-multi/cpplexer/re2clex/cpp_re.o
gcc.archive bin.v2/libs/wave/build/gcc-4.9.2/release/link-static/threading-multi/libboost_wave.a
common.copy /opt/rstudio-tools/boost/boost_1_50_0/lib/libboost_wave.a
...failed updating 58 targets...
...skipped 18 targets...
...updated 10601 targets...
==> FEHLER: Ein Fehler geschah in build().
Breche ab ...

ljw commented on 2014-10-20 07:29

I think the PKGBUILD could just be modified by running ./dependencies/common/install-common rather than by accessing the dependency installers directly.

I can get the package installed doing this, but nothing is getting it linked into PAM authentication on my end.

gabx commented on 2014-05-30 14:13

package is broken.Need a total rewrite

gabx commented on 2014-04-21 14:42

If server is not started, yes.
But even with an online server, you have more settings to do before you can connect. Please refer to the official doc for settings.

gabx commented on 2014-04-21 14:40

If server is not started, yes

wasperen commented on 2014-04-21 13:48

Would that cause the error "/auth-sign-in not found"? As that is the error I get in my browser when starting this server and browsing to port 8787 on it...

gabx commented on 2014-04-11 13:02

there is something wrong with the current systemd service. Trying to fix it