Package Details: servo-git r47479.92196d985dc-1

Git Clone URL: https://aur.archlinux.org/servo-git.git (read-only, click to copy)
Package Base: servo-git
Description: Parallel Browser Project: web browser written in Rust
Upstream URL: https://github.com/servo/servo
Keywords: browser engine rust
Licenses: MPL
Conflicts: servo
Provides: servo
Submitter: beatgammit
Maintainer: alerque (farseerfc, yar)
Last Packager: alerque
Votes: 46
Popularity: 0.033454
First Submitted: 2013-08-16 05:23 (UTC)
Last Updated: 2024-03-26 13:28 (UTC)

Dependencies (26)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

cypa commented on 2024-04-10 16:30 (UTC) (edited on 2024-04-10 16:39 (UTC) by cypa)

confirm crown -vV error

error: could not execute process 'crown -vV' (never executed)

Caused by:
  No such file or directory (os error 2)
Failed in 0:00:00
[Warning] Could not generate notification: org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

I guess we need setup proper environment ...

xiota commented on 2024-01-18 19:11 (UTC)

Clean chroot. Same crown -vV error. Unfortunately, I don't know how to fix.

alerque commented on 2024-01-11 09:33 (UTC)

@xiota Happy to accept contributions. Upstream has been messing around with the build system(s) and keep adding and removing stuff. If you have patches that work to make this build at any given point feel free to post them here or ever better PR them here.

xiota commented on 2023-09-25 05:42 (UTC) (edited on 2023-12-24 19:22 (UTC) by xiota)

Clean chroot. Fails to build.

Error from 2023-12-24:

error: could not execute process `crown -vV` (never executed)

Caused by:
  No such file or directory (os error 2)
Failed in 0:00:12
[Warning] Could not generate notification: org.freedesktop.DBus.Error.NotSupported: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead

Error from 2023-09-25:

error: failed to run `rustc` to learn about target-specific information

Caused by:
  process didn't exit successfully: `/home/main-builder/.rustup/toolchains/stable-x86_64-unknown-linux-gnu/bin/rustc - --crate-name ___ --print=file-names -Zgcc-ld=lld --crate-type bin --crate-type rlib --crate-type dylib --crate-type cdylib --crate-type staticlib --crate-type proc-macro --print=sysroot --print=split-debuginfo --print=crate-name --print=cfg` (exit status: 1)
  --- stderr
  error: the option `Z` is only accepted on the nightly compiler

  note: selecting a toolchain with `+toolchain` arguments require a rustup proxy; see <https://rust-lang.github.io/rustup/concepts/index.html>

  help: consider switching to a nightly toolchain: `rustup default nightly`

  note: for more information about Rust's stability policy, see <https://doc.rust-lang.org/book/appendix-07-nightly-rust.html#unstable-features>

Failed in 0:00:06
[Warning] Could not generate notification: org.freedesktop.DBus.Error.NotSupported: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead

alerque commented on 2021-09-21 17:10 (UTC)

@mble It looks like the Arch [community] package for python-blessings is newer than this build demands. Probably the thing to do is patch the servo sources to be more accepting of other versions, then if it doesn't build with 1.7.x submit a patch to servo upstream to fix it. I'm happy to accept such a patch (either in comments with git format-patch or as a PR on this repository) but I'm unlikely to have time to hack around on this build any time too soon. Also either way this should be reported upstream.

mble commented on 2021-09-21 16:42 (UTC)

Updating files:  98% (99189/101213)
Updating files:  99% (100201/101213)
Updating files: 100% (101213/101213)
Updating files: 100% (101213/101213), done.
==> Starting prepare()...
==> Starting pkgver()...
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Obtaining file:///var/tmp/pamac-build-mble/servo-git/src/servo-git/python/tidy (from -r /var/tmp/pamac-build-mble/servo-git/src/servo-git/python/requirements.txt (line 35))
Collecting blessings==1.6
  Using cached blessings-1.6.tar.gz (19 kB)
    ERROR: Command errored out with exit status 1:
     command: /var/tmp/pamac-build-mble/servo-git/src/servo-git/python/_virtualenv3.9/bin/python -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-dwdd9aw3/blessings_044041f758424b8c8c5d7f6d82c2deeb/setup.py'"'"'; __file__='"'"'/tmp/pip-install-dwdd9aw3/blessings_044041f758424b8c8c5d7f6d82c2deeb/setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-dmkmryeq
         cwd: /tmp/pip-install-dwdd9aw3/blessings_044041f758424b8c8c5d7f6d82c2deeb/
    Complete output (1 lines):
    error in blessings setup command: use_2to3 is invalid.
    ----------------------------------------
WARNING: Discarding https://files.pythonhosted.org/packages/af/4a/61acd1c6c29662d3fcbcaee5ba95c20b1d315c5a33534732b6d81e0dc8e8/blessings-1.6.tar.gz#sha256=edc5713061f10966048bf6b40d9a514b381e0ba849c64e034c4ef6c1847d3007 (from https://pypi.org/simple/blessings/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement blessings==1.6 (from versions: 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.5.1, 1.6, 1.6.1, 1.7)
ERROR: No matching distribution found for blessings==1.6
"/var/tmp/pamac-build-mble/servo-git/src/servo-git/python/_virtualenv3.9/bin/python" "-m" "pip" "install" "-I" "-r" "/var/tmp/pamac-build-mble/servo-git/src/servo-git/python/requirements.txt" failed with error code 1:
Output:
Error:
==> ERROR: A failure occurred in build().
    Aborting...

yar commented on 2021-07-06 00:15 (UTC)

Same error as @hcsch. Please fix or orphan, thanks.

hcsch commented on 2021-03-21 12:10 (UTC)

I got "Python virtualenv is not installed. Please install it prior to running mach." as an error when trying to install this with yay (I also tried plain makepkg). It seems to me that mach uses python (3) instead of python2. Switching the makedeps python packages from python2 to python worked for me.

farseerfc commented on 2020-08-17 06:56 (UTC)

@dmitmel good point, I stopped installing libraries in PKGBUILD