Package Details: flutter-beta 3.22.0_0.1.pre-1

Git Clone URL: https://aur.archlinux.org/flutter-beta.git (read-only, click to copy)
Package Base: flutter-beta
Description: A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
Upstream URL: https://flutter.dev
Keywords: flutter
Licenses: BSD-3-Clause
Conflicts: flutter
Provides: flutter
Submitter: subosito
Maintainer: Kppqju77
Last Packager: Kppqju77
Votes: 6
Popularity: 0.000184
First Submitted: 2018-08-31 06:31 (UTC)
Last Updated: 2024-04-05 06:54 (UTC)

Dependencies (18)

Required by (25)

Sources (3)

Latest Comments

1 2 Next › Last »

Kppqju77 commented on 2023-10-05 09:28 (UTC) (edited on 2023-10-05 12:19 (UTC) by Kppqju77)

@evgfilim1 I got the same problem, and upgrading to 3.15.0_15.2.pre doesn't work either for now, however flutter doctor is working fine, I am still investigation on this error, if you find any workaround for this let me know Edit: I've reverted to the "old" way of building the package, which is not really satisfactory... if anybody has some pointers to fix 3.15.0_15.2.pre-1 (not -2) please let me know

evgfilim1 commented on 2023-10-05 07:25 (UTC)

After upgrading, the toolchain is not working: Because my_project depends on flutter_test from sdk which doesn't exist (the Flutter SDK is not available), version solving failed.

Kppqju77 commented on 2023-09-20 06:12 (UTC)

@xuiqzy I tried to have the same logic than the flutter package for this one. 3.15.0_15.1.pre version might need a cleanbuild, a groupel flutterusers, and a rm -rf /opt/flutter/.

Like the flutter package, there will be warning of missing /opt/flutter/.git-refs files, this is by design to avoid overwriting files.

The next upgrades should be smoother now.

xuiqzy commented on 2023-09-11 12:56 (UTC)

Upgrade from 3.14.0_0.1.pre-1 to 3.14.0_0.2.pre-1 fails with:

(1/1) checking for file conflicts                                                               [########################################################] 100%
error: failed to commit transaction (conflicting files)
flutter-beta: /opt/flutter/.git/logs/refs/remotes/origin/dependabot/github_actions/actions/checkout-4.0.0 exists in filesystem
flutter-beta: /opt/flutter/.git/logs/refs/remotes/origin/flutter-3.14-candidate.14 exists in filesystem
flutter-beta: /opt/flutter/.git/logs/refs/remotes/origin/native-assets-linux exists in filesystem
flutter-beta: /opt/flutter/.git/logs/refs/remotes/origin/native-assets-windows exists in filesystem
flutter-beta: /opt/flutter/.git/logs/refs/remotes/origin/revert-133806-leak-fix-fix exists in filesystem
flutter-beta: /opt/flutter/.git/refs/remotes/origin/dependabot/github_actions/actions/checkout-4.0.0 exists in filesystem
flutter-beta: /opt/flutter/.git/refs/remotes/origin/flutter-3.14-candidate.14 exists in filesystem
flutter-beta: /opt/flutter/.git/refs/remotes/origin/native-assets-linux exists in filesystem
flutter-beta: /opt/flutter/.git/refs/remotes/origin/native-assets-windows exists in filesystem
flutter-beta: /opt/flutter/.git/refs/remotes/origin/revert-133806-leak-fix-fix exists in filesystem
flutter-beta: /opt/flutter/.git/refs/tags/3.13.3 exists in filesystem
flutter-beta: /opt/flutter/.git/refs/tags/3.14.0-14.0.pre exists in filesystem
Errors occurred, no packages were upgraded.

Maybe this is why the .git directory is removed in pre_install in the flutter package https://aur.archlinux.org/cgit/aur.git/tree/flutter.install?h=flutter and should be done here, too?

Kppqju77 commented on 2023-03-30 15:38 (UTC)

OK, I'll look into it

xuiqzy commented on 2023-02-12 00:49 (UTC) (edited on 2023-02-12 00:49 (UTC) by xuiqzy)

Executing flutter doctor after the install of flutter-beta fails with:
rm: cannot remove '/opt/flutter/version': Permission denied

The flutter doctor command succeeds after install of the flutter AUR package, so maybe it needs something from the PKGBUILD, install file, etc of that package:
https://aur.archlinux.org/cgit/aur.git/tree/?h=flutter

Kppqju77 commented on 2022-06-08 23:35 (UTC)

You might need to overwrite 2 files to bump to 3.1.0, you can use this options with pacman: --overwrite /opt/flutter/.git/logs/refs/remotes/origin/master,/opt/flutter/.git/refs/remotes/origin/master

Kppqju77 commented on 2022-04-19 14:02 (UTC)

Thanks, typo corrected

xuiqzy commented on 2022-04-19 13:02 (UTC)

The dollar sign is missing before "(tput sgr0)" in the latest update and the text is printed literally on the terminal.

Kppqju77 commented on 2022-01-26 08:12 (UTC) (edited on 2022-01-26 08:29 (UTC) by Kppqju77)

Sure, will do