Package Details: turboprint 2.48.2-1

Git Clone URL: https://aur.archlinux.org/turboprint.git (read-only)
Package Base: turboprint
Description: High-quality printer driver system for Linux
Upstream URL: http://www.turboprint.info/
Licenses: custom
Submitter: net147
Maintainer: severach
Last Packager: severach
Votes: 49
Popularity: 0.024984
First Submitted: 2008-07-08 07:30
Last Updated: 2019-06-11 05:02

Latest Comments

1 2 3 4 5 6 Next › Last »

esjeon commented on 2019-07-15 01:34

Installing the package doesn't automatically install desktop widgets. Running /usr/share/turboprint/lib/install-post as root installs the widget, but I'm not sure if this is safe. For example, this script copies an init script to /etc/init.d (a file, not a directory.)

nfortier commented on 2019-06-17 19:40

Important note: before upgrading to this package, make sure any AUR helper you use does save earlier versions in /var/cache/pacman/pkg. Otherwise, if the period covered by your license key for upgrades has expired, this package will not work. In which case you may find earlier versions of turboprint here: ftp://ftp.zedonet.com/tp2

GinoE commented on 2019-06-01 09:28

The listed version 2.47.1-1 is no longer available for download. The currently available version is turboprint-2.48-2.x86_64.tgz

Until the package is updated, edit the PKGBUILD during install and change

pkgver to 2.48.2

md5sum for x86_64 = 1e10ba5d88c2754b264027a0a2207d64

sha256sum for x86_64 = 76c8e4e4b02f37da09c7711226b978b64aa6f7a9b4280a9a42e9e6da69a658e8

Tristelune commented on 2017-07-29 08:04

I won't maintain this package anymore, a new maintainer can take it. Regards.

arnonuehm66 commented on 2017-07-02 12:08

If you encounter the

"curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading http://www.turboprint.info/tp2/turboprint-2.40-1.x86_64.tgz"

error, do the following, until this package is updated:

During installation say 'yes' to editing the PKGBUILD file.

Change
pkgver=2.40
to
pkgver=2.43
and
md5sums_x86_64=('775506a50c1faf6cb7b7d55312f3c3b4')
to
md5sums_x86_64=('c860f5335a12e4ffd5d83c4fa275b2af')

That works for me.

welkie commented on 2017-06-12 21:35

This isn't working for me right now. I'm getting the following error message:

==> Retrieving sources...
-> Found turboprint.desktop
-> Found turboprint-monitor.desktop
-> Found tprintdaemon.service
-> Downloading turboprint-2.40-1.x86_64.tgz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading http://www.turboprint.info/tp2/turboprint-2.40-1.x86_64.tgz
Aborting...
==> ERROR: Makepkg was unable to build turboprint.

I notice that manually clicking that link on this web page also 404s.

Tristelune commented on 2017-06-04 21:17

Hi, thank you for the patch. My license is not valid anymore and I won't probably use turboprint anymore. I can update the package, but somebody has to test it. Do you have a license ? Could you test the package ?

redinva commented on 2017-05-28 16:47

diff --git a/PKGBUILD b/PKGBUILD
index d39356f..e4f7273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainerb
# Contributor: Daniel Cardenas <thecubeisalie@gmail.com>
pkgname=turboprint
-pkgver=2.40
+pkgver=2.43
_realpkgver=${pkgver}-1
pkgrel=1
pkgdesc="High-quality printer driver system for Linux"
@@ -24,8 +24,8 @@ source_x86_64+=("http://www.turboprint.info/tp2/${pkgname}-${_realpkgver}.x86_64
md5sums=('e3c504b2c1b7deb01d03fde710b117d7'
'60a1754b2abd30e75e51acd9576cda43'
'4965b03fdb3c57282f74b0d79a66c6ef')
-md5sums_i686=('cf37916b5aa048a6c524e63dbad5ffb4')
-md5sums_x86_64=('775506a50c1faf6cb7b7d55312f3c3b4')
+md5sums_i686=('075f85fa19b444a9071f8d21c474babd')
+md5sums_x86_64=('c860f5335a12e4ffd5d83c4fa275b2af')

Tristelune commented on 2016-12-04 09:53

Hi rrkadio, I had a look at the file tprintdaemon.service. The file is included in the package. What you want is that the service is enabled after the installation of the package, right ?

Tristelune commented on 2016-11-27 09:36

@rrkadio

Thank you for your answer. I also answer very late. I'll have a look in about one week. At the moment I can't because I have a lot of work. Thank you for the information, I'll be able to solve the problem faster.