Package Details: twinkle 1.10.3-1

Git Clone URL: (read-only, click to copy)
Package Base: twinkle
Description: Softphone for voice over IP and IM communication using SIP
Upstream URL:
Licenses: GPL2
Submitter: sergej
Maintainer: freswa (malus)
Last Packager: freswa
Votes: 26
Popularity: 0.36
First Submitted: 2012-05-15 11:57 (UTC)
Last Updated: 2022-02-19 11:16 (UTC)

Latest Comments

usuariopolivalen commented on 2021-04-06 11:43 (UTC)

Is it possible to get twinkle-git or to get this package based on the git page?

I ask because there are so many fixes and additions ( Like G722 CODEC) to twinkle that are not in the february 2019 version...

Dunno why they don't release a new version yet...

Thanks @sergej and @freswa for all. I hope you can do something about it.

danilo.schembri commented on 2021-02-17 07:20 (UTC)

The site in "Upstream URL" is wrong.

malus commented on 2020-11-25 07:59 (UTC)

@Hazzl bison is a part of base-devel

Hazzl commented on 2020-11-23 12:51 (UTC)

This needs a build dependency on bison

rumpelsepp commented on 2020-07-10 06:28 (UTC)

Whats the difference to the twinkle package?

dreieck commented on 2020-03-21 12:17 (UTC)

Fails to build for me with -DWITH_G729=ON (dependency bcg729 is installed):

[...]/src/audio/audio_decoder.cpp: In member function ‘virtual uint16 t_g729a_audio_decoder::decode(uint8*, uint16, int16*, uint16)’:
[...]/src/audio/audio_decoder.cpp:550:50: error: invalid conversion from ‘int16*’ {aka ‘short int*’} to ‘uint8_t’ {aka ‘unsigned char’} [-fpermissive]
  550 |   bcg729Decoder(_context, &payload[done], false, &pcm_buf[done * 8]);
      |                                                  ^~~~~~~~~~~~~~~~~~
      |                                                  |
      |                                                  int16* {aka short int*}
[...]/src/audio/audio_decoder.cpp:550:68: error: too few arguments to function ‘void bcg729Decoder(bcg729DecoderChannelContextStruct*, uint8_t*, uint8_t, uint8_t, uint8_t, uint8_t, int16_t*)’
  550 |   bcg729Decoder(_context, &payload[done], false, &pcm_buf[done * 8]);

nimbusflow commented on 2020-02-08 04:40 (UTC)

May want to change the upstream URL to ? seems to belong to someone else now.

malus commented on 2020-01-14 06:40 (UTC)

@City-busz I had this in mind, but wanted to help :/ Will remove it again, sorry.

City-busz commented on 2020-01-14 00:02 (UTC)

@malus: you should not add packages to makedepends that part of base-devel. See:

malus commented on 2020-01-13 19:37 (UTC)

@mr_ersatz You are right anyways, it uses those dependencies. I use fresh archroot for my builds, but with base-devel which includes those packages already. I added them as make dependency.

malus commented on 2020-01-13 19:15 (UTC)

@mr_ersatz I can build it without those dependencies and therefore would not like to add them. But I will double check tomorrow, as my last build was from 23th December.

mr_ersatz commented on 2020-01-13 17:54 (UTC)

I had to install flex and bison packages to get this to build. Might want to add those to dependencies.

insatiable_kin commented on 2019-05-19 07:59 (UTC)

Fails to build due to broken dependency on libzrtpcpp

libzrtpcpp build from aur is broken preventing twinkle from being built.

ejKDE commented on 2018-10-11 12:32 (UTC) (edited on 2018-10-11 12:36 (UTC) by ejKDE)


Solved. The bug was fixed long ago and merged to master, unfortunately aur pkbuild file uses tag, so you're stuck with non fixed version.

Just change this and you're good to go, everything works:

from: source=("git+$_pkgname.git#tag=v${pkgver}")

to: source=("git+$_pkgname.git")

Maniaxx commented on 2018-08-15 22:48 (UTC) (edited on 2018-08-15 22:49 (UTC) by Maniaxx)

Doesn't find ucommon 7.0.0. Can be manually installed though. But then this comes up:

/tmp/makepkg/twinkle-qt5/src/twinkle/src/gui/getprofilenameform.cpp: In member function 'void GetProfileNameForm::init()':
/tmp/makepkg/twinkle-qt5/src/twinkle/src/gui/getprofilenameform.cpp:36:36: error: expected type-specifier before 'QRegExpValidator'
  profileLineEdit->setValidator(new QRegExpValidator(rxFilenameChars, this));
make[2]: *** [src/gui/CMakeFiles/twinkle.dir/build.make:690: src/gui/CMakeFiles/twinkle.dir/getprofilenameform.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [CMakeFiles/Makefile2:904: src/gui/CMakeFiles/twinkle.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
==> ERROR: A failure occurred in build().
:: Unable to build twinkle-qt5 - makepkg exited with code: 4

City-busz commented on 2018-02-08 17:27 (UTC)

@tredaelli: Please replace the twinkle package with this one, and then I'll merge this package into it.

schulmar commented on 2017-06-28 10:28 (UTC)

Thanks for the swift response. After the update of ucommon I got following errors when building libzrtpcpp during the installation of twinkle-qt5: /usr/bin/ld: warning:, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/, not found (try using -rpath or -rpath-link) /usr/bin/ld: warning:, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/, not found (try using -rpath or -rpath-link) /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/ undefined reference to `ucommon::ThreadLock::access(unsigned long)' After reinstalling ccrtp they vanished and twinkle works again.

schulmar commented on 2017-06-28 08:54 (UTC) (edited on 2017-06-28 08:55 (UTC) by schulmar)

Twinkle stopped working with the update to Qt 5.9 so I tried to reinstall. That resulted in following compiler error: In file included from /usr/include/ucommon/ucommon.h:91:0, from /usr/include/commoncpp/config.h:42, from /tmp/yaourt-tmp-schulmar/aur-twinkle-qt5/src/twinkle/src/util.h:29, from /tmp/yaourt-tmp-schulmar/aur-twinkle-qt5/src/twinkle/src/utils/file_utils.cpp:20: /usr/include/ucommon/object.h: In member function 'const T* ucommon::sarray<T>::at(unsigned int) const': /usr/include/ucommon/object.h:305:60: error: no matching function for call to 'ucommon::sarray<T>::get(unsigned int&) const' return immutable_cast<T*>(SparseObjects::get(offset)); ^ /usr/include/ucommon/object.h:243:21: note: candidate: ucommon::ObjectProtocol* ucommon::SparseObjects::get(unsigned int) <near match> ObjectProtocol *get(unsigned offset); ^~~ /usr/include/ucommon/object.h:243:21: note: passing 'const ucommon::sarray<T>*' as 'this' argument discards qualifiers In file included from /usr/include/ucommon/ucommon.h:91:0, from /usr/include/commoncpp/config.h:42, from /tmp/yaourt-tmp-schulmar/aur-twinkle-qt5/src/twinkle/src/parser/sip_body.h:23, from /tmp/yaourt-tmp-schulmar/aur-twinkle-qt5/src/twinkle/src/im/im_iscomposing_body.h:30, from /tmp/yaourt-tmp-schulmar/aur-twinkle-qt5/src/twinkle/src/im/im_iscomposing_body.cpp:19: As far as I can tell, the error seems to come from invalid code in ucommon which isn't listed in the dependencies of this package.

MountainX commented on 2016-07-19 01:03 (UTC)

after installing Twinkle, I am not able to get in-call audio working. I installed another SIP client (Jitsi) and it works correctly. Furthermore, I have an older version of Twinkle working. Given that the settings dialogs have not changed and my settings are exactly the same as the working (older) version, I am now suspecting that there is an issue with this package... I'd like to figure it out as I prefer to use Twinkle. My issue is that everything seems to work correctly except I have no in-call audio (in either direction). (My guess is that this is related to the interface with my sound card.)

MountainX commented on 2016-07-13 04:31 (UTC)

I got twinkle-qt5 to install today. The problem was in qt5-quick1. See this thread for more info: problem installing twinkle-qt5 from AUR / AUR Issues, Discussion & PKGBUILD Requests / Arch Linux Forums

MountainX commented on 2016-07-12 22:05 (UTC)

There seems to be a conflicting files error. After a lot of troubleshooting, I got stuck at this error: error: failed to commit transaction (conflicting files) /usr/lib/qt/bin/qdoc exists in filesystem IRC help suggested I file a bug report with package maintainer.

MountainX commented on 2016-07-12 07:44 (UTC)

I am getting this error: CMake Error at /usr/lib64/cmake/Qt5Declarative/Qt5DeclarativeConfig.cmake:99 (find_package): Could not find a configuration file for package "Qt5Script" that is compatible with requested version "5.7.1". The following configuration files were considered but not accepted: /usr/lib64/cmake/Qt5Script/Qt5ScriptConfig.cmake, version: 5.7.0 I thought it was from qt5-quick1, but it is not. I installed qt5-quick1 individually and there was no error. I guess it is an upstream problem, but I'm not sure what to do next.

oliver_aur commented on 2016-02-09 15:29 (UTC)

Just a small point but why does the upstream URL point to the original qt3 version (at release 1.4.2) when the code is using the qt5 version (at 1.9.0)? This URL has more up to date info -

oliver_aur commented on 2016-02-09 01:35 (UTC)

The bcg729 upgrade from 1.0.0 to 1.0.1 removed some required stuff. 1.0.0 has (not a list of everything) bcg729 /usr/include/bcg729/decoder.h bcg729 /usr/lib/ bcg729 /usr/lib/mediastreamer/plugins/ 1.0.1 has just the mediastreamer plugin. Looks like an upstream change, not a packaging change

RubenKelevra commented on 2016-02-08 18:58 (UTC)

Not buildable since 2015-05

MetaNova commented on 2016-01-07 22:00 (UTC)

I couldn't get this package to build without creating a symbolic link: ln -s /usr/lib/mediastreamer/plugins/ /usr/lib/ It appears that the bcg729 package installs the library to /usr/lib/mediastreamer/plugins/ but the twinkle build script looks for it in /usr/lib. I'm not all that good with CMake/Autoconf but by looking through the files it also appears that the twinkle scripts expect the library to be named "bcg729" instead of "msbcg729."

gamag commented on 2015-05-04 15:16 (UTC)

libzrtpcpp seems to be not available any more in the aur.

degerhar commented on 2014-12-06 12:08 (UTC)

I got it to work by adding "-I/usr/include/libzrtpcpp" to the CPPFLAGS in PKGBUILD (line #33): CPPFLAGS="$CPPFLAGS -I/usr/include/qt3 -I/usr/include/libzrtpcpp"

ricardofunke commented on 2014-12-04 17:27 (UTC)

I'm getting "configure: error: zrtp header files missing"

tredaelli commented on 2014-07-24 09:21 (UTC)

twinkle needs qt3, just compile it

0liver commented on 2014-07-23 19:29 (UTC)

with latest kernel and qt4 installed, I get #makepkg ==> Making package: twinkle 1.4.2-19 (Wed Jul 23 21:17:42 CEST 2014) ==> Checking runtime dependencies... ==> Missing dependencies: -> qt3 -> libzrtpcpp -> commoncpp2 ==> Checking buildtime dependencies... ==> Missing dependencies: -> boost -> gendesk ==> ERROR: Could not resolve all dependencies.

hundeboll commented on 2014-04-01 19:40 (UTC)

please add libzrtpcpp include path to the CPPFLAGS: CPPFLAGS="$CPPFLAGS -I/usr/include/qt3 -I/usr/include/libzrtpcpp/"

tredaelli commented on 2013-09-20 11:44 (UTC)

Updated, it should work now. Thanks for reporting

commented on 2013-09-20 00:07 (UTC)

Had the same issue as scan and mazieres: "configure: error: lrelease is missing (qt3-devel-tools package)" Found a workaround * sudo ln -s /usr/bin/lrelease-qt3 /usr/bin/lrelease * makepkg * sudo rm /usr/bin/lrelease Someone more motivated could patch the build to use lrelease-qt3.... Good luck :)

commented on 2013-09-02 20:15 (UTC)

me too configure: error: lrelease is missing (qt3-devel-tools package)

mazieres commented on 2013-08-29 07:46 (UTC)

Doesn't build for me. Perhaps a missing dependency? The configure phase fails with: checking for lrelease... no configure: error: lrelease is missing (qt3-devel-tools package)

mathias.steiger commented on 2013-04-27 16:57 (UTC)

Doesn't compile anymore. Very ugly fix: Put this under patch -p0 .. up to .configure .. as a replacement. You need to install automake-1.12 from AUR. -------------------------------- cd "$pkgname-$pkgver" export automake=1.12 export QTDIR=/usr/lib/qt3/ /usr/bin/aclocal-1.12 /usr/bin/autoconf /usr/bin/automake-1.12 -a mkdir -p src/gui/.ui mkdir -p src/gui/.obj mkdir -p src/gui/.moc if [[ "$(uname -a | grep -os x86_64)" == "x86_64" ]]; then find ./ -exec sed "s/\(i686-pc\|i586-pc\)/x86-64/g" -i '{}' \; find ./ -exec sed "s/\(i686\|i586\)/x86-64/g" -i '{}' \; fi -------------------------------- You also need to: ln -s /usr/share/qt3/mkspecs /usr/lib/qt3/mkspecs ln -s /usr/lib /usr/lib/qt3/lib ln -s /usr/include/qt3 /usr/lib/qt3/include It compiles, HOWEVER: I have a near-perfect asterisk setup locally and wouldn't get SIP audio. The UI of twinkle is not nice imo and it crashes for all sorts of reasons, e.g. if the connection to the SIP provider is suddenly lost .. Not very worthwhile.

nemamradfazole commented on 2013-04-18 19:31 (UTC)

/etc/profile.d/ (formerly from qt3) doesn't exist anymore, but it is called by PKGBUILD.

cidermole commented on 2013-04-06 20:44 (UTC)

Here is an additional section for the patch of to make it work: @@ -1,6 +1,6 @@ AC_INIT(src/phone.h) AC_CANONICAL_SYSTEM -AM_CONFIG_HEADER(src/twinkle_config.h) +AC_CONFIG_HEADERS(src/twinkle_config.h) AC_ARG_ENABLE(qt-check, AC_HELP_STRING([--disable-qt-check], [do not check Qt installation]),

bidulock commented on 2013-04-03 18:21 (UTC)

1.4.2-18 won't compile on x86_64. aclocal: warning: autoconf input should be named '', not '' acinclude.m4:3437: warning: the serial number must appear before any macro definition acinclude.m4:3482: warning: the serial number must appear before any macro definition acinclude.m4:3527: warning: the serial number must appear before any macro definition acinclude.m4:5689: warning: the serial number must appear before any macro definition error: 'AM_CONFIG_HEADER': this macro is obsolete. You should use the 'AC_CONFIG_HEADERS' macro instead. /usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build twinkle.

nemamradfazole commented on 2013-02-25 21:59 (UTC)

I tried version 1.4.1 from the official site and it works the same way. It seems ( this might be a quite old problem. So I tried compiling version 1.2 (, but it depends on old alocal etc. so I wasn't successful.

olive commented on 2013-02-25 21:32 (UTC)

@nemamradfazole Yes this is what I said. There is a patch to build with the recent version of ccrtp and libzrtpcpp but this seems broken. It build but does not give a working binary. Downgrading these two libaries fixed the problem, but I just use linphone now. Anyway, I would be happy if someone have a solution.

nemamradfazole commented on 2013-02-25 21:19 (UTC)

With the latest version a call-receiver hears me, but I cannot hear anything.

JohnnyDeacon commented on 2013-02-14 23:19 (UTC)

Please update this package! or create a GIT version.

Michitux commented on 2013-02-12 16:45 (UTC)

The macro AM_CONFIG_HEADER is obsolete, according to AC_CONFIG_HEADERS in current automake versions is a synonym for this obsolete macro. Adding sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' after cd "$pkgname-$pkgver" solved the problem for me.

slot commented on 2013-01-22 14:54 (UTC)

Error here: autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1

commented on 2012-08-20 18:59 (UTC)

This package is missing dependencies : - automake - autoconf Otherwise the package works great. Thanks!

olive commented on 2012-06-19 21:56 (UTC)

This package is broken. We do not ear the person called (even without NAT) and it hangs when we try to quit. Downgrading ccrtp to 1.8.0 and libzrtpcpp to 1.4.2 fix the problem (after rebuilding it without the twinkle-1.4.2-ccrtp.patch. The patch in this package twinkle-1.4.2-ccrtp.patch allows twinkle to build but gives a broken binary apparently.

CheariX commented on 2012-06-16 09:52 (UTC)

Building the package does not work if u set: BUILDDIR=/tmp/makepkg in /etc/makepkg.conf How can this be fixed (without disabling this option)...

oslik commented on 2012-06-14 13:47 (UTC)

please add 'automake' and 'autoconf' to makedepends

sergej commented on 2012-05-17 08:56 (UTC)

Yes, this package is waiting for maintainer. Probably you can make pkgbuild for previous version of ccrtp, which can be installed in parallel with current ccrtp.

mazieres commented on 2012-05-17 07:28 (UTC)

Doesn't build for me. It pulls in ccrtp version 2 as a dependency, but then I get: checking for libccrtp1 >= 1.6.0... Package libccrtp1 was not found in the pkg-config search path. Perhaps you should add the directory containing `libccrtp1.pc' to the PKG_CONFIG_PATH environment variable No package 'libccrtp1' found configure: error: Library requirements (libccrtp1 >= 1.6.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them. Maybe there needs to be a separate ccrtp1 package in aur for twinkle to depend on?

sergej commented on 2012-05-15 11:58 (UTC)

moved from community because of it is incompatible with current ccrtp.