Package Details: virtualbox-ext-oracle 6.1.26-1

Git Clone URL: https://aur.archlinux.org/virtualbox-ext-oracle.git (read-only, click to copy)
Package Base: virtualbox-ext-oracle
Description: Oracle VM VirtualBox Extension Pack
Upstream URL: https://www.virtualbox.org/
Keywords: virtualbox
Licenses: custom:PUEL
Submitter: seblu
Maintainer: seblu (eworm)
Last Packager: eworm
Votes: 1336
Popularity: 4.08
First Submitted: 2010-12-24 16:48
Last Updated: 2021-07-29 12:25

Pinned Comments

seblu commented on 2019-04-25 17:41

There is no version dependency on this package on purpose! You could read comments back from 2011 to understand why.

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

Marcel_K commented on 2018-01-16 19:00

Should be 5.2.6 (maintenance releases are always even-numbered).

oldgaro commented on 2018-01-16 18:48

Thanks!

seblu commented on 2017-12-20 17:37

1) IIRC to not pull virtualbox deps during build. 2) No, cf previous comments. We don't care of non-arch users here.

Anonymous comment on 2017-12-20 16:47

Two questions: 1. why is depends array in the package() function and not global? 2. can the maintainer maintain the corresponding virtualbox version dependency? it should be as easy as writing depends=('virtualbox>=whatever_the_ext_version_is'). this way it won't break the setup for non-arch users.

Anonymous comment on 2017-10-23 23:03

Hi @seblu , you have to add version dependency of virtualbox for this package, because https://www.virtualbox.org/wiki/Downloads says: "Please install the extension pack with the same version as your installed version of VirtualBox". That is not correct to use virtualbox-ext-oracle with any version of virtualbox.

zeroflag commented on 2017-10-23 21:24

@seblu @eworm Since versioned dependencies are not used in Arch, the package maintainer, committer should've checked the versions compatibility prior committing such crippled update.

The philosophy adopted by Archlinux is KISS. But for some reason, immature community members stick to the "stupid" part only. This is not a playground, or is it...

@giogziro95 Thanks for the provided PKBUILD, mate, very much appreciated!

mxfm commented on 2017-10-23 05:03

Recent update 5.1=>5.2 has broken my virtualbox because of version mismatch.

@seblu @Scimmia this issue should be somehow fixed, or this package should have not been updated to version 5.2 without corresponding update of virtualbox from main repos.

Saying that we coudn't not do versioned dependecies because thay are broken in Arch is nonsense. If this is true, than pacman should be fixed. I am amazed how often arch people blame users and not crippled features.

By the way, this update breaks policy of not supporting partial updates, because what essentially is done is exactly partial update. I would expect that virtualbox and ext pack to be kept in syns.

giogziro95 commented on 2017-10-21 10:50

Here's a PKGBUILD for 5.1.2, if anybody's interested:

https://gist.github.com/giogziro95/da59150b7ba4731125063fa8d0b994ab

seblu commented on 2017-10-21 09:40

We do not use versioned dependencies in Arch. I remember this was suggested and tested years ago and it breaks the upgrades.

giogziro95 commented on 2017-10-21 01:18

Scimmia, in this case, it's the other way around — the VirtualBox version is lower than the Extension Pack version. And it's broken after the Extension Pack update because of the version mismatch, so it's a good idea not to update the Extension Pack only.

In order to avoid the problem you've mentioned, this can be used instead:

depends=('virtualbox>=VERSION')