Package Details: vlc-git 4.0.0.r6571.g3fce6dbf7d-1

Git Clone URL: https://aur.archlinux.org/vlc-git.git (read-only)
Package Base: vlc-git
Description: A multi-platform MPEG, VCD/DVD, and DivX player (GIT Version)
Upstream URL: https://www.videolan.org/vlc/
Licenses: GPL2, LGPL2.1
Conflicts: vlc, vlc-dev, vlc-plugin, vlc-stable-git
Provides: vlc=4.0.0.r6571.g3fce6dbf7d
Submitter: None
Maintainer: andrewSC
Last Packager: andrewSC
Votes: 195
Popularity: 0.400695
First Submitted: 2008-04-01 12:14
Last Updated: 2019-02-20 19:22

Dependencies (154)

Required by (105)

Sources (3)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

friday commented on 2019-04-16 06:48

Missing dependency: qt5-quickcontrols2

filthyAUR commented on 2019-03-23 12:37

Getting this:

video_output/decklink.cpp:1162:23: error: invalid conversion from ‘void (*)(audio_output_t*, bool)’ {aka ‘void (*)(audio_output*, bool)’} to ‘void (*)(audio_output_t*)’ {aka ‘void (*)(audio_output*)’} [-fpermissive]
make[4]: *** [Makefile:25111: video_output/libdecklinkoutput_plugin_la-decklink.lo] Error 1
make[3]: *** [Makefile:28258: all-recursive] Error 1
make[2]: *** [Makefile:12304: all] Error 2
make[1]: *** [Makefile:1567: all-recursive] Error 1
make: *** [Makefile:1452: all] Error 2
==> ERROR: A failure occurred in build().
Error making: vlc-git

andrewSC commented on 2019-02-26 14:23

soloturn: I don't see why you couldn't use libdvdread-git in place of the PKGBUILD I provided, although, it may be less stable than the tagged version/what the PKGBUILD provides.

soloturn commented on 2019-02-23 09:39

as long as libdvdread is not 6.0.1 in arch, can you use libdvdread-git ? tried it and it builds again.

jbkempf from vlc pointed out that it is a "greater than", not "greater than or equal" 6.0.0, hahaha, my blunder. even if mere mortals deal easier with >=

mrturcot commented on 2019-02-20 21:06

@andrewSC thanks a lot! It built successfully :)

Packages (1) vlc-git-4.0.0.r6578.g13606fd50d-1
Total Installed Size: 56.11 MiB

Best Regards,
MrTurcot

andrewSC commented on 2019-02-20 19:25

mrturcot: The issue you're running into is because extra/libdvdread is out-of-date at the moment. To make things a little bit easier for you, I've created the updated PKGBUILD which you can find here: https://ptpb.pw/M5zn

I'd suggest just building that locally, then either installing it in the chroot or if you don't use one, installing on your machine, then building vlc-git.

Also, I worked with upstream to resolve the dvdnav versioning issue so you shouldn't run into that error anymore.

soloturn: Thanks for bringing xosd to my attention. Definitely appears safe to remove at this point!

soloturn commented on 2019-02-19 18:14

created ticket https://trac.videolan.org/vlc/ticket/21944, vlc-git used to build a couple of weeks ago, namely commit 4.0.0-dev-6229-g9868c4be81, or vlc-git-4.0.0.r6467.g2f3f44804e. and the version produces less crashes resp X stalls than the ABS version vlc-3.x.

soloturn commented on 2019-02-19 17:54

can you pls remove xosd as dependency? this should not be necessary any more. is not in the vlc package as well.

mrturcot commented on 2019-02-16 19:46

checking for DVDREAD... no
configure: error: Library dvdread > 6.0.0 needed for dvdread was not found
==> ERROR: A failure occurred in build().
Aborting...
Error making: vlc-git

I had "extra/libdvdread 6.0.0-1" installed

After installing "libdvdread-git & libdvdcss-git" I was able to pass "checking for DVDREAD... yes"

But now getting

configure: error: Library dvdnav > 6.0.0 needed for dvdnav was not found
==> ERROR: A failure occurred in build().
Aborting...
Error making: vlc-git

with "libdvdnav 6.0.0-1" or "libdvdnav-git" installed

6ax commented on 2019-01-22 10:48

Pls add package vulkan-headers to makedepends. Tnx.