Package Details: appmenu-gtk-module-git 0.7.3.2-1

Git Clone URL: https://aur.archlinux.org/appmenu-gtk-module-git.git (read-only, click to copy)
Package Base: appmenu-gtk-module-git
Description: Gtk module for exporting menus
Upstream URL: https://gitlab.com/vala-panel-project/vala-panel-appmenu
Licenses: LGPL3
Conflicts: appmenu-gtk-module
Provides: unity-gtk-module
Submitter: rilian
Maintainer: rilian
Last Packager: rilian
Votes: 7
Popularity: 0.33
First Submitted: 2018-03-11 21:56 (UTC)
Last Updated: 2020-09-06 22:13 (UTC)

Latest Comments

NateR100 commented on 2020-09-28 13:51 (UTC) (edited on 2020-09-28 13:52 (UTC) by NateR100)

@rilian

Yes, vala-panel-appmenu-registrar-git 0.7.4.r3.g1e8791e-1.

Actually, for whatever reason, it seems to be working now. Not sure what happened. (other than Firefox cause not supported).

rilian commented on 2020-09-28 08:23 (UTC)

@NateR100

appmenu-gtk-module does not work with Firefox.

Do appmenu-registrar is installed?

NateR100 commented on 2020-09-27 20:24 (UTC) (edited on 2020-09-27 22:44 (UTC) by NateR100)

I installed this on ArchLinux with XFCE4-Panel, but it doesn't display File, Edit menus etc. Only the application name (like Firefox) and clicking it shows New Window, etc.

How can I get the File, Edit and other menu items to show up?

I also get this message: (xfce4-panel:8717): Gtk-CRITICAL **: 16:15:50.181: gtk_widget_grab_default: assertion 'gtk_widget_get_can_default (widget)' failed GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface “com.canonical.AppMenu.Registrar” on object at path /com/canonical/AppMenu/Registrar

rilian commented on 2020-09-06 22:14 (UTC)

@Brianb, fixed.

Brianb commented on 2020-09-01 05:30 (UTC)

This should probably conflict with the non git version of the package

saulhidalgoaular commented on 2019-03-22 17:25 (UTC)

I know that the package is taken directly from git, but please, update the version number to 0.7.1. It looks outdated.

michaelrk02 commented on 2018-12-11 03:12 (UTC) (edited on 2018-12-11 03:13 (UTC) by michaelrk02)

Yes, i've already installed these packages:

pango (1.40.4), cairo (1.14.8), gdk-pixbuf2 (2.36.5)

rilian commented on 2018-12-10 11:52 (UTC)

Ok. Do you have pango,cairo and gdk-pixbuf? If no, install it, please)

michaelrk02 commented on 2018-12-10 11:02 (UTC)

Ok. Here's the list: https://pastebin.com/zjMk5t8S

rilian commented on 2018-12-10 03:15 (UTC)

Ok, I will look for it. Can you show me pacman -Ql gtk2?

michaelrk02 commented on 2018-12-10 02:09 (UTC)

Yes. I've installed the dependencies. But wait, i've found the following output when building:

==> Starting build()...

-- Could NOT find GTK (missing: GDK) (found suitable version "2.24.31", minimum required is "2.24")

CMake Warning at CMakeLists.txt:32 (find_package):

Could not find a package configuration file provided by "VCM" with any of the following names:

VCMConfig.cmake

vcm-config.cmake

Add the installation prefix of "VCM" to CMAKE_PREFIX_PATH or set "VCM_DIR" to a directory containing one of the above files. If "VCM" provides a separate development package or SDK, be sure it has been installed.

What should i do?

rilian commented on 2018-12-09 23:55 (UTC)

I do not mean makepkg, I mean using my readme)

https://gitlab.com/vala-panel-project/vala-panel-appmenu/blob/master/subprojects/appmenu-gtk-module/README.md

All is done?

michaelrk02 commented on 2018-12-09 15:35 (UTC)

I've makepkg-ed this without any special configuration. But it builds for gtk3 only, so there's no libappmenu-gtk-module.so in /usr/lib/gtk-2.0/modules inside the package. Also the log said that gtk2 feature is enabled

rilian commented on 2018-12-09 04:42 (UTC)

Are you done all configurations?

michaelrk02 commented on 2018-12-09 03:46 (UTC) (edited on 2018-12-09 03:47 (UTC) by michaelrk02)

When i run GTK 2 apps from terminal, it shows the following output:

Gtk-Message: Failed to load module "appmenu-gtk-module"

But the GTK 3 seems to be okay

rilian commented on 2018-10-31 07:00 (UTC)

In English, please.

dakataca commented on 2018-10-31 03:57 (UTC) (edited on 2018-10-31 03:58 (UTC) by dakataca)

error: no se pudo realizar la operación (archivos en conflicto)

appmenu-gtk-module-git: /usr/lib/gtk-2.0/modules/libappmenu-gtk-module.so existe en el sistema de archivos

appmenu-gtk-module-git: /usr/lib/gtk-3.0/modules/libappmenu-gtk-module.so existe en el sistema de archivos

appmenu-gtk-module-git: /usr/lib/systemd/user/appmenu-gtk-module.service existe en el sistema de archivos

Ocurrieron errores, por lo que no se actualizaron los paquetes

==> ADVERTENCIA: Hubo fallos al instalar el (o los) paquetes compilados.