Package Details: authenticator 3.32.2-3

Git Clone URL: https://aur.archlinux.org/authenticator.git (read-only, click to copy)
Package Base: authenticator
Description: 2FA code generator for GNOME
Upstream URL: https://gitlab.gnome.org/World/Authenticator
Keywords: 2FA
Licenses: GPL3
Submitter: lll2yu
Maintainer: lll2yu
Last Packager: lll2yu
Votes: 10
Popularity: 1.03
First Submitted: 2018-03-23 18:23
Last Updated: 2019-07-30 15:31

Latest Comments

1 2 Next › Last »

kaipee2 commented on 2020-05-12 14:24

Upstream bug report for lambda TypeError: (https://gitlab.gnome.org/World/Authenticator/-/issues/177)

Developer comment:

Seems to be an issue in the code itself, I shouldn't be calling init_template at all

The following disables all calls to init_template and allows the application to launch

grep -rl "init_template" /usr/lib/python3.*/site-packages/Authenticator/ | sudo xargs sed -i 's/self.init_template/#self.init_template/g'

aorth commented on 2020-05-07 10:47

Currently failing:

$ authenticator 
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/Authenticator/application.py", line 208, in _is_locked_changed
    Window.get_default().refresh_view()
  File "/usr/lib/python3.8/site-packages/Authenticator/widgets/window.py", line 70, in get_default
    Window.instance = Window()
  File "/usr/lib/python3.8/site-packages/Authenticator/widgets/window.py", line 55, in __init__
    self.init_template('Window')
TypeError: <lambda>() takes 0 positional arguments but 1 was given
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/Authenticator/application.py", line 77, in do_activate
    window = Window.get_default()
  File "/usr/lib/python3.8/site-packages/Authenticator/widgets/window.py", line 70, in get_default
    Window.instance = Window()
  File "/usr/lib/python3.8/site-packages/Authenticator/widgets/window.py", line 55, in __init__
    self.init_template('Window')
TypeError: <lambda>() takes 0 positional arguments but 1 was given

ShayBox commented on 2019-10-04 00:03

libsecret* needs to be a dependency, it's required for the app to work

lll2yu commented on 2019-06-18 13:45

@maslic @rafaelff added libhandy as dependency, apologies for the delay in update.

rafaelff commented on 2019-06-11 22:54

Indeed. Even though libhandy is not listed in the requirements.txt file, a grep in the source code shows it is required by a couple of files. Should be added to depends array.

Anonymous comment on 2019-06-10 20:10

Seems it's missing libhandy as dependency:

Traceback (most recent call last):
  File "/usr/bin/authenticator", line 31, in <module>
    require_version("Handy", "0.0")
  File "/usr/lib/python3.7/site-packages/gi/__init__.py", line 129, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Handy not available

Depau commented on 2019-05-23 19:47

Also, please considere these suggestions

From 66349a3992459c1914cd9c9b1042605477114987 Mon Sep 17 00:00:00 2001
From: Davide Depau <davide@depau.eu>
Date: Thu, 23 May 2019 21:45:15 +0200
Subject: [PATCH] Add suggestions from comment by @rafaelff

https://aur.archlinux.org/packages/authenticator-git/#comment-694669
---
 .SRCINFO | 8 ++++----
 PKGBUILD | 8 ++++----
 2 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index cd60f16..e90c7d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = authenticator-git
    pkgdesc = 2FA code generator for GNOME
-   pkgver = 0.2.4.r15.g7091453
+   pkgver = 0.2.4.r16.gaf7aed5
    pkgrel = 1
    url = https://github.com/bilelmoussaoui/Authenticator
    arch = any
@@ -8,15 +8,15 @@ pkgbase = authenticator-git
    makedepends = meson
    makedepends = ninja
    makedepends = gobject-introspection
-   makedepends = gnome-common
-   depends = gtk3>=3.16.0
-   depends = python>=3.3.0
+   depends = gtk3
+   depends = python
    depends = glib2
    depends = python-pyotp
    depends = libsecret
    depends = python-pillow
    depends = pyzbar
    depends = python-gnupg
+   depends = python-beautifulsoup4
    provides = authenticator
    conflicts = authenticator
    source = authenticator::git+https://github.com/bilelmoussaoui/Authenticator.git
diff --git a/PKGBUILD b/PKGBUILD
index 62b87cc..04857e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@

 _pkgname=authenticator
 pkgname=$_pkgname-git
-pkgver=0.2.4.r15.g7091453
+pkgver=0.2.4.r16.gaf7aed5
 pkgrel=1
 pkgdesc="2FA code generator for GNOME "
 arch=('any')
 url="https://github.com/bilelmoussaoui/Authenticator"
 license=('GPL')
-depends=('gtk3>=3.16.0' 'python>=3.3.0' 'glib2' 'python-pyotp' 'libsecret' 'python-pillow' 'pyzbar' 'python-gnupg')
-makedepends=('meson' 'ninja' 'gobject-introspection' 'gnome-common')
+depends=('gtk3' 'python' 'glib2' 'python-pyotp' 'libsecret' 'python-pillow' 'pyzbar' 'python-gnupg' 'python-beautifulsoup4')
+makedepends=('meson' 'ninja' 'gobject-introspection')
 provides=('authenticator')
 conflicts=('authenticator')
 source=("$_pkgname::git+https://github.com/bilelmoussaoui/Authenticator.git")
@@ -22,7 +22,7 @@ pkgver() {

 prepare() {
   cd "$srcdir/$_pkgname"
-  meson build --prefix=/usr --libdir=lib
+  meson build --prefix=/usr --libdir=lib --libexecdir=lib
 }

 build() {
-- 
2.21.0

kaipee2 commented on 2019-03-01 09:14

Please update dependencies to replace python-pyzbar with pyzbar.

Looks like the package has been renamed, https://github.com/NaturalHistoryMuseum/python-pyzbar no longer exists.

cpuheater commented on 2018-11-28 15:03

'git' should be added to the makedepends list, otherwise you get ERROR: Cannot find the git package needed to handle git sources. in a clean build environment.

lll2yu commented on 2018-10-07 15:32

v0.2.5 was tagged at the time of pkg update. Though it's still tagged as 0.2.5 on flathub and in the meson.build file https://flathub.org/apps/details/com.github.bilelmoussaoui.Authenticator https://gitlab.gnome.org/World/Authenticator/blob/master/meson.build I've no idea why the tag was removed from gitlab repo.

Reverted to older tag so should be fixed now.