Package Details: brave 0.19.88-1

Git Clone URL: https://aur.archlinux.org/brave.git (read-only)
Package Base: brave
Description: Web browser that blocks ads and trackers by default.
Upstream URL: https://www.brave.com/
Keywords: browser muon web
Licenses: custom
Provides: brave-browser
Submitter: mischka
Maintainer: mischka (vorbote)
Last Packager: mischka
Votes: 39
Popularity: 1.537677
First Submitted: 2016-01-29 19:47
Last Updated: 2017-11-10 23:02

Dependencies (12)

Required by (0)

Sources (1)

Latest Comments

mischka commented on 2017-11-04 19:09

Hm. Are you sure that the installation is being run with your globally installed node and not some lower version that's in your path (installed via nvm maybe)?

I believe node's strictness checking that returns those errors shouldn't be an issue after about v7.5.

jperic commented on 2017-11-04 17:39

Hello and thank you.

I'm trying to update with packer to v0.19.80-1

pacman -Q nodejs
nodejs 8.8.1-1

pacman -Q npm
npm 5.5.1-1

packer -S brave

Aur Targets (1): brave

Proceed with installation? [Y/n]

Edit brave PKGBUILD with $EDITOR? [Y/n]

==> Making package: brave 0.19.80-1 (Sat Nov 4 13:09:43 EDT 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found browser-laptop-0.19.80dev.tar.gz
==> Validating source files with md5sums...
browser-laptop-0.19.80dev.tar.gz ... Passed
==> Extracting sources...
-> Extracting browser-laptop-0.19.80dev.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...

> brave@0.19.80 postinstall /tmp/packerbuild-1000/brave/brave/src/browser-laptop-0.19.80dev
> npm run download-sync-client && webpack


> brave@0.19.80 download-sync-client /tmp/packerbuild-1000/brave/brave/src/browser-laptop-0.19.80dev
> node ./tools/downloadSyncClient

writing sync bundle to /tmp/packerbuild-1000/brave/brave/src/browser-laptop-0.19.80dev/app/extensions/brave/content/scripts/sync.js
/tmp/packerbuild-1000/brave/brave/src/browser-laptop-0.19.80dev/webpack.config.js:13
let c = {
^^^

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Module.require (module.js:367:17)
at require (internal/module.js:20:19)
at module.exports (/tmp/packerbuild-1000/brave/brave/src/browser-laptop-0.19.80dev/node_modules/webpack/bin/convert-argv.js:80:13)
at Object.<anonymous> (/tmp/packerbuild-1000/brave/brave/src/browser-laptop-0.19.80dev/node_modules/webpack/bin/webpack.js:39:40)
at Module._compile (module.js:413:34)

npm WARN optional Skipping failed optional dependency /7zip-bin/7zip-bin-mac:
npm WARN notsup Not compatible with your operating system or architecture: 7zip-bin-mac@1.0.1
npm WARN optional Skipping failed optional dependency /7zip-bin/7zip-bin-win:
npm WARN notsup Not compatible with your operating system or architecture: 7zip-bin-win@2.1.1
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2
npm WARN eslint-plugin-react@6.9.0 requires a peer of eslint@^2.0.0 || ^3.0.0 but none was installed.
npm WARN react-dom@15.6.2 requires a peer of react@^15.6.2 but none was installed.
npm WARN react-select@0.9.1 requires a peer of react@^0.14.1 but none was installed.
npm WARN react-select@0.9.1 requires a peer of react-dom@^0.14.1 but none was installed.
npm WARN react-test-renderer@15.6.2 requires a peer of react@^15.6.2 but none was installed.
npm ERR! Linux 4.13.8-1-ARCH
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
npm ERR! node v5.11.0
npm ERR! npm v3.8.6
npm ERR! code ELIFECYCLE
npm ERR! brave@0.19.80 postinstall: `npm run download-sync-client && webpack`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the brave@0.19.80 postinstall script 'npm run download-sync-client && webpack'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the brave package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run download-sync-client && webpack
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs brave
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls brave
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /tmp/packerbuild-1000/brave/brave/src/browser-laptop-0.19.80dev/npm-debug.log
==> ERROR: A failure occurred in build().
Aborting...
The build failed.

I get the same messages with yaourt but then it goes on to building and installing.

mischka commented on 2017-10-10 02:51

@Chiruno looks like https://github.com/npm/npm/issues/18520, should be fixed upon upgrading npm to 5.5.0 or downgrading to 5.4.0 (I think, maybe lower). Not sure what I should do here to work around that for now. Any suggestions?

@FreelancePolice I'm willing to bet that will be fixed in a new release of brave (should be soon), that has tended to be the case for errors in `buildPackage.js` for me before. Sorry, also not sure what I should do here to fix it.

I'd recommend using brave-bin in the meantime, but I'm happy to hear suggestions.

Chiruno commented on 2017-10-10 02:28

make: Entering directory '/home/chiruno/.cache/pacaur/brave/src/browser-laptop-0.18.36dev/node_modules/tracking-protection/node_modules/cppunitlite/build'
CXX(target) Release/obj.target/CppUnitLite/src/Failure.o
CXX(target) Release/obj.target/CppUnitLite/src/SimpleString.o
CXX(target) Release/obj.target/CppUnitLite/src/Test.o
CXX(target) Release/obj.target/CppUnitLite/src/TestResult.o
CXX(target) Release/obj.target/CppUnitLite/src/TestRegistry.o
AR(target) Release/obj.target/CppUnitLite.a
COPY Release/CppUnitLite.a
CXX(target) Release/obj.target/test/test/StackMain.o
CXX(target) Release/obj.target/test/test/StackTest.o
LINK(target) Release/test
make: Leaving directory '/home/chiruno/.cache/pacaur/brave/src/browser-laptop-0.18.36dev/node_modules/tracking-protection/node_modules/cppunitlite/build'
+ cppunitlite@1.0.0
added 1 package in 1.38s
npm ERR! Cannot read property 'pause' of undefined

npm ERR! A complete log of this run can be found in:
npm ERR! /home/chiruno/.npm/_logs/2017-10-10T02_25_16_154Z-debug.log
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build brave package(s)

FreelancePolice commented on 2017-09-30 20:12

This package fails to compile. The error message is:

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! brave@0.18.36 build-package: `node ./tools/buildPackage.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the brave@0.18.36 build-package script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/adam/.npm/_logs/2017-09-30T20_11_31_303Z-debug.log
==> ERROR: A failure occurred in build().
Aborting...

Chiruno commented on 2017-08-11 21:34

This package seems to be outdated.
https://github.com/brave/browser-laptop/releases/tag/v0.18.14dev

ZioCroccante commented on 2017-06-05 14:38

@palopezv
Thanks for the clear answer.

vorbote commented on 2017-06-05 14:30

@ZioCroccante

Can't be helped. It is a perfect storm of upstream changing library requirements to versions incompatible with npm 4.6.x. Thus, we need newer tools in Arch (will require a staging transition I think) and upstream to straighten out its act.

Patience. As you should be aware, brave is a browser in development and code quality is poor, not even alpha at some release milestones. That is, when it breaks you get to keep the pieces. Being brutally honest, if you are depending on it for something more than playing around at this stage, you are in trouble.

In the meantime, I'll fake the version to push the last working version.

vorbote commented on 2017-05-28 19:16

I just pushed 0.16.0 for your compiling and browsing pleasure. :-)

pseudoramble commented on 2017-05-28 16:41

Thanks @palopezv. I updated my comment to clarify what I was doing (which is not a good way to go). I've had a very simple script to do AUR package installations for a long time, and didn't realize some packages won't support the snapshot method anymore.

You should install cower, like I will :)

All comments