Package Details: codelite-git 17.10.0.r2.g82c71e994-1

Git Clone URL: https://aur.archlinux.org/codelite-git.git (read-only, click to copy)
Package Base: codelite-git
Description: Cross platform IDE for C, C++, Rust, Python, PHP and Node.js written in C++
Upstream URL: https://codelite.org/
Keywords: C C++ IDE Node.js PHP wxGtk wxWidgets
Licenses: GPL
Conflicts: codelite
Provides: codelite
Submitter: PyroDevil
Maintainer: uffe
Last Packager: uffe
Votes: 15
Popularity: 0.000000
First Submitted: 2013-05-25 08:18 (UTC)
Last Updated: 2024-06-03 16:14 (UTC)

Dependencies (20)

Required by (3)

Sources (2)

Latest Comments

1 2 3 Next › Last »

FabioLolix commented on 2023-07-24 20:53 (UTC)

Hello,

  • please use https for url=
  • conflicts with codelite-bin is not needed (I've just adopted codelite-bin to update and fix it)
  • packages of the base-devel group like pkg-config don't have to be specified as makedepends
  • would you like to switch from wxgtk3 to wxwidgets-gtk3?

zwastik commented on 2022-10-19 15:53 (UTC)

This works for me:

# Maintainer: Jefferson Gonzalez <jgmdev@gmail.com>
# Contributor: Pyro Devil <p dot devil at gmail dot com>
_mainpkgname="eranif"
pkgname=codelite-git
_gitname=codelite
pkgver=16.4.0.r96.gda8a3904e
pkgrel=1
pkgdesc="A cross platform C/C++/PHP and Node.js IDE written in C++"
arch=('i686' 'x86_64' 'aarch64')
url="http://www.codelite.org/"
license=('GPL')
makedepends=('pkgconfig' 'cmake' 'ninja' 'clang' 'git')
depends=(
  'wxgtk3'
  'libedit'
  'libssh'
  'mariadb-libs'
  'ncurses'
  'xterm'
  'wget'
  'curl'
  'python2'
  'clang'
  'lldb'
  'hunspell'
)
optdepends=(
  'graphviz: callgraph visualization'
  'cscope: CScope Integration for CodeLite'
  'clang: compiler'
  'gcc: compiler'
  'gdb: debugger'
  'valgrind: debugger'
)
conflicts=('codelite' 'codelite-bin')
provides=('codelite')
source=(
  "$_gitname::git+https://github.com/$_mainpkgname/$_gitname" 
  http://repos.codelite.org/wxCrafterLibs/wxgui.zip
)
md5sums=(
  'SKIP'
  'SKIP'
)
noextract=('wxgui.zip')


pkgver() {
  cd "${srcdir}/${_gitname}"
  git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}

prepare() {
  cd "${srcdir}/${_gitname}"
  git submodule update --init
  mkdir -p build
}

build() {
  cd "${srcdir}/${_gitname}/build"

  CXXFLAGS="${CXXFLAGS} -fno-devirtualize"

  cmake -G "Ninja" -DCMAKE_BUILD_TYPE=Release \
    -DWITH_WX_CONFIG=/usr/bin/wx-config-gtk3 \
    -DENABLE_LLDB=1 -DWITH_MYSQL=0 \
    -DCMAKE_INSTALL_LIBDIR=lib \
    ..

  ninja
}

package() {
  cd "${srcdir}/${_gitname}/build"

  DESTDIR="${pkgdir}" ninja install
  install -m 644 -D "${srcdir}/wxgui.zip" "${pkgdir}/usr/share/codelite/wxgui.zip"
  install -m 644 -D "${srcdir}/${_gitname}/LICENSE" "${pkgdir}/usr/share/licenses/codelite/LICENSE"
}

zwastik commented on 2022-10-16 07:57 (UTC)

I can't fetch the sources with pikaur, is this an issue for you too?

jgmdev commented on 2019-01-30 19:58 (UTC)

@hpmachining Thanks a lot for taking the time to report it upstream!

hpmachining commented on 2019-01-28 18:28 (UTC) (edited on 2019-01-29 17:21 (UTC) by hpmachining)

@jgmdev I reported an issue upstream about the mariadb issue. MariaDB 10.3 breaks build when using WITH_MYSQL=1 #2215. Also, the tagging issue that caused the pkgver() error should be fixed now, as well. i'm getting a failure from git describe #2211.

Update

Issue has been fixed upstream.

jgmdev commented on 2019-01-22 01:53 (UTC)

@eimis Seems that latest archlinux update of libmariadb changed the API that codelite uses. This issue has to be reported to codelite developer directly. Meanwhile you can set -DWITH_MYSQL=1 to -DWITH_MYSQL=0 to compile without MYSQL support.

SolarAquarion commented on 2019-01-21 16:24 (UTC) (edited on 2019-01-21 16:32 (UTC) by SolarAquarion)

You need to add git to "makedepends"

==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace. ==> ERROR: pkgver() generated an invalid version: warning: tag 'v12.0.10' is really '12.0.10' here v12.0.10.r93.gb98f6878b

eimis commented on 2019-01-21 00:04 (UTC)

something broke :/

/tmp/codelite-git/src/codelite/sdk/databaselayer/src/dblayer/MysqlPreparedStatementWrapper.cpp:97:25: error: ‘MYSQL_STMT’ {aka ‘struct st_mysql_stmt’} has no member named ‘affected_rows’; did you mean ‘prefetch_rows’?

jgmdev commented on 2017-12-10 01:54 (UTC)

@Houkime

Recently I tried to build this package since latest archlinux updates broke many libraries which the codelite binaries depend on but, it seems there is an issue on the codelite git repo because the build was failing with some compile error about some undeclared gtk_* function. Since I was in a hurry of getting codelite working I did a git checkout tags/11.0 which builds fine. I will try later again to see if the issue was fixed and try to work with your suggestions.

Houkime commented on 2017-12-02 23:19 (UTC) (edited on 2017-12-02 23:20 (UTC) by Houkime)

NOTE: some vital functions are not enabled in Plugin management by default. Please take a look.