Package Details: darling-mach-dkms r3131.fa5348c8a-1

Git Clone URL: https://aur.archlinux.org/darling.git (read-only, click to copy)
Package Base: darling
Description: Darwin/macOS emulation layer for Linux (Stable)
Upstream URL: http://www.darlinghq.org
Keywords: Darwin Emulator macOS OSX Stable Wine
Licenses: GPL3
Conflicts: darling-mach-dkms
Provides: darling-mach-dkms
Submitter: jamesbrink
Maintainer: jamesbrink
Last Packager: jamesbrink
Votes: 12
Popularity: 0.039367
First Submitted: 2019-07-10 02:21 (UTC)
Last Updated: 2020-07-27 17:54 (UTC)

Dependencies (20)

Required by (1)

Sources (113)

Pinned Comments

jamesbrink commented on 2019-07-10 02:37 (UTC)

This package is identical to the darling-git, but it will remain locked in on git refs that are known to build. I have labeled it stable in an attempt to clarify this.

Latest Comments

1 2 3 4 Next › Last »

Samega7Cattac commented on 2022-06-09 14:02 (UTC)

Someone flagged this package out-of-date bc of a build error. But now the package is really ou-of-date https://github.com/darlinghq/darling/releases/tag/v0.1.20220213

nobodywasishere commented on 2022-04-26 19:36 (UTC)

@recolic because as per AUR guidelines, submodules need to be downloaded separately, each with their own git url, which unfortunately makes this package a pain to maintain

recolic commented on 2022-04-19 21:49 (UTC)

Why are you listing all submodules, instead of simply running git clone --recursive https://github.com/darlinghq/darling.git? This is the official supported way to build darling.

I am experiencing many compilation error with this PKGBUILD. Maybe it's outdated. However, the extremely simple official repo works very well.

bbaovanc commented on 2021-06-15 21:49 (UTC)

Failed to build (does ruby need to be marked as a dependency?)

==> Making package: darling r3131.fa5348c8a-1 (Tue 15 Jun 2021 04:39:05 PM CDT)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> ruby
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.
error: failed to build 'darling-r3131.fa5348c8a-1 (darling-mach-dkms darling)':
:: Packages failed to build: darling-r3131.fa5348c8a-1 (darling-mach-dkms darling)

After installing ruby, it got to about 10%, and then failed, showing errors about TARGET_OS_DRIVERKIT not being defined:

clang-12: warning: include path for libstdc++ headers not found; pass '-stdlib=libc++' on the command line to use the libc++ standard library instead [-Wstdlibcxx-not-found]
clang-12: warning: include path for libstdc++ headers not found; pass '-stdlib=libc++' on the command line to use the libc++ standard library instead [-Wstdlibcxx-not-found]
/home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/dyldAPIsInLibSystem.cpp:34:6: error: 'TARGET_OS_DRIVERKIT' is not defined, evaluates to 0 [-Werror,-Wundef-prefix=TARGET_OS_]
#if !TARGET_OS_DRIVERKIT
     ^
In file included from /home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/dyldAPIsInLibSystem.cpp:50:
/home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/ImageLoader.h:46:6: error: 'TARGET_OS_DRIVERKIT' is not defined, evaluates to 0 [-Werror,-Wundef-prefix=TARGET_OS_]
#if !TARGET_OS_DRIVERKIT && (BUILDING_LIBDYLD || BUILDING_DYLD)
     ^
In file included from /home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/dyldAPIsInLibSystem.cpp:50:
In file included from /home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/ImageLoader.h:53:
In file included from /home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/dyld3/shared-cache/DyldSharedCache.h:41:
In file included from /home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/dyld3/MachOAnalyzer.h:28:
In file included from /home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/dyld3/MachOLoaded.h:29:
/home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/dyld3/Array.h:33:6: error: 'TARGET_OS_DRIVERKIT' is not defined, evaluates to 0 [-Werror,-Wundef-prefix=TARGET_OS_]
#if !TARGET_OS_DRIVERKIT && (BUILDING_LIBDYLD || BUILDING_DYLD)
     ^
/home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/dyldAPIsInLibSystem.cpp:85:41: error: 'TARGET_OS_DRIVERKIT' is not defined, evaluates to 0
[-Werror,-Wundef-prefix=TARGET_OS_]
#if __IPHONE_OS_VERSION_MIN_REQUIRED || TARGET_OS_DRIVERKIT
                                        ^
/home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/dyldAPIsInLibSystem.cpp:1381:5: error: 'TARGET_OS_DRIVERKIT' is not defined, evaluates to 0 [-Werror,-Wundef-prefix=TARGET_OS_]
#if TARGET_OS_DRIVERKIT
    ^
/home/bbaovanc/.cache/paru/clone/darling/src/darling/src/dyld/src/dyldAPIsInLibSystem.cpp:1488:6: error: 'TARGET_OS_DRIVERKIT' is not defined, evaluates to 0 [-Werror,-Wundef-prefix=TARGET_OS_]
#if !TARGET_OS_DRIVERKIT
     ^
6 errors generated.
make[2]: *** [src/dyld/CMakeFiles/system_dyld_obj.dir/build.make:76: src/dyld/CMakeFiles/system_dyld_obj.dir/src/dyldAPIsInLibSystem.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:15144: src/dyld/CMakeFiles/system_dyld_obj.dir/all] Error 2
make: *** [Makefile:136: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'darling-r3131.fa5348c8a-1 (darling-mach-dkms darling)':
:: Packages failed to build: darling-r3131.fa5348c8a-1 (darling-mach-dkms darling)

crazyquark commented on 2021-05-06 07:52 (UTC) (edited on 2021-05-06 07:54 (UTC) by crazyquark)

The LFS issue has been resolved after I reported it to them on Github, however there is another build issue now.

    #define __CF_NAMED_ENUM(_type, _name)     enum _name : _type _name; enum _name : _type
                                                        ^~~~~~~
    In file included from /home/cristian/Desktop/Workspace/darling/src/darling/src/CoreAudio/CoreAudioUtilityClasses/CoreAudio/PublicUtility/CABufferList.cpp:47:
    In file included from /home/cristian/Desktop/Workspace/darling/src/darling/src/CoreAudio/AudioFileTools/../CoreAudioUtilityClasses/CoreAudio/PublicUtility/CABufferList.h:51:
    In file included from /home/cristian/Desktop/Workspace/darling/src/darling/src/CoreAudio/AudioFileTools/../CoreAudioUtilityClasses/CoreAudio/PublicUtility/CAStreamBasicDescription.h:52:
    In file included from /home/cristian/Desktop/Workspace/darling/src/darling/src/external/corefoundation/include/CoreFoundation/CoreFoundation.h:78:
    In file included from /home/cristian/Desktop/Workspace/darling/src/darling/src/external/corefoundation/include/CoreFoundation/CFPropertyList.h:36:
    In file included from /home/cristian/Desktop/Workspace/darling/src/darling/src/external/corefoundation/include/CoreFoundation/CFStream.h:34:
    /home/cristian/Desktop/Workspace/darling/src/darling/src/external/corefoundation/include/CoreFoundation/CFURL.h:39:9: error: non-defining declaration of enumeration with a fixed underlying type is only permitted as a standalone declaration; missing list of enumerators? [-Welaborated-enum-base]
    typedef CF_ENUM(CFIndex, CFURLPathStyle) {
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

crazyquark commented on 2021-05-05 08:58 (UTC)

@Kido, looks like the https://github.com/darlinghq/darling-swift.git repo has reached a download quota; it might be that they need to insert money into Microsoft's slot machine... I know, this is not helpful but that's the issue, If you try to clone https://github.com/darlinghq/darling-swift.git (the problem repo) you get: This repository is over its data quota. Account responsible for LFS bandwidth should purchase more data packs to restore access.

Kido commented on 2021-05-02 17:02 (UTC)

I'm getting git-lfs error on fetching darling-swift mentioned in the comments.

How can I fix it?

konicks commented on 2021-03-26 16:51 (UTC)

@jamesbrink well it still doesn't build, regardless of clarification or branches it shouldn't be marked as stable if it doesn't build, please fix your app/PKGBUILD as it's a really great project and not being able to install it is a shame

thebagarius commented on 2021-01-18 14:14 (UTC) (edited on 2021-01-18 14:15 (UTC) by thebagarius)

Hi,

To add to what @Alkaris said, I get the following error message while building:

/usr/include/gnu/stubs.h:7:11: fatal error: 'gnu/stubs-32.h' file not found

which results in the same build failure.

dreieck commented on 2021-01-12 19:57 (UTC) (edited on 2021-01-12 19:58 (UTC) by dreieck)

I get the same error which @Alkis reported on 2020-12-08. (Same error as I get for darling-git.)

Thanks for maintaining and making it building again!