Package Details: dolphin-emu-git 5.0.r5739.91dac03c45-1

Git Clone URL: (read-only)
Package Base: dolphin-emu-git
Description: A GameCube / Wii / Triforce emulator
Upstream URL:
Licenses: GPL
Conflicts: dolphin-emu
Provides: dolphin-emu
Submitter: None
Maintainer: alucryd
Last Packager: alucryd
Votes: 94
Popularity: 2.539091
First Submitted: 2011-08-20 13:05
Last Updated: 2017-10-29 17:01

Dependencies (36)

Sources (1)

Latest Comments

VerruckteFuchs commented on 2018-03-09 04:06

Sorry I've taken a long time to reply. I expected to get an email notification, but I'm not sure how that works for replies to comments on somebody else's package(s). Anyway, there was an issue with a few of my packages/libraries. Reinstalling them, including glib2, fixed the problem and everything compiles fine. I use F2FS for / and at one point I was getting a fsck error on boot about corrupted files which was probably a result of some forced shut downs. F2FS doesn't use the /lost+found/ directory, so I opted to delete the files hoping they weren't important and to get rid of the error message. It looks like glib2 and some other packages/libraries got corrupted from the errors I was getting elsewhere, which I opted to delete unknowingly. I guess I'm lucky to have been able to boot at all! Good thing I make backups.

alucryd commented on 2017-12-27 14:50

The wx error is nothing to worry about. 3.1.0 is a development version so we won't have it in our repos, and dolphin builds its own anyway.

The gthread error I can't reproduce, neither locally nor in a clean chroot, which means there's a problem with your particular system. Did you perhaps temper with glib2?

VerruckteFuchs commented on 2017-12-24 00:59

I'm getting an error with gthread I haven't gotten before along with a wxWidgets issue:

-- Could NOT find wxWidgets: Found unsuitable version "3.0.3", but required is at least "3.1.0" (found -pthread;;;-lwx_gtk2u_core-3.0;-lwx_gtk2u_aui-3.0;-lwx_gtk2u_adv-3.0;-lwx_baseu-3.0) -- Using static wxWidgets from Externals -- Some or all of the gtk libraries were not found. (missing: GTK2_GLIB_INCLUDE_DIR GTK2_GLIBCONFIG_INCLUDE_DIR) CMake Error at CMake/CheckLib.cmake:51 (message): gthread-2.0 is required but not found Call Stack (most recent call first): Externals/wxWidgets3/CMakeLists.txt:865 (check_lib)

-- Configuring incomplete, errors occurred! See also "/home/user/.cache/pacaur/dolphin-emu-git/src/dolphin-emu/build/CMakeFiles/CMakeOutput.log". See also "/home/user/.cache/pacaur/dolphin-emu-git/src/dolphin-emu/build/CMakeFiles/CMakeError.log". ==> ERROR: A failure occurred in build(). Aborting... :: failed to build dolphin-emu-cli-git,dolphin-emu-qt-git,dolphin-emu-git package(s)

There may be a new dependency on whatever provides gthread, though it looks like it may be some general breakage with GTK dependencies.

agapito commented on 2017-11-28 14:31

Using jsoncpp1.8.3 from testing repo:

cmake: error while loading shared libraries: cannot open shared object file: No such file or directory

pedrofleck commented on 2017-11-06 20:27

The WX GUI is broken (really small icons/banners, Gdk-critical errors in console and the configurations text isn't formatted correctly) in the last build but I tried Dolphin help and apparently nothing has changed

hcorion commented on 2017-10-29 19:52

That's because you need to launch the Qt version via dolphin-emu-qt2 @gfurst

gfurst commented on 2017-10-28 03:34

I don't get it, apparently the qt version of this is built on this aur repository, however, even if its installed, I'm still running a gtk version?

qlipsos commented on 2017-10-09 03:13

Now depends on "" Provided by "hidapi" package

sleepyoh commented on 2017-07-16 01:12

I can confirm that it build's fine now! =)


alucryd commented on 2017-07-15 17:49

Re-enabled PIE and disabled LTO for the Qt build. Arch now enforces PIE for everything.

All comments