Package Details: ffmpeg-full-git 4.4.r98323.gb35968e060-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-full-git.git (read-only, click to copy)
Package Base: ffmpeg-full-git
Description: Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
Upstream URL: https://www.ffmpeg.org/
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac hwaccel libnpp media nvenc svt video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, ffmpeg-full, ffmpeg-git, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 15
Popularity: 1.55
First Submitted: 2015-12-27 19:22
Last Updated: 2020-06-27 01:04

Dependencies (109)

Required by (1000)

Sources (6)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

clap22 commented on 2018-12-07 19:05

Today this needed to be rebuilt against the new libfdk-aac for me. Is it worth incrementing pkgrel to trigger it for everyone?

clap22 commented on 2018-11-08 00:04

@dbermond I had the same problem as @winneon - I have only an AMD GPU present and if I install cuda it breaks a few apps like mpv.

mpv by default always shows this for me: Cannot load libcuda.so.1 If cuda is present it hangs then segfaults, I can't provide exact error because I'm not touching that cuda package never more.

edit: I created alternate packages based on this and mpv-full-git removing Nvidia and Intel stuff. They're called ffmpeg-amd-full-git and mpv-amd-full-git - its my first try on AUR, but it should work as well as this one and should fix some problems related to cuda presence with AMD gpus.

dbermond commented on 2018-10-05 02:12

Important note:

  • in short: the next time you update your system, use this command: # pacman -Syu intel-media-driver. If you're using intel-media-driver-git you're not affected and you can skip this note.

  • the long story: intel-media-driver is now in the [community] official repository (it is a dependency of intel-media-sdk, which in turn is a dependency of this package). intel-media-driver from the official repository changed the pkgver major number, causing it to be seen as a downgrade by pacman (and AUR helpers of course). This means that pacman will not automatically pull/install intel-media-driver from official repositories when you simply use the usual -Syu. You need to manually specify intel-media-driver alongside with the -Syu command as shown above.

dbermond commented on 2018-09-30 15:59

@SolarAquarion Ok, thank you for the feedback.

SolarAquarion commented on 2018-09-30 00:24

I think it was the testing version of smbc

dbermond commented on 2018-09-28 22:40

@SolarAquarion Package is building fine. Using smbclient 4.8.5 from the official repositories.

SolarAquarion commented on 2018-09-28 19:40

-> Running ffmpeg configure script. Please wait... ERROR: libsmbclient not found

nemethdani commented on 2018-03-15 15:45

Can you add libx265.so to dependencies please? Upgrading the library from the repo breaks ffmpeg.

dbermond commented on 2018-03-06 21:32

@winneon Can you please provide a pastebin output log of the ffmpeg and mpv commands that are generating these crashes for you? You are the first one to report this.

winneon commented on 2018-03-06 00:53

Are you going to update this package to provide a way to not include CUDA and NVENC-related options? These packages have no use to anyone not on Nvidia GPUs and it causes crashes specifically on AMD GPUs.