Package Details: foobnix 3.2.1-1

Git Clone URL: https://aur.archlinux.org/foobnix.git (read-only, click to copy)
Package Base: foobnix
Description: GTK+ music player
Upstream URL: http://www.foobnix.com
Licenses: GPL3
Conflicts: foobnix
Provides: foobnix
Submitter: fusion809
Maintainer: toastercup
Last Packager: toastercup
Votes: 13
Popularity: 0.053118
First Submitted: 2016-02-04 21:49
Last Updated: 2020-05-15 17:58

Latest Comments

1 2 Next › Last »

toastercup commented on 2020-05-15 01:22

@foobnix would you be able to cut a new release with the changes you made to setup.py? Once you do so, I'll be able to release it here as well - the broken Last.fm integration looks to be related to a change in their API, rather than any changes from 3.1 to 3.2.

toastercup commented on 2020-05-07 21:11

@yochananmarqos @foobnix Thanks, friends! I've pushed those changes into the foobnix-git package.

I'm playing around with making the same updates for this package (I saw a new 3.2 release was created on GitHub), but noticed the Last.fm integration isn't working anymore. I'm testing to see if it's something specific to my setup or environment, and whether it's something we can fix through packaging alone. It's also possible the Last.fm integration broke in the previous release, as well - I think they've had some API changes/deprecations lately.

If I can't get it working, I'll file an issue on GitHub, and will make a new release for the AUR package anyway.

yochananmarqos commented on 2020-04-18 15:11

@foobnix: It builds now with your latest commits. Here's my working PKGBUILD. Do the dependencies look right?

foobnix commented on 2020-04-17 14:37

@yochananmarqos I didn't modify setup.py but if you run "python foobnix.py" it is working good with python 3.8 I will check setup.py also

yochananmarqos commented on 2020-04-17 14:24

@foobnix: Your project isn't ready for Python 3.8 yet, it won't build:

  File "setup.py", line 43
    print "generating", mofile
          ^
SyntaxError: Missing parentheses in call to 'print'. Did you mean print("generating", mofile)?

foobnix commented on 2020-04-17 14:04

Please update foobnix player to versoin "foobnix 3.2" and python 3+ and gkt 3+

chapa commented on 2019-09-12 18:00

yochananmarqos thanks.

yochananmarqos commented on 2019-09-03 15:22

@laichiaheng It should build and run now.

laichiaheng commented on 2019-09-03 07:42

running install running install_lib warning: install_lib: 'build/lib' does not exist -- no Python modules to install

running install_scripts error: cannot copy tree 'build/scripts-2.7': not a directory

fusion809 commented on 2019-03-25 19:45

@yochananmarqos:

  1. You're only meant to flag a package out of date when the version number is outdated, not when you think the dependencies are out of date.
  2. I don't use this package any more, so I'll disown it, feel free to adopt it and implement your changes.