Package Details: gimp-devel 2.99.10-2

Git Clone URL: https://aur.archlinux.org/gimp-devel.git (read-only, click to copy)
Package Base: gimp-devel
Description: GNU Image Manipulation Program (Development version)
Upstream URL: https://www.gimp.org/
Licenses: GPL, LGPL
Conflicts: gimp
Provides: gimp
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 22
Popularity: 0.99
First Submitted: 2017-02-02 23:39 (UTC)
Last Updated: 2022-03-25 14:31 (UTC)

Required by (128)

Sources (2)

Pinned Comments

Latest Comments

skalt711 commented on 2022-05-20 17:56 (UTC) (edited on 2022-05-20 17:57 (UTC) by skalt711)

Hi. It fails to compile with clang (13.0.1-2).

  CCLD     gimptool-2.99
clang-13: error: no such file or directory: '../libgimpbase/.libs/libgimpbase-3.0.so'

MajorMayer commented on 2022-03-23 10:14 (UTC)

Yes indeed, installing the highway package before compiling GIMP enables the JXL support. This should be added to the (optional) dependencies, at least if the user opts in for JPEG XL support.

alium commented on 2022-03-21 06:36 (UTC) (edited on 2022-03-21 06:37 (UTC) by alium)

i can confirm, for libjxl support you really need install 'highway' package too!

JPEG XL: yes

ersei commented on 2022-03-03 03:16 (UTC)

Seems like gegl 0.4.36 is out of testing.

twa022 commented on 2022-03-02 04:01 (UTC)

@lyhokia: for the moment you have to install gegl-git to get the required version. 0.4.36 is in testing now though so should be promoted soon enough.

lyhokia commented on 2022-03-01 03:52 (UTC)

I run into this:

error: could not find all required packages:
    gegl>=0.4.36 (wanted by: gimp-devel)

HurricanePootis commented on 2022-02-25 15:24 (UTC) (edited on 2022-02-25 15:24 (UTC) by HurricanePootis)

Gimp 2.99.10 now depends on gegl>=0.4.36, and babl>=0.1.90, and now has a new optional dependency on xdg-desktop-portal for a screenshot API.

Here's a new PKGBUILD I made

# Maintainer: twa022 <twa022 at gmail dot com>

_pkgname=gimp
pkgname=${_pkgname}-devel
pkgver=2.99.10
pkgrel=1
pkgdesc="GNU Image Manipulation Program (Development version)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="http://www.gimp.org/"
license=('GPL' 'LGPL')
depends=('gtk3' 'lcms2' 'libwmf' 'icu' 'enchant' 'libgexiv2' 'librsvg' 'desktop-file-utils'
         'libexif' 'openjpeg2' 'poppler-glib' 'poppler-data' 'openexr' 'mypaint-brushes1'
         'babl>=0.1.90' 'gegl>=0.4.36' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
makedepends=('intltool' 'libxslt' 'glib-networking'
             'alsa-lib' 'curl' 'ghostscript' 'libxpm' 'webkit2gtk'
             'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib' 'libjxl'
             'gjs'  'luajit' 'meson' 'gobject-introspection'
             'gtk-doc' 'xorg-server-xvfb' 'vala')
checkdepends=('xorg-server-xvfb')
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
            'alsa-lib: for MIDI event controller module'
            'curl: for URI support'
            'ghostscript: for postscript support'
            'libxpm: XPM support'
            'webkit2gtk: HTML renderer and web content engine'
            'libheif: HEIF support'
            'libjxl: JPEG XL support'
            'libwebp: WebP support'
            'libmng: MNG support'
            'iso-codes: Language support'
            'aalib: ASCII art support'
            'zlib: Compression routines'
            'gjs: JavaScript scripting support'
            'luajit: LUA scripting support'
            'lua51-lgi: LUA scripting support'
            'xdg-desktop-portal: Screenshot Support')
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2 linux.gpl)
sha256sums=('9e08f1c4a455e8dd4dd0579fe289419e38c835db38e3c0d40cd1137fb0112f29'
            '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
build() {
  cd "${_pkgname}-${pkgver}"
    ./configure \
    --prefix=/usr \
    --sysconfdir=/etc \
    --libdir=/usr/lib \
    --libexecdir=/usr/lib/gimp \
    --datarootdir=/usr/share \
    --enable-mp \
    --enable-gimp-console \
    --enable-gtk-doc
  make
}

package() {
  cd "${_pkgname}-${pkgver}"
  make DESTDIR="${pkgdir}" install
  install -Dm 644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.99/palettes/Linux.gpl"
}

MajorMayer commented on 2022-02-06 22:28 (UTC) (edited on 2022-02-06 22:28 (UTC) by MajorMayer)

I have jpegxl library installed from official Manjaro repos, but still when i build this package i get:

checking for libjxl >= 0.5.0... no

and

Optional Plug-Ins:

Ascii Art: yes

...

JPEG XL: no (libjxl not found)

There is no option to save my images as Jpeg XL when the build finished.

post-factum commented on 2021-10-21 11:44 (UTC)

Hmmm:

Package 'libhwy', required by 'libjxl', not found

Probably, gimp needs community/highway now.

post-factum commented on 2021-10-21 11:41 (UTC)

I wonder why this happens if the package is built in OBS:

[   26s] [111/358] installing libjxl-0.6-1
[   79s] checking for libjxl >= 0.5.0... no
[   90s]   JPEG XL:                   no (libjxl not found)

?

twa022 commented on 2021-09-11 20:34 (UTC)

@Kunda: yes, why? ...

Kunda commented on 2021-09-11 14:34 (UTC)

Is this still being maintained?

katt commented on 2020-12-26 13:26 (UTC)

Needs vala as a makedepend.

configure: error: Vala-plugins are enabled, but could not find vala compiler
==> ERROR: A failure occurred in build().
    Aborting..

Kodehawa commented on 2020-12-17 02:23 (UTC)

Hello! This needs graphviz as a dependency, and not only for make.

This is because GIMP needs gegl:instrospect and gegl will only enable it with graphviz installed. See: https://gitlab.gnome.org/GNOME/gegl/-/commit/1f50456de59c686941a861d299a63bfcd4126ee5

[> <]; -> pacman -F /usr/bin/dot
usr/bin/dot is owned by extra/graphviz 2.44.1-6

mozzi32 commented on 2018-05-07 17:39 (UTC)

or for gegl-0.4 you modify PKGBUILD with gegl-git in 'depends' instead of gegl

butfly commented on 2018-05-03 08:48 (UTC)

for gegl-0.4 upgraded, you need to:

manually install libmypaint, change the PKGBUILD, remove the "enable-gegl'' in "./configure --prefix=/usr --enable-gegl"

from https://aur.archlinux.org/packages/libmypaint/?comments=all

RubenKelevra commented on 2018-04-29 13:30 (UTC)

so if someone want to upgrade to the final version: it's working fine, you just have to manually update the gegl package to 0.4.0 with the checksum. You can use yaourt -Sb gegl to fetch the PKGBUILD easily from ABS. :)

rafaelff commented on 2018-04-16 10:43 (UTC)

@twa022: the 'provides' array should end up like gimp=2.10.0, but since pkgver contains 'rc1' the 'provides' is currently gimp=2.10.0rc1; I recommend using pkgver=2.10.0, adding an extra variable _rc=-RC1 and use version like ${pkgver}${rc} instead, and 'provides' array would be fixed.

magnade commented on 2018-04-01 01:55 (UTC)

anyone hitting bug like: https://bugzilla.gnome.org/show_bug.cgi?id=794818 make sure to recompile libmypaint

sekret commented on 2018-03-29 13:47 (UTC)

Error: GIMP configuration failed.

  • Error: missing dependency poppler-data >= 0.4.7

Please add poppler-data to makedepends.

bm456 commented on 2018-03-28 18:24 (UTC) (edited on 2018-03-28 18:27 (UTC) by bm456)

Updated to 2.10.RC1 https://p.teknik.io/E1Peq

donny commented on 2018-01-06 04:09 (UTC)

If gimp argues about missing libjson-c.so.2 after update of core/json-c, rebuild the dependent package "libmypaint".

sekret commented on 2017-12-27 13:27 (UTC)

Please add glib-networking to makedepends, otherwise the package doesn't build.

SinClaus commented on 2017-12-16 07:01 (UTC) (edited on 2017-12-16 07:03 (UTC) by SinClaus)

@twa022 Thanks, I'v installed babl/gegl from git and they are with right version numbers, but yaourt don't know about this, it know about old versions only.

$ yaourt -Ss babl-git

aur/babl-git 0.1.30.42.gcc29a76-1 [installed: 0.1.38.23.g5aa4a51-1] (106) (0.86)

babl is a dynamic, any to any, pixel format translation library.

SinClaus commented on 2017-12-15 02:40 (UTC)

Yes, I can modify, but developer think something when say about dependencies.

maderios commented on 2017-12-14 14:14 (UTC)

@SinClaus You have to modify dependencies in PKGBUILD. I built gimp-devel 2.9.8 with babl-git and gegl-git. It works fine.

twa022 commented on 2017-12-14 14:01 (UTC)

@SinClaus: the pkgver for babl-git and gegl-git will be updated at build time. Build and install those packages in that order, them gimp-devel. If you feel comfortable editing the official babl and gegl PKGBUILDs, both required versions have been released by developers just not yet packaged by the arch packagers yet.

SinClaus commented on 2017-12-14 13:46 (UTC)

Fuck!!! Where are babl and gegl? In the git repo we have gegl-git 0.3.20.13-1. Why gimp is released without them?

twa022 commented on 2017-12-14 01:50 (UTC)

My 2.9.8 build successfully loads the python plugins - let me know if you experience errors. You may need to remove ~/.config/GIMP/2.9/pluginrc -- I got this error on 2.9.6 to 2.9.8 upgrade: GIMP-Error: Skipping '/home/<username>/.config/GIMP/2.9/pluginrc': wrong pluginrc file format version.</username>

twa022 commented on 2017-12-13 04:13 (UTC) (edited on 2017-12-14 01:50 (UTC) by twa022)

Gimp 2.9.8 requires babl>=0.1.38 and gegl>=0.3.24. You will need to build those packages yourself until official repos are updated to latest versions. Or build babl-git and gegl-git from AUR.

misanthropist commented on 2017-09-28 20:39 (UTC)

@therealfarfetchd I have the same problem, and your workaround almost did the trick, but I had to change /usr/lib/gimp/2.0/plug-ins/*.py to /usr/lib/gimp/2.0/plug-ins/**/*.py to include .py files in subdirectories as well.

2xsaiko commented on 2017-09-28 20:07 (UTC)

For some reason, /usr/bin/env doesn't want to find python2 when loading GIMP, so the python interpreter isn't available. Here's a workaround: for file in /usr/lib/gimp/2.0/plug-ins/*.py; do sed -i 's|#! */usr/bin/env python2|#!/usr/bin/python2|' "$file"; done Does anyone else have this problem?

donny commented on 2017-08-11 18:21 (UTC)

Missing build dependencies: libraw lensfun suitesparse

xuiqzy commented on 2017-03-01 03:24 (UTC)

Please change the url of the source and the upstream url to the TLS encrypted https variant! thanks :)