Package Details: gimp-devel 2.9.8-1

Git Clone URL: (read-only)
Package Base: gimp-devel
Description: GNU Image Manipulation Program (Development version)
Upstream URL:
Licenses: GPL, LGPL
Conflicts: gimp
Provides: gimp=2.9.8
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 11
Popularity: 1.810078
First Submitted: 2017-02-02 23:39
Last Updated: 2017-12-14 01:43

Dependencies (32)

Required by (148)

Sources (2)

Latest Comments

donny commented on 2018-01-06 04:09

If gimp argues about missing after update of core/json-c, rebuild the dependent package "libmypaint".

sekret commented on 2017-12-27 13:27

Please add glib-networking to makedepends, otherwise the package doesn't build.

SinClaus commented on 2017-12-16 07:01

@twa022 Thanks, I'v installed babl/gegl from git and they are with right version numbers, but yaourt don't know about this, it know about old versions only.

$ yaourt -Ss babl-git

aur/babl-git [installed:] (106) (0.86)

babl is a dynamic, any to any, pixel format translation library.

SinClaus commented on 2017-12-15 02:40

Yes, I can modify, but developer think something when say about dependencies.

maderios commented on 2017-12-14 14:14

@SinClaus You have to modify dependencies in PKGBUILD. I built gimp-devel 2.9.8 with babl-git and gegl-git. It works fine.

twa022 commented on 2017-12-14 14:01

@SinClaus: the pkgver for babl-git and gegl-git will be updated at build time. Build and install those packages in that order, them gimp-devel. If you feel comfortable editing the official babl and gegl PKGBUILDs, both required versions have been released by developers just not yet packaged by the arch packagers yet.

SinClaus commented on 2017-12-14 13:46

Fuck!!! Where are babl and gegl? In the git repo we have gegl-git Why gimp is released without them?

twa022 commented on 2017-12-14 01:50

My 2.9.8 build successfully loads the python plugins - let me know if you experience errors. You may need to remove ~/.config/GIMP/2.9/pluginrc -- I got this error on 2.9.6 to 2.9.8 upgrade: GIMP-Error: Skipping '/home/<username>/.config/GIMP/2.9/pluginrc': wrong pluginrc file format version.</username>

twa022 commented on 2017-12-13 04:13

Gimp 2.9.8 requires babl>=0.1.38 and gegl>=0.3.24. You will need to build those packages yourself until official repos are updated to latest versions. Or build babl-git and gegl-git from AUR.

misanthropist commented on 2017-09-28 20:39

@therealfarfetchd I have the same problem, and your workaround almost did the trick, but I had to change /usr/lib/gimp/2.0/plug-ins/*.py to /usr/lib/gimp/2.0/plug-ins/**/*.py to include .py files in subdirectories as well.

All comments