Package Details: gnome-terminal-transparency 3.52.2-1

Git Clone URL: (read-only, click to copy)
Package Base: gnome-terminal-transparency
Description: The GNOME Terminal Emulator with background transparency
Upstream URL:
Keywords: gnome terminal transparency
Licenses: cc-by-sa-3.0, GPL-3.0-or-later, GPL-3.0-only, GFDL-1.3-only
Groups: gnome-extra
Conflicts: gnome-terminal
Provides: gnome-terminal
Submitter: hoschi
Maintainer: hoschi
Last Packager: hoschi
Votes: 110
Popularity: 0.27
First Submitted: 2016-04-12 21:23 (UTC)
Last Updated: 2024-05-30 19:03 (UTC)

Required by (11)

Sources (2)

Pinned Comments

hoschi commented on 2017-04-26 15:38 (UTC) (edited on 2022-11-06 16:47 (UTC) by hoschi)


This is less invasive than gnome-terminal-fedora because it doesn't include the notification feature. Therefore you can stay with the regular vte3 and vte-common! To fulfill the makedepends you probably need to install the packages itstool, docbook-xsl, appstream-glib and yelp-tools. Ensure that you have installed the package group base-devel, which is a requirement to use AUR.

Top Workaround with devilspie, fore- and background are transparent.

Bottom Background transparency with gnome-terminal, better readability.

@Users of Manjaro

Please check if Manjaro is providing the same version of GNOME, especially the dependencies vte3 and vte-common. If you want the package for an older release, you can pick the required files from the git log.

Latest Comments

1 2 3 4 5 6 .. 11 Next › Last »

NYI_87 commented on 2024-06-14 16:41 (UTC)

Had to install glib2 first, even though it's marked as a dependency here. Otherwise received an error about gdbus_codegen.

hoschi commented on 2024-06-07 11:11 (UTC)

Yep :) commented on 2024-06-07 11:09 (UTC)

Oops, it's a dependency of base-devel. My bad commented on 2024-06-07 11:07 (UTC)

The patch package is missing from the make dependencies

hoschi commented on 2024-04-01 10:57 (UTC) (edited on 2024-04-01 11:21 (UTC) by hoschi)


Good Morning!

• Arch and Manjoro are different distributions.
• You can use this package, likely on Manjaro. Keep in mind that AUR is intended for Arch.
• Check the installed version of vte3 (i.e. pacman -Q vte3). Again, you must have vte3 0.76installed. It is a requirement by gnome-terminal 3.52.
• Arch does not support partial upgrades. Package maintainers can require specific versions, but they often do not.

Your response indicates that you use Manjaro, if that is the case:
Manjaro ships today (2024-04-01) the previous versions of gnome-terminal and vte3. The new packages are currently in the unstable branch. If you want to use the package here, you can pick the previous version from the git log or wait till Manjaro upgrades. Switching to unstable is something I don't recommend for you.

The deceiving versions numbers:
I hope I have described it correctly; please don't punish me. The version number 2.91 is part of the library soname, and the version number 0.74 is part of the package name. The library sonames are important for linking and indicating compatibility. Here is a brief description. The soname says every executable or library compatible with 2.xx can link to this library. The developers of vte3 didn't bump the major or the minor version of the soname. That's their decision.
The developers of gnome-terminal 3.52 require vte3 with soname ` 2.91' and also require the package version 0.76.

I hope this helps you and explains the background.
Happy easter.

linuxghost commented on 2024-04-01 09:31 (UTC) (edited on 2024-04-01 09:34 (UTC) by linuxghost)

I don't understand. 1) Build/pkgconfig needs vte-2.91 2) Found 0.74.2 3) vte-2.91 is located in /usr/bin and owned by vte3 0.74.2-1 !

The required version of vte is there, nothing a Manjaro update would change IMHO. How can I change the PKGBUILD to piont to the location of vte-2.91?

hoschi commented on 2024-03-31 13:12 (UTC)

Looks like your Arch needs an upgrade (pacman -Syu). Or you are using Manjaro, which seems to lag behind (in this case I recommend the previous version from the source tree).
See pinned post above :)

linuxghost commented on 2024-03-31 10:05 (UTC)

Build fails with: Dependency vte-2.91 found: NO found 0.74.2 but need: '>=0.76.0' Found CMake: /usr/bin/cmake (3.28.3) Run-time dependency vte-2.91 found: NO (tried cmake)

gnome-terminal-3.52.0/ ERROR: Dependency lookup for vte-2.91 with method 'pkgconfig' failed: Invalid version, need 'vte-2.91' ['>=0.76.0'] found '0.74.2'.

pacown vte-2.91 /usr/bin/vte-2.91 is owned by vte3 0.74.2-1

hoschi commented on 2023-12-12 19:14 (UTC) (edited on 2023-12-18 18:38 (UTC) by hoschi)

I will update the package as soon as possible. My laptop did need a new mainboard 🫢

// edit DONE

hoschi commented on 2023-02-19 21:48 (UTC) (edited on 2023-02-19 21:48 (UTC) by hoschi)

I've removed the debug option. The vanilla package also removed it.