Package Details: gnome-terminal-transparency 3.30.2-1

Git Clone URL: https://aur.archlinux.org/gnome-terminal-transparency.git (read-only)
Package Base: gnome-terminal-transparency
Description: The GNOME Terminal Emulator, with background transparency
Upstream URL: https://wiki.gnome.org/Apps/Terminal
Keywords: gnome terminal transparency
Licenses: GPL
Groups: gnome
Conflicts: gnome-terminal
Provides: gnome-terminal=3.30.2
Submitter: hoschi
Maintainer: hoschi
Last Packager: hoschi
Votes: 52
Popularity: 1.159875
First Submitted: 2016-04-12 21:23
Last Updated: 2018-11-03 21:01

Required by (8)

Sources (2)

Pinned Comments

hoschi commented on 2017-04-26 15:38

Hi! This is less invasive than gnome-terminal-fedora[1], because it doesn't include the notify-feature. Therefore you can stay with the regular vte and vte-common! To fullfill the makedepends you probably need to install the packages 'itstool docbook-xsl appdata-tools yelp-tools', they can be removed when makepkg was executed successfully. Please ensure that you have installed the package group 'base-devel', which is a requirement to use AUR.

http://i.imgur.com/whZYSLX.png

Top: Workaround with devilspie, fore- and background are transparent.

Bottom: Background transparency with gnome-terminal, better readability.

For those who want the notfiy-feature and some other minor changes, look here:

[1] https://aur.archlinux.org/packages/gnome-terminal-fedora

Latest Comments

1 2 3 4 5 Next › Last »

hoschi commented on 2018-10-07 09:31

Well done surrealistic :)

surrealistic commented on 2018-10-07 09:24

I just fixed it, it was because my PKG_CONFIG_PATH variable was bad defined and it couldn't find the required files.

surrealistic commented on 2018-10-05 10:29

Yes, looks like GNOME is not installed, but I'm already using GNOME and it's installed with the GTK libraries. I thought that maybe it's because I was using the Plasma session in that moment and I tried again with the GNOME session with the same result so I disabled SDDM and I enabled GDM and I started the GNOME session again to try to install gnome-terminal-transparency but it returns the same.

hoschi commented on 2018-10-04 22:27

The package requirements are not fulfilled. Looks like GNOME is not installed?

surrealistic commented on 2018-10-04 14:38

Checking GTK+ fails:

checking which gtk+ version to compile against... 3.0 Package gdk-3.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gdk-3.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gdk-3.0' found checking for TERM... no configure: error: Package requirements (vte-2.91 >= 0.54.1 glib-2.0 >= 2.42.0 gio-2.0 >= 2.34.0 gtk+-3.0 >= 3.12.0 gsettings-desktop-schemas >= 0.1.0 dconf >= 0.14.0 uuid libpcre2-8 >= 10.00 ) were not met:

No package 'vte-2.91' found No package 'glib-2.0' found No package 'gio-2.0' found No package 'gtk+-3.0' found No package 'gsettings-desktop-schemas' found No package 'dconf' found No package 'uuid' found No package 'libpcre2-8' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variables TERM_CFLAGS and TERM_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details. ==> ERROR: A failure occurred in build(). Aborting... Error making: gnome-terminal-transparency

hoschi commented on 2018-09-10 19:56

@beto: Hello! Please install base-devel this is a requirement for using AUR.

beto commented on 2018-09-10 15:59

Running makepkg launches an error:

PKGBUILD: line 29: patch: command not found ==> ERROR: A failure occurred in prepare(). Aborting...

Edit: My mistake, if somebody gets the same it's because you need to install "patch" package with "pacman -S patch"

hoschi commented on 2018-05-23 05:41

Hello abdulhakeem! Seems like upstream has bumped the requirement from “0.52.0“ to “0.52.2“. The official package from Archlinux requires only “0.52.0”, maybe I should raise it for my package. Generally I like to keep it aligned to the official one.

Your fix: pacman -Syu

The Archlinux maintainers have provided vte-0.52.2 around 34 hours ago, with an up-to-date installation you cannot hit that problem.

abdulhakeem commented on 2018-05-23 04:20

I'm not able to update to the latest version (2018-5-22), error output below:

<hr>

Requested 'vte-2.91 >= 0.52.2' but version of vte is 0.52.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variables TERM_CFLAGS and TERM_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details. ==> ERROR: A failure occurred in build(). Aborting... :: failed to build gnome-terminal-transparency package(s)

hoschi commented on 2018-04-04 09:47

Hello recolic! I've changed a detail in the package and it therefore uses directly the GNU-Autotools, which it didn't before. Please install the the package group 'base-devel'[1] which is a requirement[2] for using AUR. This should fix your problem[3].

[1] https://www.archlinux.org/groups/x86_64/base-devel/ [2] https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started [3] https://wiki.archlinux.org/index.php/Arch_User_Repository#Foo_in_the_AUR_does_not_compile_when_I_run_makepkg.3B_what_should_I_do.3F