Package Details: gst-plugins-rs 1.24.2-1

Git Clone URL: https://aur.archlinux.org/gst-plugins-rs.git (read-only, click to copy)
Package Base: gst-plugins-rs
Description: GStreamer plugins written in Rust (dav1d disabled when fail to build)
Upstream URL: https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs
Keywords: gstreamer rust
Licenses: MIT, Apache, LGPL2.1, MPL2
Conflicts: gst-plugin-gtk4
Provides: gst-plugin-gtk4
Submitter: oktopod11
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 3
Popularity: 0.21
First Submitted: 2019-07-02 09:36 (UTC)
Last Updated: 2024-04-09 12:52 (UTC)

Latest Comments

1 2 3 Next › Last »

yochananmarqos commented on 2024-04-09 16:39 (UTC)

@FabioLolix: There's no need to disable LTO, just add CFLAGS+=" -ffat-lto-objects" to the build function.

yochananmarqos commented on 2024-03-19 17:16 (UTC) (edited on 2024-03-19 17:40 (UTC) by yochananmarqos)

@FabioLolix: Ah, sorry. I was using an old, local PKGBUILD.

By the way, we have GStreamer 1.24.0, this package should be updated to match it. If for some reason you're sticking with 1.22.X, why did you update to 1.22.9 and not 1.22.11? I just built 1.24.0 fine, by the way.

Oh and the SPDX license identifiers are:

license=('Apache-2.0 AND LGPL-2.1-or-later AND MIT AND MPL-2.0')

FabioLolix commented on 2024-03-19 16:56 (UTC)

@yochananmarqos can't reproduce and dav1d is disabled

yochananmarqos commented on 2024-03-19 16:42 (UTC)

@FabioLolix: No version of this can be built right now as dav1d 1.4.0 is too new. 1.22.9 requires <=1.2.1 and 1.24.0 requires <=1.3.

--- stderr
  thread 'main' panicked at /build/gst-plugins-rs/src/cargo-home/registry/src/index.crates.io-6f17d22bba15001f/dav1d-sys-0.7.2/build.rs:83:10:
  called `Result::unwrap()` on an `Err` value: `PKG_CONFIG_ALLOW_SYSTEM_CFLAGS="1" PKG_CONFIG_ALLOW_SYSTEM_LIBS="1" PKG_CONFIG_PATH="/build/gst-plugins-rs/src/build/meson-uninstalled" "/usr/bin/pkg-config" "--libs" "--cflags" "dav1d" "dav1d >= 1.0.0" "dav1d <= 1.2.1"` did not exit successfully: exit status: 1
  error: could not find system library 'dav1d' required by the 'dav1d-sys' crate

  --- stderr
  Package dependency requirement 'dav1d <= 1.2.1' could not be satisfied.
  Package 'dav1d' has version '1.4.0', required version is '<= 1.2.1'

FabioLolix commented on 2023-12-02 12:40 (UTC)

Yo, I'm a bit busy, PR can be made here https://github.com/FabioLolix/PKGBUILD-AUR_fix


in prepare+build: export CARGO_HOME="$srcdir/CARGO_HOME"

I'm not sure about adding this

begin-theadventu commented on 2023-12-02 11:01 (UTC)

Has this package been abandoned? Should I submit an orphan request?

begin-theadventu commented on 2023-11-07 12:43 (UTC) (edited on 2023-11-07 12:54 (UTC) by begin-theadventu)

@FabioLolix

  • isolate cargo from home:

in prepare+build: export CARGO_HOME="$srcdir/CARGO_HOME"

  • build error fix:

export RUSTUP_TOOLCHAIN=stable

  • dependencies:

core: glibc gcc-libs glib2 openssl

other already depend on them: (gtk4:) pango, cairo, graphene; gst-plugins-base-libs (gst-plugins-bad-libs), gstreamer (gst-x).

provides=('gst-plugin-gtk4')

yochananmarqos commented on 2023-10-17 17:05 (UTC)

@FabioLolix: This should provide gst-plugin-gtk4 so users can have either installed to satisfy the dependency.