Package Details: kate-git 24.04.70_r21426.g34a64411f-1

Git Clone URL: https://aur.archlinux.org/kate-git.git (read-only, click to copy)
Package Base: kate-git
Description: Advanced text editor
Upstream URL: https://apps.kde.org/kate/
Keywords: editor kde text
Licenses: GPL-2.0-or-later, LGPL-2.0-or-later
Groups: kde-utilities, kde-applications-git, kde-utilities-git
Conflicts: kate, kwrite, kwrite-git
Provides: kate, kwrite, kwrite-git
Replaces: kwrite-git
Submitter: tajidinabd
Maintainer: IslandC0der (chaotic-aur)
Last Packager: IslandC0der
Votes: 6
Popularity: 0.000262
First Submitted: 2015-10-10 01:59 (UTC)
Last Updated: 2024-03-26 04:21 (UTC)

Latest Comments

1 2 Next › Last »

dr460nf1r3 commented on 2023-10-21 16:23 (UTC)

I'm dropping maintenance of this package as I'm quite busy maintaining other things.

dreieck commented on 2023-09-15 12:23 (UTC)

cmake fails for me:

-- Could NOT find KF6I18n (missing: KF6I18n_DIR)
-- Could NOT find KF6I18n: found neither KF6I18nConfig.cmake nor kf6i18n-config.cmake 
-- Could NOT find KF6CoreAddons (missing: KF6CoreAddons_DIR)
-- Could NOT find KF6CoreAddons: found neither KF6CoreAddonsConfig.cmake nor kf6coreaddons-config.cmake 
-- Could NOT find KF6GuiAddons (missing: KF6GuiAddons_DIR)
-- Could NOT find KF6GuiAddons: found neither KF6GuiAddonsConfig.cmake nor kf6guiaddons-config.cmake 
-- Could NOT find KF6Crash (missing: KF6Crash_DIR)
-- Could NOT find KF6Crash: found neither KF6CrashConfig.cmake nor kf6crash-config.cmake 
-- Could NOT find KF6IconThemes (missing: KF6IconThemes_DIR)
-- Could NOT find KF6IconThemes: found neither KF6IconThemesConfig.cmake nor kf6iconthemes-config.cmake 
-- Could NOT find KF6TextEditor (missing: KF6TextEditor_DIR)
-- Could NOT find KF6TextEditor: found neither KF6TextEditorConfig.cmake nor kf6texteditor-config.cmake 
-- Could NOT find KF6DocTools (missing: KF6DocTools_DIR)
-- Could NOT find KF6DocTools: found neither KF6DocToolsConfig.cmake nor kf6doctools-config.cmake 
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find KF6 (missing: I18n CoreAddons GuiAddons Crash IconThemes
  TextEditor) (Required is at least version "5.240.0")
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/ECM/find-modules/FindKF6.cmake:93 (find_package_handle_standard_args)
  CMakeLists.txt:48 (find_package)


-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().

Seems like some dependencies need to be updated, but I don't know which.

Also,

  • optional dependency python-language-server should be replaced by python-lsp-server,
  • consider changing optional dependency konsole-git to konsole,
  • make dependency extra-cmake-modules needs to be replaced by extra-cmake-modules-git (it needs very new variant) or extra-cmake-modules>=5.240.0.

Thanks for maintaining!

Riedler commented on 2023-08-09 13:17 (UTC) (edited on 2023-08-09 13:18 (UTC) by Riedler)

ugh, lsp server crashes instantly since recently. Maybe fmt10 related? idk, something about the json parser not accepting some data.

dr460nf1r3 commented on 2022-07-12 00:27 (UTC)

Sure thing, you have made good points!

MarsSeed commented on 2022-07-11 15:49 (UTC)

If you'd like, you could make me co-maintainer. :)

I would use this -git package every day so I should be able to keep it in quite a good shape. :)

MarsSeed commented on 2022-07-11 15:48 (UTC)

python-language-server is broken, and is pending deletion now.

MarsSeed commented on 2022-06-14 16:10 (UTC)

Hi, thank you for maintaining this package.

Could you please kindly adjust some dependencies?

First, I've noted some differences from Arch repo's kate. Would you edit your PKGBUILD dependencies to be similar to the former? Here is a list of changes required for that:

  • remove kitemmodels
  • remove the obsolete python-language-server and add python-lsp-server (optional): Python LSP support
  • change konsole-git to konsole (allow non-git version, as it's a separate app and differing release versions should work together)
  • add git (optional): git-blame plugin
  • add markdownpart (optional): Markdown preview
  • add svgpart (optional): SVG preview

There is a mistake in Arch kate and therefore here as well, please kindly amend it:

  • remove rust (optional) and replace it with rust-analyzer (optional): Rust LSP support

You can also add additional optdepends that the repo package misses:

I know it seems a lot but it would be really helpful! Thank you in advance!

dr460nf1r3 commented on 2021-03-30 15:45 (UTC) (edited on 2021-03-31 09:21 (UTC) by dr460nf1r3)

Well its aligned with most of the KDE/Plasma -git packages in AUR/Chaotic-AUR

malcolm commented on 2021-03-30 14:17 (UTC)

are you sure that all these dependencies need to be the git version? they are pulling in several others and the whole system will change.

i have been using a very alternative version of this pkgbuild for a long time, that i changed myself (not very professional), and i did not need to use these git packages.

dr460nf1r3 commented on 2021-03-30 10:49 (UTC)

After having seen the preview of the new version I had to get this done. Looks too good :D