Package Details: kdenlive-git 22.11.70.r16404-1

Git Clone URL: https://aur.archlinux.org/kdenlive-git.git (read-only, click to copy)
Package Base: kdenlive-git
Description: A non-linear video editor for Linux using the MLT video framework. KF5 Frameworks (Latest Applications GIT Version)
Upstream URL: http://www.kdenlive.org/
Licenses: GPL
Conflicts: kdenlive
Provides: kdenlive
Submitter: nous
Maintainer: evorster
Last Packager: evorster
Votes: 65
Popularity: 0.005630
First Submitted: 2011-11-28 22:37 (UTC)
Last Updated: 2022-07-21 17:01 (UTC)

Latest Comments

evorster commented on 2021-06-25 20:28 (UTC)

Oooh, they have finally switched over to mlt7! Awesome, I'll update the package.

ruestique commented on 2021-06-25 14:08 (UTC)

-- Performing Test _OFFT_IS_64BIT -- Performing Test _OFFT_IS_64BIT - Success -- Performing Test HAVE_DATE_TIME -- Performing Test HAVE_DATE_TIME - Success CMake Warning (dev) at /usr/share/ECM/modules/ECMFindModuleHelpers.cmake:112 (message): Your project should require at least CMake 3.16.0 to use FindKF5.cmake Call Stack (most recent call first): /usr/share/ECM/find-modules/FindKF5.cmake:30 (ecm_find_package_version_check) CMakeLists.txt:50 (find_package) This warning is for project developers. Use -Wno-dev to suppress it.

-- Found KF5Archive: /usr/lib64/cmake/KF5Archive/KF5ArchiveConfig.cmake (found version "5.83.0") -- Found KF5Bookmarks: /usr/lib64/cmake/KF5Bookmarks/KF5BookmarksConfig.cmake (found version "5.83.0") -- Found KF5CoreAddons: /usr/lib64/cmake/KF5CoreAddons/KF5CoreAddonsConfig.cmake (found version "5.83.0") -- Found KF5Config: /usr/lib64/cmake/KF5Config/KF5ConfigConfig.cmake (found version "5.83.0") -- Found KF5ConfigWidgets: /usr/lib64/cmake/KF5ConfigWidgets/KF5ConfigWidgetsConfig.cmake (found version "5.83.0") -- Found KF5DBusAddons: /usr/lib64/cmake/KF5DBusAddons/KF5DBusAddonsConfig.cmake (found version "5.83.0") -- Found KF5KIO: /usr/lib64/cmake/KF5KIO/KF5KIOConfig.cmake (found version "5.83.0") -- Found KF5WidgetsAddons: /usr/lib64/cmake/KF5WidgetsAddons/KF5WidgetsAddonsConfig.cmake (found version "5.83.0") -- Found KF5NotifyConfig: /usr/lib64/cmake/KF5NotifyConfig/KF5NotifyConfigConfig.cmake (found version "5.83.0") -- Found KF5NewStuff: /usr/lib64/cmake/KF5NewStuff/KF5NewStuffConfig.cmake (found version "5.83.0") -- Found KF5XmlGui: /usr/lib64/cmake/KF5XmlGui/KF5XmlGuiConfig.cmake (found version "5.83.0") -- Found KF5Notifications: /usr/lib64/cmake/KF5Notifications/KF5NotificationsConfig.cmake (found version "5.83.0") -- Found KF5GuiAddons: /usr/lib64/cmake/KF5GuiAddons/KF5GuiAddonsConfig.cmake (found version "5.83.0") -- Found Gettext: /usr/bin/msgmerge (found version "0.21") -- Found KF5TextWidgets: /usr/lib64/cmake/KF5TextWidgets/KF5TextWidgetsConfig.cmake (found version "5.83.0") -- Found KF5IconThemes: /usr/lib64/cmake/KF5IconThemes/KF5IconThemesConfig.cmake (found version "5.83.0") -- Found KF5Declarative: /usr/lib64/cmake/KF5Declarative/KF5DeclarativeConfig.cmake (found version "5.83.0") -- Found KF5Solid: /usr/lib64/cmake/KF5Solid/KF5SolidConfig.cmake (found version "5.83.0") -- Found KF5DocTools: /usr/lib64/cmake/KF5DocTools/KF5DocToolsConfig.cmake (found version "5.83.0") -- Found KF5FileMetaData: /usr/lib64/cmake/KF5FileMetaData/KF5FileMetaDataConfig.cmake (found version "5.83.0") -- Found KF5Crash: /usr/lib64/cmake/KF5Crash/KF5CrashConfig.cmake (found version "5.83.0") -- Found KF5Purpose: /usr/lib64/cmake/KF5Purpose/KF5PurposeConfig.cmake (found version "5.83.0") -- Found KF5: success (found version "5.83.0") found components: Archive Bookmarks CoreAddons Config ConfigWidgets DBusAddons KIO WidgetsAddons NotifyConfig NewStuff XmlGui Notifications GuiAddons TextWidgets IconThemes Declarative Solid DocTools FileMetaData Crash Purpose -- Checking for module 'mlt++-7' -- Package 'mlt++-7', required by 'virtual:world', not found CMake Error at /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find MLT (missing: MLT_LIBRARIES MLTPP_LIBRARIES MLT_INCLUDE_DIR) (Required is at least version "7.0.0") Call Stack (most recent call first): /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE) cmake/modules/FindMLT.cmake:65 (find_package_handle_standard_args) CMakeLists.txt:61 (find_package)

-- Configuring incomplete, errors occurred! See also "/home/chibo/.cache/yay/kdenlive-git/src/build/CMakeFiles/CMakeOutput.log". ==> ERROR: A failure occurred in build(). Aborting... error making: kdenlive-git ↪

K4LCIFER commented on 2021-06-22 02:24 (UTC)

Could not build due to errors:

CMake Warning (dev) at /usr/share/ECM/modules/ECMFindModuleHelpers.cmake:112 (message):
  Your project should require at least CMake 3.16.0 to use FindKF5.cmake
Call Stack (most recent call first):
  /usr/share/ECM/find-modules/FindKF5.cmake:30 (ecm_find_package_version_check)
  CMakeLists.txt:50 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.
-- Could NOT find KF5Purpose (missing: KF5Purpose_DIR)
-- Could NOT find KF5Purpose: found neither KF5PurposeConfig.cmake nor kf5purpose-config.cmake 
CMake Error at /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find KF5 (missing: Declarative) (found version "5.83.0")
Call Stack (most recent call first):
  /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/ECM/find-modules/FindKF5.cmake:93 (find_package_handle_standard_args)
  CMakeLists.txt:50 (find_package)

carlosnewmusic commented on 2021-04-25 17:01 (UTC)

Error build https://pastebin.com/ysSBdBcd

titaniumtown commented on 2021-04-08 20:18 (UTC)

Missing dependency: qt5-networkauth

evorster commented on 2021-03-30 11:45 (UTC) (edited on 2021-03-30 11:47 (UTC) by evorster)

Thanks for checking over my work.

The makedepends in kdenlive-git is pretty much the same as kdenlive, except for the added git dependency, as we are checking out the source with it.

I had a look with namcap, and there are a couple of new dependencies, but nothing that qualifies as "lots of stuff"

Can you please post a list of this stuff that is missing?

dr460nf1r3 commented on 2021-03-30 10:39 (UTC)

This misses lots of stuff in makedepends, see the ASP PKGBUILD for reference (asp checkout kdenlive)

ruestique commented on 2021-03-09 00:56 (UTC)

-- Found KF5: success (found version "5.79.0") found components: Archive Bookmarks CoreAddons Config ConfigWidgets DBusAddons KIO WidgetsAddons NotifyConfig NewStuff XmlGui Notifications GuiAddons TextWidgets IconThemes Declarative Solid DocTools FileMetaData Crash Purpose 
CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package):
  Could not find a package configuration file provided by "Qt5NetworkAuth"
  with any of the following names:

    Qt5NetworkAuthConfig.cmake
    qt5networkauth-config.cmake

  Add the installation prefix of "Qt5NetworkAuth" to CMAKE_PREFIX_PATH or set
  "Qt5NetworkAuth_DIR" to a directory containing one of the above files.  If
  "Qt5NetworkAuth" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:55 (find_package)

tallero commented on 2020-06-14 01:44 (UTC)

Fixed PKGBUILD, please merge.

beaux_monde commented on 2020-06-13 19:39 (UTC)

Update sources URL.

evorster commented on 2019-11-04 04:56 (UTC)

@electricprism

This package follows the master branch, the last update to which was done 8 hours ago. How much more up to date do you want?

kdenlive-release-git follows the latest released branch, currently 19.08

electricprism commented on 2019-11-04 02:51 (UTC)

It seems to me that https://invent.kde.org/kde/kdenlive.git

Is newer than https://cgit.kde.org/kdenlive.git/?

Or at least that 19.04 should be revved to 19.08 -- this is a git package afterall

rican-linux commented on 2019-04-22 03:30 (UTC)

for non plasma 5 users the plasma-framework package is needed as a dependency to build and run as of now.

muralisc commented on 2017-04-01 17:54 (UTC)

Cribbed for libSDL-1.2.so.0 while starting. Fixed by installing "sdl_image" manually

grandchild commented on 2016-11-13 00:36 (UTC)

you should add extra/qt5-quickcontrols to the dependencies. it segfaults on start without it.

syarifqwerty commented on 2016-07-28 02:21 (UTC)

i can't open title for saved title. must rename saved title with *.kdenlivetitle

evorster commented on 2016-07-02 01:57 (UTC)

The dependencies were added to be the same as the official kdenlive package. Thanks for the info on the quotation marks, it is fixed now.

blackhole commented on 2016-07-01 22:03 (UTC)

Also some quotation marks missing in depends

blackhole commented on 2016-07-01 22:01 (UTC)

Why plasma-desktop?

evorster commented on 2016-05-27 08:53 (UTC)

The issue with the home directory deletion has been corrected, according to the git comments. https://quickgit.kde.org/?p=kdenlive.git

osc commented on 2016-05-25 18:16 (UTC) (edited on 2016-05-25 18:29 (UTC) by osc)

i had the same issue! my /home/myuser was deleted! but the problem could be a kdenlive commit rather than this package: https://quickgit.kde.org/?p=kdenlive.git&a=commit&h=d9b73c74a0b6725d1455558d5a3cb244b7e812cf

xF0E commented on 2016-05-25 13:01 (UTC)

ATTENTION ATTENTION ATTENTION don't install this package(at least the current version). Installed it yesterday and upon the first start the whole content of my /home was deleted. Such a shame. I only tried this version because the 16.04 crashes a way too frequently.

regreddit commented on 2016-04-01 16:09 (UTC)

This package isn't really usable with gnome until oxygen-icons is installed. The interface is missing all of its icons and buttons. I think it should be a required dependency

blackhole commented on 2016-03-27 00:07 (UTC)

I am using xfce4. I think kinit must be a dependency, otherwise it would be impossible to add clips "could not start process cannot talk to klauncher the name org.kde.klauncher5 was not provided by any .service files"

jz_train commented on 2016-02-01 16:32 (UTC)

Can confirm. qt5-quickcontrols eliminates the segfault

nous commented on 2016-01-21 09:51 (UTC)

Needs qt5-quickcontrols in depends(), otherwise kdenlive segfaults at launch.

evorster commented on 2015-11-16 09:11 (UTC)

Optional dependency of oxygen-icons added.

commented on 2015-11-14 13:11 (UTC)

"oxygen-icons" should definitely be marked as "optional for xfce" as the hicolor-icon-theme doesn't seem to do the trick - missing "play" "markers" etc buttons until oxygen-icons is installed.

bidulock commented on 2015-09-08 00:02 (UTC)

I think you also need kded as a dependency just as the 15.08 version from 'extra'.

bidulock commented on 2015-09-07 23:46 (UTC)

A corrected PKGBUILD with a VCS conforming pkgver() furnction is here: https://gist.github.com/bbidulock/65b52cb7f726ed24e72c

evorster commented on 2015-06-03 13:10 (UTC)

I get this segfault too, reported the backtrace to devs upstream. I suggest using kdenlive-applications15.04-git for now until this is fixed.

RankoKohime commented on 2015-05-25 16:29 (UTC)

Also experiencing a segfault at startup on my end. Even running through gdb, the only output is that the application segfaulted.

zobi8225 commented on 2015-05-05 18:44 (UTC)

I seg fault at startup :-( ➜ ~ kdenlive [1] 10738 segmentation fault (core dumped) kdenlive ➜ ~ uname -a Linux amelie 4.0.1-1-ARCH #1 SMP PREEMPT Wed Apr 29 12:00:26 CEST 2015 x86_64 GNU/Linux

arojas commented on 2015-03-24 20:53 (UTC)

Merging in kdenlive-git

agapito commented on 2015-03-03 01:50 (UTC)

Sorry, it was my fault. I was not using cmake from extra repo.

agapito commented on 2015-03-02 09:08 (UTC)

Resolving deltas: 100% (50512/50512), done. Checking connectivity... done. ==> Validando las fuentes con md5sums... kdenlive ... Omitido ==> Extrayendo las fuentes... -> Creando copia de trabajo de kdenlive del repositorio git... Cloning into 'kdenlive'... done. Switched to a new branch 'makepkg' ==> Iniciando pkgver()... ==> Versión actualizada: kdenlive-frameworks-git v0.9.10.369.g8e95cf3-1 ==> Iniciando prepare()... ==> Iniciando build()... cmake: error while loading shared libraries: libjsoncpp.so.0: cannot open shared object file: No such file or directory ==> ERROR: Se produjo un fallo en build(). Cancelando... ==> ERROR: Makepkg no ha podido compilar kdenlive-frameworks-git. ==> ¿Reiniciar la compilación de kdenlive-frameworks-git? [s/N] ==> ----------------------------------------------------------- ==>

sl1pkn07 commented on 2015-03-02 01:15 (UTC)

More log podase

agapito commented on 2015-03-01 23:58 (UTC)

cmake: error while loading shared libraries: libjsoncpp.so.0: cannot open shared object file: No such file or directory

evorster commented on 2015-02-27 08:32 (UTC)

Looks like the dependency of mlt-git has changed to mlt-qt5. It may be best to base this package of off kdenlive-frameworks-git now, as that is what I used to build the latest working git version of kdenlive, with only changing the source to the same one used in kdenlive-git. The other option could be to make a new package called kdenive-kf5, but since kdenlive-git does not build anymore in it's current form, it may be best to just modify this package? ;)

evorster commented on 2015-02-27 08:07 (UTC)

As of 2015-02-27, the git master is now based on Kdenlive-git gained two dependencies, namely: "extra-cmake-modules" and "kdoctools" I get a successful build with those two extra depenedncies installed: kdenlive-git-v0.9.10.r225.gda91989-1, but the binary segfaults

arojas commented on 2015-02-25 22:22 (UTC)

This is now based on Qt5/KF5

IncredibleLaser commented on 2015-02-02 21:07 (UTC)

I'm not 100% sure about that. I think kdenlive just uses the icons as specified in application appearance settings (which for KDE is systemsettings). However, any icon set providing the appropriate icons should be good. That's why hicolor-icon-theme is a dependency of this package (which in itself only provides the directories, not icons itself). Not perfect, I agree, but I don't like listing all icon sets as optional dependencies. Thoughts?

sakalisc commented on 2015-01-30 15:08 (UTC)

Hi, with the current dependencies, icons do not appear in the application. Installing oxygen-icons seems to fix this, perhaps the package should be a dependency? At the very least, an optional one? Best

nous commented on 2014-10-05 13:01 (UTC)

Thanks for testing, as I no longer use the -git version.

wcasanova commented on 2014-10-03 18:13 (UTC)

thanks perfect current version 0.9.10

e8hffff commented on 2014-03-02 19:05 (UTC)

Still builds. Just need to change 'pkgver=' in PKGBUILD, to represent your date or build name.

lockheed commented on 2014-02-23 18:42 (UTC)

Well, if anyone wants to adopt it, here's the fix that should be implemented: http://forum.kde.org/viewtopic.php?f=279&t=119774&p=302804#p302804

nous commented on 2014-02-21 20:54 (UTC)

I'm not actively using this anymore. I'll orphan it so anyone interested can adopt it.

lockheed commented on 2014-02-21 12:57 (UTC)

The package is broken in the vdpau part. Here's details: https://bbs.archlinux.org/viewtopic.php?pid=1383474#p1383474

lockheed commented on 2014-02-13 10:36 (UTC)

Anyone knows how to fix this error during compilation? producer_avformat.c: In function ‘producer_get_audio’: producer_avformat.c:2270:4: warning: ‘request_channels’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:1926) [-Wdeprecated-declarations] codec_context->request_channels = self->audio_index == INT_MAX ? codec_context->channels : *channels; ^ <builtin>: recipe for target 'producer_avformat.o' failed make[2]: *** [producer_avformat.o] Error 1 make[2]: *** Waiting for unfinished jobs.... make[2]: Leaving directory '/tmp/yaourt-tmp-juha/aur-mlt-git/src/mlt-build/src/modules/avformat' Makefile:5: recipe for target 'all' failed make[1]: *** [all] Error 1 make[1]: Leaving directory '/tmp/yaourt-tmp-juha/aur-mlt-git/src/mlt-build/src/modules' Makefile:9: recipe for target 'all' failed make: *** [all] Error 1 ==> ERROR: A failure occurred in build(). Aborting...

nous commented on 2013-11-02 23:42 (UTC)

Added, thanks.

alphazo commented on 2013-11-02 20:31 (UTC)

Package "glew" needs to be added as a required package to compile kdenlive-git.

Splashy commented on 2013-06-01 06:41 (UTC)

If you can't launch kdenlive: kdenlive with --mlt-path /usr/share/mlt/profiles and then in kdenlive go in option/environment and check that the path for the binaries are ok.

nous commented on 2012-09-23 16:33 (UTC)

Done, thanks.

commented on 2012-09-23 10:58 (UTC)

The current version fails with the following: [ 87%] Building CXX object src/CMakeFiles/kdenlive.dir/renderer.o /home/thor/kdenlive/kdenlive-git/src/kdenlive/src/renderer.cpp: In member function 'void Render::buildConsumer(const QString&)': /home/thor/kdenlive/kdenlive-git/src/kdenlive/src/renderer.cpp:199:42: error: 'class Mlt::Profile' has no member named 'colorspace' make[2]: *** [src/CMakeFiles/kdenlive.dir/renderer.o] Error 1 make[1]: *** [src/CMakeFiles/kdenlive.dir/all] Error 2 make: *** [all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... This was fixed by removing "mlt" and installing "mlt-git", so maybe you need to update the dependencies until the mlt changes make it to the regular version?

nous commented on 2012-07-20 10:46 (UTC)

Fixed, thanks. At least it compiles on others.

attilio commented on 2012-07-20 08:08 (UTC)

I tried to compile using makepkg but it does not work for me unless I apply the modification shown in my previous comment. Attilio

nous commented on 2012-07-19 18:25 (UTC)

If yaourt (or any other pacman/makepkg wrapper) fails, please use straight makepkg. It should work where yaourt fails. I still can't compile it though, cmake wont find automoc4 binary no matter what.

attilio commented on 2012-07-19 14:44 (UTC)

Error in building: tmp/yaourt-tmp-sickboy/aur-kdenlive-git/./PKGBUILD: line 56: cd: /tmp/yaourt-tmp-sickboy/aur-kdenlive-git/src/kdenlive-build: No such file or directory ==> ERROR: A failure occurred in package(). Aborting... ==> ERROR: Makepkg was unable to build kdenlive-git. Successfully compiled with the following modification package() { cd "$srcdir/$_gitname-build" --> package() { cd "$srcdir/$_gitname/build"

nous commented on 2012-07-19 09:30 (UTC)

==> Connecting to the GIT server.... Cloning into 'kdenlive'... remote: Counting objects: 45674, done. remote: Compressing objects: 100% (9811/9811), done. Receiving objects: 26% (12110/45674), 7.37 MiB | 635 KiB/s But it fails at cmake configuration: CMake Error at /usr/share/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE): Did not find automoc4 (Automoc4Config.cmake, install git://anongit.kde.org/automoc). (missing: AUTOMOC4_EXECUTABLE) Call Stack (most recent call first): /usr/share/apps/cmake/modules/FindAutomoc4.cmake:49 (find_package_handle_standard_args) /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:423 (find_package) /usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE) CMakeLists.txt:51 (find_package) -- Configuring incomplete, errors occurred! Something's broken in my configuration (automoc4 is installed alright), does it compile on anyone else?

commented on 2012-07-19 02:52 (UTC)

can anyone else compile this? I'm sitting @ Cloning into 'kdenlive'... but it's not pulling any data.

nous commented on 2011-11-28 22:47 (UTC)

Well, since I sometimes use kdenlive I adopted it. Please use the new kdenlive-git at https://aur.archlinux.org/packages.php?ID=54418. I started it using the PKGBUILD submitted by amirs. I'll request this page/comments/votes be merged with the new one. Your comments and contributions will help me maintain it better.

alphazo commented on 2011-11-26 22:05 (UTC)

PKGBUILD proposed below for git repo worked fine assuming that you rename kdenlive-svn.install to kdenlive.install. I hope that maintainer will update it.

amirs commented on 2011-11-08 10:43 (UTC)

this PKGBUILD worked for me: http://pastebin.com/dNm3b9Q8

amirs commented on 2011-11-08 10:19 (UTC)

moved to git The Git repository is online at http://quickgit.kde.org/?p=kdenlive.git&a=summary

alphazo commented on 2011-04-23 21:18 (UTC)

No longer works with ffmpeg-mt-git (which uses x264-git). avformat is not recognized when starting Kdenlive. I had to go back to x264 and ffmpeg from Extra/Community and mlt-git (AUR).

alphazo commented on 2011-02-18 22:44 (UTC)

This PKGBUILD has been working fine until rev 5425. qjson package is now required (for building only I guess). Can you please add it as a build dependency.

commented on 2010-09-15 10:57 (UTC)

I tuned the PKGbuild a bit and now the build works flawlessly... <script src="http://pastebin.com/embed_js.php?i=E7g0mDmD"></script>

ChemBro commented on 2010-08-10 18:20 (UTC)

I get this error: mkdir: kann Verzeichnis „build“ nicht anlegen: Die Datei existiert bereits (mkdir: cannot create directory "build": it already exists). Also kdenlive-svn does not like mlt-git because the version number is not high enough (but it's mlt-git and it's newer than mlt).