Package Details: libjxl-doc-git 0.10.1.r23.gcae805d8-1

Git Clone URL: https://aur.archlinux.org/libjxl-git.git (read-only, click to copy)
Package Base: libjxl-git
Description: JPEG XL image format reference implementation (documentation; git version)
Upstream URL: https://jpeg.org/jpegxl/
Keywords: jpeg-xl
Licenses: BSD-3-Clause
Conflicts: libjpeg-xl-doc-git, libjxl-doc
Provides: libjpeg-xl-doc-git, libjxl-doc
Replaces: libjpeg-xl-doc-git
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 14
Popularity: 0.000055
First Submitted: 2021-06-02 18:30 (UTC)
Last Updated: 2024-03-01 15:40 (UTC)

Dependencies (18)

Required by (0)

Sources (11)

Latest Comments

1 2 3 4 5 6 .. 13 Next › Last »

dbermond commented on 2024-04-14 15:27 (UTC)

@xiota What I mean, is that your package have the great potential to break the system of users that have libjpeg (libjpeg-turbo) installed, hence it's broken. I understand that it should not be used in the way you propose. My pointed comment explains why, as this subject have already been talked before.

xiota commented on 2024-04-11 03:58 (UTC) (edited on 2024-04-11 03:58 (UTC) by xiota)

The jpegli package is not "broken". The diff is for testing by those who want to check on its development progress and "works" as intended.

dbermond commented on 2024-04-10 16:58 (UTC)

@xiota Your libjpegli package is broken, as it cannot be treated as a provider for libjpeg. Please read my previous comment from 2023-08-12 about libjpegli.

xiota commented on 2024-04-10 05:04 (UTC) (edited on 2024-04-10 05:08 (UTC) by xiota)

For anyone interested, here's a diff that adds a subpackage libjpeg-jpegli to this package: libjxl-git.diff. Spoilers: Doesn't work. (I forgot the -git. Anyone who bothers trying to build it is free to add it.)

cjpegli and djpegli are already installed by this package. 16-bit decoding of existing jpegs is pretty impressive.

louietaur commented on 2024-03-04 11:05 (UTC) (edited on 2024-03-04 11:06 (UTC) by louietaur)

@0ion9 I encountered a similar issue with building the package and not being able to find org.jpeg.jpegxl.jar. I fixed it by running archlinux-java status and selecting a JDK instead of JRE as my default Java enviroment.

Apparently, I had set java-8-openjdk/jre as default for some reason instead of java-21-openjdk. The package probably wasn't building right because it needed a JDK, not a JRE.

I remember running into this issue before and not being able to figure it out. Checking CMakeCache.txt led me to find that some tools like javac were not being found, hence the JNI jar not being built.

dbermond commented on 2023-10-09 02:03 (UTC)

@0ion9 If it builds in a clean chroot with devtools but does not build locally with makepkg, then something is wrong with your system. Up to you to find out. As I said since the beginning, the package is building fine and there is no issue.

0ion9 commented on 2023-10-08 01:34 (UTC)

Yeah, that works. Now I'm just trying to figure out why.

dbermond commented on 2023-10-07 12:53 (UTC)

@0ion9 build the package in a clean chroot.

0ion9 commented on 2023-10-06 22:50 (UTC) (edited on 2023-10-06 23:46 (UTC) by 0ion9)

It suggests that, maybe, but the suggestion is incorrect. That directory is in the log because that's where I cded in order to update the git checkouts and run makepkg.

I followed your instructions and am not using an aur helper to build.

I can see there may be an advantage to copying just the PKGBUILD to a random directory and building there, but I point out that this would not be following your instructions. Nevertheless I will copy the PKGBUILD to a random directory and try makepkg-ing there.

EDIT: I have done that. The result is exactly the same - can't find jar file. I have checked my makepkg.conf; it is entirely unmodified, ie. exactly the file that Arch distributes in the pacman package, specifically the 6.0.2-8 version, which was current when I updated my system yesterday.

dbermond commented on 2023-10-01 16:24 (UTC)

@0ion9 Your log suggests that you're still using an aur helper (/home/kau/.cache/yay/...), and this is not supported. Maybe you configured something to invoke the aur helper when you type makepkg? Are you on Arch Linux? There is no missing java dependency, since the package depends on java-environment (which in turn installs jdk and jre) as described in the Java package guidelines. I've just checked again, and the package builds fine with the recently released java 21, including the jni bindings file. There is no issue. You can try to build the package in a clean chroot and it should work.