Package Details: multimc5 0.6.11-1

Git Clone URL: (read-only, click to copy)
Package Base: multimc5
Description: Minecraft launcher with ability to manage multiple instances.
Upstream URL:
Keywords: launcher minecraft
Licenses: Apache
Conflicts: multimc
Provides: multimc
Submitter: vorpalblade
Maintainer: xiretza
Last Packager: xiretza
Votes: 72
Popularity: 4.06
First Submitted: 2015-06-06 11:37
Last Updated: 2020-03-29 07:52

Dependencies (10)

Required by (1)

Sources (5)

Pinned Comments

Fuxy commented on 2019-07-13 08:47

just a friendly reminder even though this installs packages of jdk < 12 it will still attempt to use the default one which may be set to 12 like in my case.

You need to use sudo archlinux-java status and sudo archlinux-java set java-11-openjdk to figure out what you have and set something lower than 12 as default before attempting to install.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Toadtoad commented on 2020-05-23 23:39

Why can't you set the JAVA_HOME env variable in the build function, like is done in the multimc-git package ( It seems to work fine like this, and could solve a lot of frustration.

Wennadocta commented on 2020-04-04 21:55

@xiretza thanks, I set java to openjdk 8 and everything works nice now

xiretza commented on 2020-04-04 11:06

@Wennadocta: first off, it builds fine in a clean chroot, which is the only setup that can be supported reasonably - AUR helpers in particular are completely out of scope, I suggest you at least use makepkg before reporting any package bugs in the future. Also, did you read the pinned comment? I think it might solve your problem.

Wennadocta commented on 2020-04-04 10:58

Last version doesn't compile

CMake Error at libraries/launcher/CMakeLists.txt:2 (project):
  No CMAKE_Java_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "JAVA_COMPILER" or the CMake cache entry CMAKE_Java_COMPILER to
  the full path to the compiler, or to the compiler name if it is in the

-- Configuring incomplete, errors occurred!
See also "/home/ayanami/.cache/yay/multimc5/src/MultiMC5-0.6.11/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Error making: multimc5

sunflsks commented on 2020-03-31 15:02

@xirertza Yeah, that did the trick. Turned out I was using jdk 13, switched to version 8 and it worked like a charm.

xiretza commented on 2020-03-30 20:28

@sybsfksks: "doesn't work" is about the least helpful error report possible. I just created a 1.10 instance, then installed forge from the "Version" menu of the instance, and it launches just fine using Java 8.

Edit: just saw you added a stack trace - the full log would probably show that the java version you're using is too new.

sunflsks commented on 2020-03-30 20:22

On the latest version, any version below 1.12.2 with forge doesn't work for some reason. Here's the full error:

xiretza commented on 2020-02-03 17:38

@mcmacker4: please use MAKEFLAGS= in makepkg.conf for this, that way it applies to all packages you build and package maintainers don't have to implement it separately for every package.

mcmacker4 commented on 2020-02-03 17:36

Since the whole program is built locally and there is quite a lot of files to build, may i suggest adding the jobs flag to the make command in the build() function of PKGBUILD like so:

make -j $(nproc)

This will allow make to build files in parallel using as many threads as cores the computer has (as reported by the nproc command). By adding this flag (on my 4 core machine) the build time was reduced from 8m36s down to 2m52s.

xiretza commented on 2020-01-06 18:44

@gameslayer: sounds like an AUR helper problem. Please use makechrootpkg when reporting bugs.