Package Details: opsu 0.16.0-1

Git Clone URL: https://aur.archlinux.org/opsu.git (read-only)
Package Base: opsu
Description: An open source osu!-client written in Java.
Upstream URL: https://itdelatrisu.github.io/opsu/
Keywords: game opsu opsu! osu osu! rhythm
Licenses: GPL3
Conflicts: opsu-git
Provides: opsu-git
Submitter: Lucki
Maintainer: Lucki
Last Packager: Lucki
Votes: 18
Popularity: 0.532488
First Submitted: 2015-02-15 01:59
Last Updated: 2017-07-03 11:41

Latest Comments

Lucki commented on 2017-08-23 17:21

I've downloaded a new beatmap (.osz) from osu placed it in $XDG_DATA_HOME/opsu/Import and clicked in opsu in the downloads screen on Import All. Import worked an the map is playable.
Please check if your beatmap is corrupt or in an old format (they've changed the format long time ago). Also give the ingame downloader a shot and try different beatmaps.
If it still doesn't load your maps please note the exact error message and an image or a video if that's helpful, explain step by step what you're doing to get this error and report it upstream [1] as I don't think this is a problem which is caused by this package (but I can be wrong - you can test this with the prebuild .jar [2] which is standalone in it's folder).

[1]: https://github.com/itdelatrisu/opsu/issues
[2]: https://github.com/itdelatrisu/opsu/releases/download/0.16.0/opsu-0.16.0.jar

Reotip commented on 2017-08-23 16:45

When I want to load a beatmaps, it says I can't load normal maps.
Can you help me ?

Lucki commented on 2016-09-28 16:32

Beatmaps are stored in "$XDG_DATA_HOME/opsu/Songs".
You can set the XDG-build-flag in the PKGBUILD to false to store all data in the working directory.

Anonymous comment on 2016-09-28 16:17

Where does this version of opsu store beatmaps?

Lucki commented on 2016-08-01 11:58

That's strange. Works here with jdk8-openjdk.

Could you recheck your 'archlinux-java' settings?
Gradle looks to the wrong place for tools.jar.

WizardOfTheWest commented on 2016-07-28 03:45

==================================================================
==> Starting build()...
:compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileJava'.
> Could not find tools.jar. Please check that /usr/lib/jvm/java-7-openjdk/jre contains a valid JDK installation.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 3.057 secs
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build opsu.
==================================================================

Had jdk8-openjdk installed, but doesn't seem to want that. Fixed by installing jdk7-openjdk manually.

Lucki commented on 2016-05-30 18:10

Sure!
Happy clicking

SajeOne commented on 2016-05-30 12:40

'xorg-xrandr' is a dependency for LWJGL. Had to search around for the fix after the application was throwing an unhandled exception because it couldn't detect monitors. Any chance this could be added to the dep list?

Lucki commented on 2015-09-02 12:33

Fixed.
Thank you for noticing.

Cravix commented on 2015-09-02 12:27

please add gradle into make dependencies, thanks :)

All comments