Package Details: panda3d 1.10.4.1-1

Git Clone URL: https://aur.archlinux.org/panda3d.git (read-only)
Package Base: panda3d
Description: A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
Upstream URL: http://www.panda3d.org
Licenses: BSD
Submitter: wonder
Maintainer: croxis
Last Packager: croxis
Votes: 36
Popularity: 0.034301
First Submitted: 2010-01-30 22:41
Last Updated: 2019-08-30 16:30

Dependencies (49)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

Anonymous comment on 2012-08-28 16:12

I think this software is great!
Hope it will be in the community repo.

corro commented on 2012-08-06 16:50

Droped ffmpeg support, thanks for the hint.

Anonymous comment on 2012-08-05 18:57

python2 makepanda/makepanda.py --everything --no-maya2012 --no-ode --no-opencv --no-ffmpeg

Compiled fine the CVS version, but you loose ffmpeg support.

archaeopteryx commented on 2012-07-30 00:24

I get the same issue as qubodup below:

Storing dependency cache.
Elapsed Time: 11 min 56 sec
The following command returned a non-zero value: g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/p3movies_composite2.o -Ibuilt/tmp -Ibuilt/include -I/usr/include/python2.7 -DMAKEPANDA= -Ipanda/src/movies -pthread -msse2 -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -DBUILDING_PANDA panda/src/movies/p3movies_composite2.cxx
Build terminated.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build panda3d.

qubodup commented on 2012-07-10 19:20

panda/src/audiotraits/fmodAudioManager.cxx: In member function ‘FMOD::DSP* FmodAudioManager::make_dsp(const FilterProperties::FilterConfig&)’:
panda/src/audiotraits/fmodAudioManager.cxx:242:51: error: ‘FMOD_DSP_TYPE_REVERB’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:311:28: error: ‘FMOD_DSP_CHORUS_FEEDBACK’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:314:28: error: ‘FMOD_DSP_REVERB_DRYMIX’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:315:28: error: ‘FMOD_DSP_REVERB_WETMIX’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:316:28: error: ‘FMOD_DSP_REVERB_ROOMSIZE’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:317:28: error: ‘FMOD_DSP_REVERB_DAMP’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:318:28: error: ‘FMOD_DSP_REVERB_WIDTH’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx: In member function ‘virtual int FmodAudioManager::getSpeakerSetup()’:
panda/src/audiotraits/fmodAudioManager.cxx:486:11: error: ‘FMOD_SPEAKERMODE_PROLOGIC’ was not declared in this scope
Storing dependency cache.
Elapsed Time: 24 min 38 sec
The following command returned a non-zero value: g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/fmod_audio_fmod_audio_composite1.o -Ibuilt/tmp -Ibuilt/include -I/usr/include/python2.7 -I/usr/include/fmodex -DMAKEPANDA= -Ipanda/src/audiotraits -pthread -msse2 -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -DBUILDING_FMOD_AUDIO panda/src/audiotraits/fmod_audio_composite1.cxx
Build terminated.
==> ERROR: A failure occurred in build().

Anonymous comment on 2012-06-30 15:13

bison is part of the base-devel [1] group which is assumed to be installed prior to executing makepkg. Source: https://wiki.archlinux.org/index.php/Makepkg#Usage

[1] http://www.archlinux.org/groups/i686/base-devel/

corro commented on 2012-06-30 13:01

@Kenji_Takahashi: Thanks for the hint, added it to the makedeps.

KenjiTakahashi commented on 2012-06-30 12:54

It needs bison to build.

corro commented on 2012-05-24 17:47

Disabled all broken extensions in PKGBUILD just like fax8 mentioned.

Anonymous comment on 2012-05-09 21:33

python2 makepanda/makepanda.py --everything --no-maya2012 --no-ode --no-opencv

Build successfully finished, elapsed time: 29 min 30 sec