Package Details: pavucontrol-git 3.0.10.gd7445a3-1

Git Clone URL: https://aur.archlinux.org/pavucontrol-git.git (read-only)
Package Base: pavucontrol-git
Description: A GTK volume control for PulseAudio
Upstream URL: http://freedesktop.org/software/pulseaudio/pavucontrol/
Licenses: GPL
Conflicts: pavucontrol
Provides: pavucontrol
Submitter: DIDI2002
Maintainer: pmattern
Last Packager: pmattern
Votes: 13
Popularity: 0.935320
First Submitted: 2011-03-15 15:26
Last Updated: 2016-02-02 12:27

Required by (11)

Sources (1)

Latest Comments

pmattern commented on 2016-04-11 12:33

According to the first comment of György Balló (City-busz) in FS#48853 which is in full accordance with my local findings this is due to using themes which haven't been adjusted to GTK 3.*20* yet.
So this package isn't involved.

jwhendy commented on 2016-04-11 01:42

gtkmm3 3.20 makes the volume bars disappear for me, and generally seems to affect the gui. Has anyone else noticed this? The separation between my top menu bar tabs disapears, as well as the right scroll bar. Downgrading to 3.18 worked for me to resolve (I also downgraded to gtk3 3.18).

EDIT:
- gtk3/gtkmm3 v 3.18: http://i.imgur.com/zeuT1ov.png
- gtk3/gtkmm3 v 3.20: http://i.imgur.com/2MMzsRv.png

Some of the error output with v3.20:

(pavucontrol:31786): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:7:37: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:31786): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:8:37: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:31786): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:9:31: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:31786): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:68:13: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(pavucontrol:31786): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:69:13: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(pavucontrol:31786): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:69:25: The :insensitive pseudo-class is deprecated. Use :disabled instead.

DIDI2002 commented on 2013-05-14 14:41

Good time to delete the package.

sl1pkn07 commented on 2013-05-14 14:31

nevermind, the git repository is hard outdate...

sl1pkn07 commented on 2013-05-14 14:26

need gtkmm3

configure: error: Package requirements ( gtkmm-3.0 >= 2.99 sigc++-2.0 libcanberra-gtk3 >= 0.16 ) were not met:

No package 'gtkmm-3.0' found

sl1pkn07 commented on 2013-05-14 14:15

need ad gtkmm3 to depends

└───╼ pavucontrol
pavucontrol: error while loading shared libraries: libgtkmm-3.0.so.1: cannot open shared object file: No such file or directory

DIDI2002 commented on 2011-11-09 16:20

Ok I'll just add gtkmm3 to make sure it compiles for everyone. Thanks for the hint!

Wintershade commented on 2011-11-09 12:52

@DIDI2002 I didn't know about that, sorry. However what I've noticed is that if gtkmm3 is not present in the system, the package doesn't build at all. Or at least it didn't build for me. What gives?

DIDI2002 commented on 2011-11-09 12:49

@Wintershade: pavucontrol should build against gtkmm as well als gtkmm3. If gtkmm3 is makedepend, you can't build with gtkmm (except with --disable-gtk3) Any ideas?

Wintershade commented on 2011-11-09 10:19

This package makedepends on gtkmm3, please add it to the makedepends list. TIA

All comments