Package Details: ptyxis 46.3-2

Git Clone URL: https://aur.archlinux.org/ptyxis.git (read-only, click to copy)
Package Base: ptyxis
Description: A terminal for a container-oriented desktop
Upstream URL: https://gitlab.gnome.org/chergert/ptyxis
Licenses: GPL-3.0-or-later, LGPL-3.0-or-later
Submitter: Piroro-hs
Maintainer: Piroro-hs
Last Packager: Piroro-hs
Votes: 6
Popularity: 2.55
First Submitted: 2024-04-07 18:51 (UTC)
Last Updated: 2024-06-13 09:45 (UTC)

Latest Comments

Piroro-hs commented on 2024-06-13 09:46 (UTC)

@muziknavi PKGBUILD fixed. Thanks!

muziknavi commented on 2024-06-12 17:26 (UTC) (edited on 2024-06-12 17:38 (UTC) by muziknavi)

seems like it needs makedepends glib2-devel as glib2 has been split recently.

https://gitlab.archlinux.org/archlinux/packaging/packages/glib2/-/issues/7

UPDATE: Ah, sorry, it will need when glib2 bumps to 2.80.3.

Piroro-hs commented on 2024-06-11 02:08 (UTC)

@ciupenhauer sudo pacman -Syud

ciupenhauer commented on 2024-06-10 16:57 (UTC)

installing vte-common (0.76.3-1) breaks dependency 'vte-common=0.76.1' required by ptyxis ==> ERROR: 'pacman' failed to install missing dependencies. ==> Missing dependencies: -> vte-common=0.76.3

I'm stuck in dependency hell, cannot do system upgrade, cannot upgrade ptyxis either

Piroro-hs commented on 2024-05-24 19:18 (UTC)

@kabe-inc You can rebuild it locally. It should fix the crash.

kabe-inc commented on 2024-05-24 00:57 (UTC)

Ptyxis crashes with the following error:

ptyxis: error while loading shared libraries: libicuuc.so.74: cannot open shared object file: No such file or directory

icu just updated to 75.1-1. Could you please rebuild with the updated library?

armandleg commented on 2024-04-25 20:32 (UTC)

Is it necessary to explicitly specify VTE version in the PKGBUILD? This way every time new VTE version is released, the same problem will occur and the PKGBUILD will have to be updated right?

Piroro-hs commented on 2024-04-25 09:46 (UTC)

VTE version updated, thanks!

armandleg commented on 2024-04-22 19:26 (UTC) (edited on 2024-04-22 19:26 (UTC) by armandleg)

Recent issues with vte-common package can be fixed by applying the following patch:

--- PKGBUILD
+++ PKGBUILD
@@ -28,7 +28,7 @@
          'pango'
          'pcre2'
          'systemd-libs'
-         "vte-common=$_vtever")
+         "vte-common")
 makedepends=('git'
              'meson'
              'patchutils'