Package Details: python-pydub 0.25.1-3

Git Clone URL: https://aur.archlinux.org/python-pydub.git (read-only, click to copy)
Package Base: python-pydub
Description: Manipulate audio with a simple and easy high level interface
Upstream URL: https://pydub.com
Licenses: MIT
Submitter: simon04
Maintainer: carlosal1015 (AutoUpdateBot)
Last Packager: carlosal1015
Votes: 10
Popularity: 1.01
First Submitted: 2014-11-26 21:23 (UTC)
Last Updated: 2021-12-14 18:35 (UTC)

Latest Comments

1 2 Next › Last »

skunk commented on 2023-10-26 20:52 (UTC)

arch now uses python 3.11. Could you @carlosal1015 please bump the pkgrel please to ensure that the package is re-built for python 3.11, please? (at least this is how I understand the upgrade to python 3.10 happened)

carlosal1015 commented on 2023-03-13 22:08 (UTC)

No error from my side. Try providing full log (hint)

$ git clone https://aur.archlinux.org/python-pydub.git
$ cd python-pydub
$ makepkg -s | tee log.txt

Upload log.txt to pastebin and paste the url.

Bluebomber182 commented on 2023-03-13 21:03 (UTC) (edited on 2023-03-13 21:08 (UTC) by Bluebomber182)

I get this error message when try to install. IndexError: list index out of range I had to resort to installing it with the Chaotic-AUR repo.

carlosal1015 commented on 2021-11-26 17:44 (UTC)

Thanks both @thelandfill, @yochananmarqos for report.

thelandfill commented on 2021-06-14 02:03 (UTC)

I am unable to install this package because one of the files (probably the LICENSE) did not pass the validity check. The exact error is

:: Checking for conflicts...                                                                            
:: Checking for inner conflicts...
[Aur:1]  python-pydub-0.25.1-1

  1 python-pydub                             (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> a
:: Deleting (1/1): /home/user/.cache/yay/python-pydub
:: Downloaded PKGBUILD (1/1): python-pydub
  1 python-pydub                             (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: (1/1) Parsing SRCINFO: python-pydub
==> Making package: python-pydub 0.25.1-1 (Sun 13 Jun 2021 08:56:42 PM CDT)
==> Retrieving sources...
  -> Found pydub-0.25.1.tar.gz
  -> Found LICENSE
==> Validating source files with sha256sums...
    pydub-0.25.1.tar.gz ... Passed
    LICENSE ... FAILED
==> ERROR: One or more files did not pass the validity check!
error downloading sources: python-pydub

I can provide more information if necessary.

yochananmarqos commented on 2020-08-23 14:47 (UTC)

@simon04: libav is included in ffmpeg on Arch.

simon04 commented on 2020-08-23 07:37 (UTC)

@yochananmarqos: Thanks for your suggestions. Changes for 0.24.1-2 –

  • Add optdepends
  • Drop Python 2
  • Use pypi.org source
  • Use HTTPS in url

yochananmarqos commented on 2020-08-11 20:17 (UTC)

The dependencies are missing.

Might as well take this opportunity to drop Python 2, there are no packages requiring python2-pydub.

Improved PKGBUILD

PurpleInk commented on 2020-04-22 00:18 (UTC)

That was it! Thank you so much! :D

simon04 commented on 2020-04-21 21:39 (UTC)

@Yekaterina, presumably your $srcdir contains a space? I've fixed the quoting in 0.23.1-3