Package Details: python-sqlalchemy1.3 1.3.24-6

Git Clone URL: https://aur.archlinux.org/python-sqlalchemy1.3.git (read-only, click to copy)
Package Base: python-sqlalchemy1.3
Description: Python SQL toolkit and Object Relational Mapper
Upstream URL: https://www.sqlalchemy.org/
Licenses: MIT
Conflicts: python-sqlalchemy
Provides: python-sqlalchemy
Submitter: jelly
Maintainer: MarsSeed
Last Packager: MarsSeed
Votes: 1
Popularity: 0.57
First Submitted: 2024-03-09 15:28 (UTC)
Last Updated: 2024-04-29 10:34 (UTC)

Dependencies (6)

Required by (122)

Sources (1)

Latest Comments

MarsSeed commented on 2024-05-02 12:25 (UTC)

Hi @Muflone,

Only the check() fails. Upstream's test suite for the v1.3.x branch is not compatible with pytest7.

I am working on backporting the pytest7 fixes from the newer v1.4.x branch.

Ideally this package should be deleted, but unfortunately there are still one or two otherwise functional applications that depend on the legacy v1.3.x module.

Muflone commented on 2024-05-01 21:11 (UTC)

@MarsSeed do you plan to fix this package which actually doesn't build or do you plan to ask for deletion?

python-piecash needs this dependency actually and it cannot be built for this reason

xiretza commented on 2024-03-16 11:21 (UTC)

The signature file doesn't exist (anymore):

  -> Downloading SQLAlchemy-1.3.24.tar.gz.asc...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   122  100   122    0     0   2999      0 --:--:-- --:--:-- --:--:--  3050
100   285  100   285    0     0   1404      0 --:--:-- --:--:-- --:--:--  1404
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404
==> ERROR: Failure while downloading https://pypi.io/packages/source/S/SQLAlchemy/SQLAlchemy-1.3.24.tar.gz.asc
    Aborting...
==> ERROR: Could not download sources.