Package Details: sayonara-player-git 1.8.0.beta1.r38.g3d444b4a-1

Git Clone URL: https://aur.archlinux.org/sayonara-player-git.git (read-only, click to copy)
Package Base: sayonara-player-git
Description: Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend.
Upstream URL: https://sayonara-player.com/
Keywords: audio music sayonara-player
Licenses: GPL3
Conflicts: sayonara-player
Provides: sayonara-player
Submitter: FixedTorres
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 15
Popularity: 0.27
First Submitted: 2016-02-28 06:28 (UTC)
Last Updated: 2022-10-25 21:04 (UTC)

Dependencies (12)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

LucioCarreras commented on 2024-01-29 19:17 (UTC)

Hi Fabio, I just wanted to let you know that Sayonara 1.9.0 has been released. https://gitlab.com/luciocarreras/sayonara-player/-/tags/1.9.0-stable1

Thank you!

FabioLolix commented on 2021-12-19 11:39 (UTC)

@halcek done

halcek commented on 2021-12-02 12:19 (UTC)

Can you also add the aarch64 architecture? It compiles on arm64 fine, but just to make it easier/quicker to install...

BujuArena commented on 2021-06-28 19:35 (UTC)

I'm getting this error when building now.

/home/alex/.cache/yay/sayonara-player-git/src/sayonara-player/src/Gui/Plugins/Stream/GUI_StationSearcher.cpp:197:14: error: ‘optional’ in namespace ‘std’ does not name a template type
  197 |         std::optional<RadioStation> stationAt(const QList<RadioStation>& stations, int row)
      |              ^~~~~~~~

From brief research, this seems to mean that this requires C++17 or later. I'm not sure if this is right, but https://cmake.org/cmake/help/latest/prop_tgt/CXX_STANDARD.html might be a useful page for fixing this.

codebling commented on 2020-10-08 20:49 (UTC)

@FabioLolix the test that is failing under chroot is still preventing this package from building. Can we disable the tests or add the flag -DCMAKE_BUILD_TYPE=Debug to allow the tests to pass?

codebling commented on 2020-09-29 01:29 (UTC)

FYI there is currently a build issue with this package. Fabio is aware and has opened issues here https://gitlab.com/luciocarreras/sayonara-player/-/issues?scope=all&utf8=%E2%9C%93&state=opened&author_username=FabioLolix

dmoebius commented on 2020-05-31 10:08 (UTC)

There's now a new AUR package sayonara-player-beta, which tracks the more recent versions of sayonara at the GitLab repository.

dmoebius commented on 2019-12-16 13:06 (UTC) (edited on 2019-12-16 13:06 (UTC) by dmoebius)

According to "How To Build" (https://sayonara-player.com/howto-build.php) the repository is now at https://gitlab.com/luciocarreras/sayonara-player.git

ljrk commented on 2015-05-15 20:21 (UTC)

Updated dependencies, desc, url and source. Added a "version offset" of 1042 as this is the revision count that got reset when the source repo was transfered to its new location. Git repo of PKGBUILD: https://github.com/LeonardKoenig/PKGBUILDs/tree/master/sayonara-player-svn