Package Details: subtitlecomposer 0.7.0-1

Git Clone URL: https://aur.archlinux.org/subtitlecomposer.git (read-only)
Package Base: subtitlecomposer
Description: A KDE subtitle editor
Upstream URL: https://github.com/maxrd2/SubtitleComposer
Keywords: composer editor kde subtitle
Licenses: GPL
Submitter: Martchus
Maintainer: Martchus (maxrd2)
Last Packager: maxrd2
Votes: 20
Popularity: 0.032771
First Submitted: 2015-09-02 23:50
Last Updated: 2019-06-27 19:04

Dependencies (20)

Required by (0)

Sources (2)

Pinned Comments

Martchus commented on 2016-05-18 21:59

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
There also exist a binary repository (i686 and x86_64, also contains Git version): https://martchus.no-ip.biz/repo/arch/ownstuff

Latest Comments

1 2 3 Next › Last »

Tio commented on 2019-06-28 00:09

Works with the latest update. Thanks!

Tio commented on 2019-06-27 15:00

I get this error now:

Building subtitlecomposer...
==> Making package: subtitlecomposer 0.6.6-6 (jue 27 jun 2019 16:59:37 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found v0.6.6.tar.gz
  -> Found 0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch
==> Validating source files with sha256sums...
    v0.6.6.tar.gz ... Passed
    0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting v0.6.6.tar.gz with bsdtar
==> Starting prepare()...
/var/tmp/pamac-build-tio/subtitlecomposer/PKGBUILD: line 45: cd: /var/tmp/pamac-build-tio/subtitlecomposer/src/subtitlecomposer-0.6.6: No such file or directory
==> ERROR: A failure occurred in prepare().
    Aborting...

Martchus commented on 2019-06-27 14:59

@Tio fixed

Tio commented on 2019-06-27 14:29

Error:

Building subtitlecomposer...
==> Making package: subtitlecomposer 0.6.6-3 (jue 27 jun 2019 15:50:29 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading v0.6.6.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   131    0   131    0     0    205      0 --:--:-- --:--:-- --:--:--   204

100 32444    0 32444    0     0  20945      0 --:--:--  0:00:01 --:--:-- 20945
100 1598k    0 1598k    0     0   654k      0 --:--:--  0:00:02 --:--:-- 1753k
  -> Downloading 0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  7759    0  7759    0     0  13263      0 --:--:-- --:--:-- --:--:-- 13240
==> Validating source files with sha256sums...
    v0.6.6.tar.gz ... FAILED
    0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch ... Passed
==> ERROR: One or more files did not pass the validity check!

Nocifer commented on 2019-01-26 14:56

I tried to build and I got the following error:

CMake Error: No source or binary directory provided

I had to edit the PKGBUILD's build() and add an extra '.' step for CMake's configuration, like so:

    ...
    -DBUILD_TESTING=OFF \
    .
  make

Neros commented on 2018-06-12 23:43

@Martchus Thanks!

Martchus commented on 2018-06-11 14:00

@Neros If you don't need it, just leave pocketsphinx out-commented and build in a clean chroot. This is the cheapest workaround.

maxrd2 commented on 2018-06-11 13:50

@Neros that cmake error is because of invalid sphinbase pkgconfig file. Have submitted pull request upstream: https://github.com/cmusphinx/sphinxbase/pull/55 Before its merged sphinxbase.pc.in should be patched manually.

Neros commented on 2018-06-11 12:39

I can't compile it anymore:

CMake Error at /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:54 (set):
  Syntax error in cmake code at

    /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:54

  when parsing string

    ;pocketsphinx;m;sphinxbase;sphinxad;pulse;pulse-simple;pthread;m;blas;lapack;pulse\;pulse-simple\;pthread\;m\;blas\;lapack\

  Invalid character escape '\' (at end of input).
Call Stack (most recent call first):
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:81 (_pkgconfig_set)
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:113 (_pkgconfig_invoke)
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:450 (_pkgconfig_invoke_dyn)
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:585 (_pkg_check_modules_internal)
  cmake/FindPocketSphinx.cmake:11 (pkg_check_modules)
  src/speechplugins/pocketsphinx/CMakeLists.txt:1 (find_package)


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-neros/aur-subtitlecomposer/src/subtitlecomposer-0.6.6/CMakeFiles/CMakeOutput.log".
See also "/tmp/yaourt-tmp-neros/aur-subtitlecomposer/src/subtitlecomposer-0.6.6/CMakeFiles/CMakeError.log".

Martchus commented on 2017-05-24 21:20

I've just rebuild the package in a clean chroot. Not sure why you're getting this error. Could you provide a little bit more of the output (not just the end)? Which makedepends/optdepends do you use?