Package Details: swayfx 0.4-0

Git Clone URL: https://aur.archlinux.org/swayfx.git (read-only, click to copy)
Package Base: swayfx
Description: SwayFX: Sway, but with eye candy!
Upstream URL: https://github.com/WillPower3309/swayfx
Licenses: MIT
Conflicts: sway, swayfx
Provides: sway, swayfx
Submitter: swayfx
Maintainer: swayfx
Last Packager: swayfx
Votes: 21
Popularity: 4.11
First Submitted: 2022-11-14 06:53 (UTC)
Last Updated: 2024-05-22 06:01 (UTC)

Dependencies (30)

Required by (45)

Sources (3)

Latest Comments

1 2 3 Next › Last »

DeltaWhy commented on 2024-05-21 21:32 (UTC)

Build is broken on 0.4. Swayfx now uses wlroots 0.17: https://github.com/WillPower3309/swayfx/blob/0.4/meson.build#L47

But the PKGBUILD sets an environment variable pointing pkgconfig to /usr/lib/wlroots0.16: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=swayfx#n60

Commenting out this line fixes it. You do not need to uninstall wlroots0.16 if this line is removed.

I also had to manually install scenefx but that seems to be an issue with aurutils and not with the actual package.

kelvie commented on 2024-05-08 05:23 (UTC)

If you still run into the wlroots 0.16.2 problem with 0.4, you need to uninstall wlroots0.16 if you have both it and wlroots (0.17) installed

yay -Rc wlroots0.16 (check that nothing needs it).

rarksz commented on 2024-05-01 06:44 (UTC) (edited on 2024-05-01 06:44 (UTC) by rarksz)

Swayfx 0.4 working correctly with wlroots 0.17

AZMCode commented on 2024-04-29 21:01 (UTC)

Absolutely correct. Uninstalling swayfx, then wlroots0.16, then reinstalling swayfx worked. Thanks for the heads up!

KatStuffs commented on 2024-04-29 20:31 (UTC)

wlroots0.16 had to be installed to use swayfx 3.5, uninstall it and it should build

AZMCode commented on 2024-04-29 20:12 (UTC) (edited on 2024-04-29 21:00 (UTC) by AZMCode)

I'm having precisely the opposite problem of rstacruz, where wlroots requires wlroots >=0.17.0, but pkgconfig says I have wlroots 0.16.2.

Oddly enough, I do have wlroots 0.17.2 as per the last update I did, which makes me wonder where pkgconfig is getting its info from.

Still haven't found an answer so I'd appreciate the support.

Here's the full recording: https://asciinema.org/a/656924

Edit: As KatStuffs pointed out, it was an issue upgrading from the previous version

cprin21 commented on 2024-02-15 11:43 (UTC)

Swayfx and all other Swayfx packages on the AUR do not build on Artix Linux as there is a SystemD requirement despite the original on Github not requiring it.

MithicSpirit commented on 2023-12-31 21:36 (UTC) (edited on 2023-12-31 21:37 (UTC) by MithicSpirit)

Since this package is almost a drop-in replacement for sway (the binary is called sway, the config goes in the same place as sway's), I think that it would make sense to also install contrib scripts to /usr/share/sway/scripts as well (rather than the current /usr/share/swayfx/scripts). I personally relied on grimshot being at /usr/share/sway/, and its disappearance there when I changed to swayfx caused some confusion, which I could imagine also happening to other users.

EDIT: note that this is a trivial change to the PKGBUILD: just change the $pkgname on line 76 to sway instead.

rstacruz commented on 2023-12-06 13:41 (UTC) (edited on 2023-12-06 13:42 (UTC) by rstacruz)

I had problems with upgrading wlroots as well. Arch repos now have wlroots upgraded to v0.17, but swayfx needs wlroots v0.16.

The fix was to install wlroots0.16.

pacman -Syu wlroots0.16

Btw, I wasn't able to do this at first because it conflicted with wlroots, so I had to remove wlroots first

pacman -Rsc wlroots
# ^ uninstalls wlroots, swayfx, and gamescope

pacman -Syu wlroots0.16

yay swayfx gamescpoe
# ^ installs swayfx and gamescope again