Package Details: unvanquished 0.54.1-1

Git Clone URL: https://aur.archlinux.org/unvanquished.git (read-only, click to copy)
Package Base: unvanquished
Description: A team-based, fast-paced, fps/rts hybrid game which pits aliens against humans.
Upstream URL: https://www.unvanquished.net
Licenses: GPL3
Conflicts: unvanquished-git
Provides: unvanquished
Submitter: Viech
Maintainer: Viech
Last Packager: Viech
Votes: 61
Popularity: 0.000084
First Submitted: 2012-07-24 13:59 (UTC)
Last Updated: 2023-12-11 06:55 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

Viech commented on 2023-05-18 13:26 (UTC)

@onurbbr, thanks, have now done so.

onurbbr commented on 2023-05-14 05:54 (UTC) (edited on 2023-05-14 05:56 (UTC) by onurbbr)

@Viech I am getting compile error due to lack of required library. The solution is this. Add the following pkgbuild to the end of the prepare() section:

sed -i '/#include "common\/using_std_string.h"/a #include <cstring>' $(find . -name "minidump_descriptor.h")
sed -i '/#include <cstring>/a #include <cstdint>' $(find . -name "minidump_descriptor.h")

Viech commented on 2022-04-30 08:16 (UTC) (edited on 2022-04-30 08:16 (UTC) by Viech)

I applied the fix by moonaru as 0.25.1-2. Thanks!

onurbbr commented on 2022-04-26 12:42 (UTC)

The application does not compile due to breakpad. Breakpad developers fixed the bug but did not update. The error is as follows:

/home/onur/.cache/yay/unvanquished/src/Unvanquished-unvanquished-0.52.1/daemon/libs/breakpad/src/client/linux/handler/exception_handler.cc: In function 'void google_breakpad::{anonymous} ::InstallAlternateStackLocked()': /home/onur/.cache/yay/unvanquished/src/Unvanquished-unvanquished-0.52.1/daemon/libs/breakpad/src/client/linux/handler/exception_handler.cc:141:49: error: no matching function for call to 'max(int, long int)' 141 | static const unsigned kSigStackSize = std::max(16384, SIGSTKSZ);

The fix for the error is commit as follows: https://github.com/DaemonEngine/breakpad/commit/cdb9214e3a81223c48a913fd18c05a8d48404620

As seen in Commit, the error has been fixed. Temporarily manually edit the PKGBUILD and add the following at the end of the 'prepare()' section:

sed -i 's/16384, SIGSTKSZ/16384u, static_cast<unsigned>(SIGSTKSZ)/g' $(find ${_breakpad} -name "exception_handler.cc")

Viech commented on 2021-01-27 18:59 (UTC)

Due to reasons that are weird and I won't go into detail here, there is literally not a byte difference between versions 0.51.1 and 0.51.2. They're the same git tag and same set of game assets. But hey, if you flag this out of date, sure I'll provide you with the full 0.51.2 experience! :)

Viech commented on 2018-11-03 11:01 (UTC)

This was flagged out of date, but the Alpha 51 release was not actually made despite the v0.51.0 tag existing.

Viech commented on 2018-01-21 17:14 (UTC)

In case you are having trouble compiling due to an "invalid conversion from ‘unsigned char’ to ‘char’" in Crypto.cpp, you can try to append

cd "${_unvanquished}/daemon"; curl https://github.com/DaemonEngine/Daemon/commit/d22a354ce9ab143a39e7e3021ff5b3264e1d1361.patch | patch -p1

to the end of the prepare function. The issue will be fixed with the next release of Unvanquished. I'll also look into using Pacman hooks with that release.

g360 commented on 2016-08-09 17:55 (UTC)

All those update-desktop-database, update-mime-database and xdg-icon-resource should be deleted from install file, as that is now handled by pacman hooks.

Viech commented on 2016-07-08 18:13 (UTC)

Salut, I told the server admin. It should be fixed now. If not, please let me know.