Package Details: wayfire 0.7.3-1

Git Clone URL: https://aur.archlinux.org/wayfire.git (read-only, click to copy)
Package Base: wayfire
Description: 3D wayland compositor
Upstream URL: https://wayfire.org
Keywords: compositor wayland
Licenses: custom:MIT
Conflicts: wayfire-git
Submitter: aperez
Maintainer: aperez
Last Packager: aperez
Votes: 34
Popularity: 2.35
First Submitted: 2019-02-14 08:43 (UTC)
Last Updated: 2022-05-13 12:13 (UTC)

Latest Comments

dr460nf1r3 commented on 2022-06-03 18:02 (UTC)

This PKGBUILD misses pango in makedepends :)

magnus commented on 2022-05-15 09:08 (UTC) (edited on 2022-05-15 09:14 (UTC) by magnus)

Thanks @aperez for the bump to 0.7.3 of this package.

kelen commented on 2022-05-01 03:19 (UTC)

Thanks, @leo_sk. And the pango is also dependent when I build wayfire.

leo_sk commented on 2022-04-16 23:38 (UTC)

I think someone should just take over this package since the current maintainer does not seem interested

leo_sk commented on 2022-04-16 23:37 (UTC)

The following changes should be made to pkgbuild, hopefully the maintainers picks some from here, otherwise execute it yourself:


pkgname=wayfire
pkgver=0.7.3
pkgrel=1
pkgdesc="3D wayland compositor"
arch=(x86_64)
url=https://wayfire.org
license=(custom:MIT)
depends=(cairo 'wf-config>=0.5' libjpeg libinput wlroots)
makedepends=(meson ninja wayland-protocols glm cmake doctest)
conflicts=("${pkgname}-git")
source=("https://github.com/WayfireWM/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
sha256sums=(99d1d51b1db88c30de6484094fd02df39a82cbb503361e52abc1d94f8357cb5f)

build() {
    rm -rf build
    arch-meson "${pkgname}-${pkgver}" build -Duse_system_wfconfig=enabled -Duse_system_wlroots=enabled
    ninja -C build
}

check () {
    meson test -C build
}

package() {
    DESTDIR="${pkgdir}/" ninja -C build install
    cd "${pkgname}-${pkgver}"
    install -Dm644 wayfire.desktop "${pkgdir}/usr/share/wayland-sessions/wayfire.desktop"
    install -Dm644 wayfire.ini "${pkgdir}/usr/share/doc/${pkgname}/wayfire.ini"
    install -Dm645 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}

szbergeron commented on 2022-03-11 17:53 (UTC)

I originally flagged this as out of date for not building with the current stable wlroots from extra. This could be solved by using -Duse_system_wlroots=false, but that isn't a great solution long term since then it conflicts with sway. I think the maintainer is currently busy with other work so there may not be an upstream resolution for some time

DN-debug commented on 2022-03-11 03:24 (UTC)

Hi,

I would repeat the last person's question -- why is this flagged out? The upstream version is matching with the aur pkg version. @aperez could you please check?

Many thanks!

ThePirate42 commented on 2022-03-05 14:54 (UTC)

Why is this package marked as outdated?

name commented on 2022-01-07 22:33 (UTC)

@aperez @IrvineHimself I still think polkit should be added to the dependencies or at least mentioned in the description, It's quite an annoying error you face when you don't have it installed and it does not point to polkit whatsoever.

IrvineHimself commented on 2021-12-06 17:27 (UTC) (edited on 2021-12-06 17:33 (UTC) by IrvineHimself)

@hynopanda: If you click on the doctest link, (above,) you will see that the only available package is in the Community-Testing repo, which you would need to enable. However, from the Wiki:

Warning:

Be careful when enabling the testing repositories. Your system may break after performing an update. Only experienced users who know how to deal with potential system breakage should use it. If you enable testing, you must also enable community-testing. If you enable any other testing repository listed in the following subsections, you must also enable both testing and community-testing.

See Here

There is not an AUR PKGBUILD, but you could download this one from the Community-Testing branch and downgrade it, (or not,) to the last known good package. :)

Irvine

hynopanda commented on 2021-12-06 16:26 (UTC)

for some reason i can't install "doctest" [zooki@zooki-arch-D ~]$ paru -S wayfire :: Resolving dependencies... :: There are 2 providers available for wayfire: :: Repository AUR: 1) wayfire 2) wayfire-git Enter a number (default=1): 1 error: could not find all required packages: doctest (wanted by: wayfire) [zooki@zooki-arch-D ~]$

IrvineHimself commented on 2021-10-25 06:37 (UTC) (edited on 2021-10-25 07:17 (UTC) by IrvineHimself)

@archorz: I do not disagree with what you are saying. Like most people, I already had polkit installed, so, (for me,) it wasn't a problem.

However, for reference only, I feel I should point out that it is not as simple as just making polkit a dependency. To get it to work you need to install a polkit authentication agent and add it to autostart in wayfire.ini

You should note:

  • Wayfire doesn't have it's own authentication-agent
  • The agent used by a DE, for example, gnome, is not the same as the authentication-agent required by Wayfire. In my example, this would be polkit-gnome. Which would be started with a1 = /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 in the autostart section of wayfire.ini.
  • Edit: You should also note that on all the wlroots compositors I have tested it on, whether they list is as an opt depend or not, most packages with elevated privileges will additionally require xorg-xhost for polkit to work.

Irvine

archorz commented on 2021-10-18 21:51 (UTC)

Like sway, on Arch wayfire requires polkit to run with default configuration.

kode54 commented on 2021-09-08 03:38 (UTC)

Might it be a good idea for the PKGBUILD to sed replace some paths in the shipped default config file that goes in docs? For instance, changing /usr/libexec/xdg-desktop-portal in the autostarts to /usr/lib/xdg-desktop-portal so that people like me don't get stupidly confused why it won't start it until I actually dig up where that command lives. It might have prevented me from stupidly adding the old hack for loading systemd's user environment into the process, thinking that was why it wasn't working. The current version already does that, I think.

maderios commented on 2021-07-17 16:26 (UTC)

I get error

Program git found: YES (/usr/bin/git)
Compiler for C++ supports link arguments -lc++fs: NO
Compiler for C++ supports link arguments -lc++experimental: NO
Compiler for C++ supports link arguments -lstdc++fs: YES
Check usable header "GLES3/gl32.h" with dependency glesv2: YES
wayfire-0.7.2/meson.build:124:2: ERROR: Dependencies must be external dependencies

yan12125 commented on 2021-07-01 05:03 (UTC)

@iTux: cmake is just a checkdepends of meson, not a runtime dependency [1].

[1] https://github.com/archlinux/svntogit-packages/blob/packages/meson/trunk/PKGBUILD

iTux commented on 2021-06-30 05:54 (UTC)

@yan12125: cmake needs not to be listed in the makedepends, if you have already meson inside. meson depends on cmake.

scruffidog commented on 2021-06-28 19:03 (UTC)

Seems like wlroots updated to 0.14 and upstream wayfire also updated to 0.7.2. Is there a showstopper to be worried about in updating ?

yan12125 commented on 2021-05-25 02:04 (UTC)

Besides doctest as mentioned by firegem, cmake is also needed to build this. Could you add both to makedepends?

firegem commented on 2021-05-08 02:08 (UTC)

Looks like this needs doctest as a makedepend now.

aperez commented on 2021-05-06 13:50 (UTC)

@Moo-Crumpus: fixed, thanks for the heads up!

Moo-Crumpus commented on 2021-05-06 12:22 (UTC)

sha256sums: wayfire-0.7.1.tar.xz One or more files did not pass the validity check!

ablankley commented on 2021-04-21 12:00 (UTC) (edited on 2021-04-21 12:01 (UTC) by ablankley)

wayfire was updated to 0.7.1 to add support for wlroots-0.13.x. Suggest (1) changing package version to say 0.7.1, (2) change wlroots dependencies to versions between 0.13 and 0.14, and (3) update the checksum (which can be acquired using makepkg -g). Users can do this manually until aperez implements the changes. These are all developments as of this week, so I wouldn't give aperez too hard of a time. If you aren't comfortable with modifying the PKGBUILD file, then install wlroots-0.12.0-1 from the archives

simona commented on 2021-04-16 15:25 (UTC)

:: l'installazione di wlroots (0.13.0-1) interrompe la dipendenza 'wlroots<0.13' richiesta da wayfire

stianz0 commented on 2021-02-07 22:31 (UTC)

I get error in the latest release, https://pastebin.com/6EJmaydZ . I don't know why it fails to build tho, everything else are updated and fine.

fluix commented on 2020-11-08 19:16 (UTC)

I believe the license should be just MIT, not custom:MIT 1, similar to wayfire-git. This is probably unimportant, but I think quoting extra placing entries like the url, packages in (make)depends, etc. is also common.

oech3 commented on 2020-09-24 18:11 (UTC)

fails to build if -fuse-ld=lld in CFLAGS,CXXFLAGS.

dlupi commented on 2020-05-24 07:28 (UTC)

Compilation error of wf-config-0.4.0:

[2/30] Compiling C++ object 'wf-config@sha/src_section.cpp.o' FAILED: wf-config@sha/src_section.cpp.o c++ -Iwf-config@sha -I. -I../wf-config-0.4.0 -Iinclude -I../wf-config-0.4.0/include -I/usr/include/libevdev-1.0/ -I/usr/include/libxml2 -flto -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -std=c++17 -Wno-deprecated-declarations -march=x86-64 -mtune=generic -O2 -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -MD -MQ 'wf-config@sha/src_section.cpp.o' -MF 'wf-config@sha/src_section.cpp.o.d' -o 'wf-config@sha/src_section.cpp.o' -c ../wf-config-0.4.0/src/section.cpp ../wf-config-0.4.0/src/section.cpp: In member function ‘std::shared_ptr<wf::config::option_base_t> wf::config::section_t::get_option(const string&)’: ../wf-config-0.4.0/src/section.cpp:38:20: error: ‘invalid_argument’ is not a member of ‘std’ 38 | throw std::invalid_argument("Non-existing option " + name | ^~~~~~~~~~~~~~~~ ../wf-config-0.4.0/src/section.cpp: In member function ‘void wf::config::section_t::register_new_option(std::shared_ptr<wf::config::option_base_t>)’: ../wf-config-0.4.0/src/section.cpp:60:20: error: ‘invalid_argument’ is not a member of ‘std’ 60 | throw std::invalid_argument( | ^~~~~~~~~~~~~~~~ [7/30] Compiling C++ object 'wf-config@sha/src_file.cpp.o' ninja: build stopped: subcommand failed.

Plexcon commented on 2020-04-01 16:27 (UTC)

==> Missing dependencies: -> wf-config>=0.4 ==> Checking dependencies while compiling... ==> ERROR: Not all dependencies could be solved.

aperez commented on 2020-01-30 16:29 (UTC)

@laichiaheng: The issue should be fixed in version 0.3.1, please give it a try.

laichiaheng commented on 2020-01-27 14:10 (UTC)

Failed to build it.

gonciarz commented on 2019-09-22 11:24 (UTC)

+1 glm

szbergeron commented on 2019-09-21 00:45 (UTC)

Seems to be broken for me at the moment:

```Found CMake: /usr/bin/cmake (3.15.3) Run-time dependency glm found: NO (tried pkgconfig and cmake)

meson.build:27:0: ERROR: Dependency "glm" not found, tried pkgconfig and cmake

A full log can be found at /home/sawyer/.cache/yay/wayfire/src/build/meson-logs/meson-log.txt ==> ERROR: A failure occurred in build(). Aborting... Error making: wayfire```

Any recommended steps to solve this?

dumblob commented on 2019-07-31 08:20 (UTC)

Please consider adding "mkdir -p /etc/skel/.config/; cp /usr/share/doc/wayfire/wayfire.ini.default /etc/skel/.config/wayfire.ini" to install(){} for the time being (until wayfire itself will potentially implement some more sane default configuration under the condition of non-existing ~/.config/wayfire.ini).

chrisjbillington commented on 2019-02-14 22:33 (UTC)

Thanks for putting these up! How about one for wcm-git, the GUI config manager? Here's a PKGBUILD I've been using locally for it, I just don't want to be the AUR maintainer:

https://pastebin.com/aTsJwL9b

swinny89 commented on 2019-02-14 19:16 (UTC)

needs glm in depends