Package Details: apache-flex-sdk 4.16.1-13

Git Clone URL: https://aur.archlinux.org/apache-flex-sdk.git (read-only, click to copy)
Package Base: apache-flex-sdk
Description: The open-source framework for building expressive web and mobile applications
Upstream URL: https://flex.apache.org/
Licenses: Apache
Submitter: yan12125
Maintainer: zrhoffman
Last Packager: zrhoffman
Votes: 48
Popularity: 0.000000
First Submitted: 2014-03-05 17:40 (UTC)
Last Updated: 2022-06-21 23:15 (UTC)

Dependencies (6)

Required by (0)

Sources (6)

Latest Comments

1 2 3 4 Next › Last »

MarsSeed commented on 2022-06-21 23:22 (UTC)

All right. Thanks for your response, and for maintaining the package. :)

zrhoffman commented on 2022-06-21 23:17 (UTC) (edited on 2022-06-21 23:18 (UTC) by zrhoffman)

Thanks for the reminder, @relrel's suggested fix of updating the player version to 32.0 is added in version 4.16.1-13 of the package.

Is this package still needed?

yes

MarsSeed commented on 2022-06-21 14:33 (UTC)

I see @relrel's fix request from more than a year ago, and that there were no updates to address that.

Is this package still needed?

relrel commented on 2021-03-15 21:47 (UTC) (edited on 2021-03-15 21:47 (UTC) by relrel)

The following files need to be patched:

  • frameworks/flex-config.xml
  • frameworks/airmobile-config.xml
  • frameworks/air-config.xml
<target-player>27.0</target-player>

Should be patched to:

<target-player>32.0</target-player>

Otherwise mxmlc and others fail to start:

$ mxmlc
Loading configuration file /opt/apache-flex-sdk/frameworks/flex-config.xml
Apache Flex Compiler (mxmlc)
Version 4.16.1 build 20171115
Copyright 2017 The Apache Software Foundation.

/opt/apache-flex-sdk/frameworks/flex-config.xml(85): Error: unable to open '/opt/apache-flex-sdk/player/27.0'

      </library-path>

zrhoffman commented on 2020-12-28 01:07 (UTC)

@rageltman It did need updating. Thanks, updated.

rageltman commented on 2020-12-27 21:42 (UTC)

The swc file fails validation - does it need updating or is this a sign of tampering?

[2020-12-27T21:06:35.360Z]     playerglobal.swc ... FAILED
[2020-12-27T21:06:35.360Z]     apache-flex-sdk.sh ... Passed
[2020-12-27T21:06:35.610Z] ==> ERROR: One or more files did not pass the validity check!
[2020-12-27T21:06:35.610Z] ==> ERROR: Could not download sources.

zrhoffman commented on 2018-12-26 18:52 (UTC)

In addition to milkmiruku's issue:

Once replacing the old checksum for playerglobal31_0.swc with e8b0799cb19d57729407be54bad0ce13e148b93ac176952ec49952e082b6869a, I get

==> Verifying source file signatures with gpg...
    apache-flex-sdk-4.16.1-bin.tar.gz ... FAILED (public key 6B0A7EC905061FC8 has been revoked)
==> ERROR: One or more PGP signatures could not be verified!

milkii commented on 2018-12-09 15:11 (UTC)

Also, might anyone be able to elucidate the difference between the contents of this package and https://github.com/madebysource/flex-sdk ?

I'm trying to get IntegraLive (https://github.com/BirminghamConservatoire/IntegraLive) to run, but it's looking for 'frameworks/libs/air/airglobal.swc' which is in the above repo.

milkii commented on 2018-12-09 01:14 (UTC)

Currently getting:

  -> Found apache-flex-sdk.sh
==> Validating source files with sha256sums...
    apache-flex-sdk-4.16.1-bin.tar.gz ... Passed
    apache-flex-sdk-4.16.1-bin.tar.gz.asc ... Skipped
    playerglobal31_0.swc ... FAILED
    apache-flex-sdk.sh ... Passed
==> ERROR: One or more files did not pass the validity check!

dbermond commented on 2018-08-21 20:46 (UTC)

@CyberShadow Thank you for reporting this. File was updated by upstream. Now fixed.