Package Details: falkon-git 3.1.99_r5703.g9bebc144-1

Git Clone URL: https://aur.archlinux.org/falkon-git.git (read-only, click to copy)
Package Base: falkon-git
Description: Cross-platform QtWebEngine browser
Upstream URL: https://www.falkon.org/
Licenses: GPL3
Conflicts: falkon
Provides: falkon
Replaces: qupzilla
Submitter: SolarAquarion
Maintainer: SolarAquarion (IslandC0der)
Last Packager: IslandC0der
Votes: 69
Popularity: 0.000003
First Submitted: 2017-09-06 03:26
Last Updated: 2021-06-03 21:44

Dependencies (15)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

tee commented on 2015-05-30 15:44

I'm getting this message: Project ERROR: QupZilla requires at least Qt 5.5!
when trying to build.

stozi commented on 2015-05-20 15:36

I got an error:

make[1]: g++: Command not found
Makefile:2793: recipe for target '../../build/qtsingleapplication.o' failed
make[1]: *** [../../build/qtsingleapplication.o] Error 127
make[1]: Leaving directory '/home/media/downloads/qupzilla-git/src/qupzilla/src/lib'
Makefile:43: recipe for target 'sub-src-lib-make_first' failed
make: *** [sub-src-lib-make_first] Error 2
==> ERROR: A failure occurred in build().
Aborting...


Also, as I understand these variables are all default:
export USE_WEBGL="true"
export QUPZILLA_PREFIX="/usr/"

stozi commented on 2015-05-20 15:29

I got an error:

make[1]: g++: Command not found
Makefile:2793: recipe for target '../../build/qtsingleapplication.o' failed
make[1]: *** [../../build/qtsingleapplication.o] Error 127
make[1]: Leaving directory '/home/media/downloads/qupzilla-git/src/qupzilla/src/lib'
Makefile:43: recipe for target 'sub-src-lib-make_first' failed
make: *** [sub-src-lib-make_first] Error 2
==> ERROR: A failure occurred in build().
Aborting...


Also, as I understand these variables are all default:
export USE_WEBGL="true"
export KDE_INTEGRATION="true"
export QUPZILLA_PREFIX="/usr/"

sxe commented on 2015-02-27 19:42

Hi krabat,
thx, fixed the PKGBUILD.

Sadly the master branch still has the 1.8* version.

pmattern commented on 2015-02-27 17:11

Given the comments below and PKGBUILD's "depends" line this package is intended to be built against QtWebEngine (which makes perfect sense, imo).
But running 'git clone https://github.com/qupzilla/qupzilla[.git]' yields legacy branch v1.8 intended to be built against QtWebKit.

Also qt5-tools is now needed to compile (which depends on qt5-webkit for now).

You may find a PKBUILD implementing these changes on https://gist.github.com/pmattern/052942fb0d2697e975a5. It introduces usage of HTTPS to download as well.

Nierro commented on 2015-02-07 10:39

You're welcome!

sxe commented on 2015-02-07 09:26

Updated to qt5.
Thx for the reminder Nierro.

Nierro commented on 2015-01-28 11:35

"Master" branch now is qt5 only and uses webengine.
If you'd like to stick with 1.8, you have to switch to "v1.8" branch.
Reference: https://github.com/QupZilla/qupzilla .

sxe commented on 2014-12-08 10:08

Updated the package.
Thx for the heads up anex.

anex commented on 2014-12-08 08:56

Working.. OP please change the PKGBUILD with these changes..


https://gist.github.com/anexation/b02e6a0e8c178b8d4ee2