Package Details: gnuradio-git v3.8.0.0.80.gd53136afd-1

Git Clone URL: https://aur.archlinux.org/gnuradio-git.git (read-only)
Package Base: gnuradio-git
Description: General purpose DSP and SDR toolkit, with drivers for usrp and fcd.
Upstream URL: https://github.com/gnuradio/gnuradio
Keywords: sdr
Licenses: GPL
Conflicts: gnuradio, gnuradio-companion
Provides: gnuradio, gnuradio-companion
Submitter: None
Maintainer: karel
Last Packager: karel
Votes: 24
Popularity: 0.000122
First Submitted: 2010-08-05 12:14
Last Updated: 2019-11-20 07:25

Required by (44)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

ackalker commented on 2013-04-10 11:40

namcap noticed one more minor nit:
gnuradio-git E: Dependency qwt detected and not included (libraries ['usr/lib/libqwt.so.6'] needed in files ['usr/lib/libgnuradio-qtgui-3.6.5git.so.0.0.0'])
I think that qwt should best be an optional dependency, as it is not needed by users who don't use the Qt GUI stuff.

Anonymous comment on 2013-02-20 21:25

mfsiher from navyfield ?

asdil12 commented on 2013-02-11 16:07

gnuradio currently only builds with some speciial libboost-versions.

https://github.com/gnuradio/gnuradio/commit/a57dbeeed3d12df16caccf0d6fefad337a0dc48d
http://gnuradio.org/redmine/issues/513

We will have to wait for boost 1.53

asdil12 commented on 2013-02-11 16:02

the boost issue is about:
https://svn.boost.org/trac/boost/ticket/7669

asdil12 commented on 2013-02-11 15:52

gnuradio currently only builds with some speciial libboost-versions.

https://github.com/gnuradio/gnuradio/commit/a57dbeeed3d12df16caccf0d6fefad337a0dc48d
http://gnuradio.org/redmine/issues/513

I don't know, which version of boost will be considered as stable again.
In the meantime use the gnuradio package insted of gnuradio-git as gnuradio<3.6.4 doesn't has this commit included.

asdil12 commented on 2013-02-11 12:34

got maintainer of this pkg and applied my patches to fix the python-bindings.

@lkoos: python2-lxml and python2-cheetah are optdepends for grc.

asdil12 commented on 2013-02-09 19:54

nickoe:

the gnuradio-guys seem to have a broken version in git atm. Use the gnuradio pkg insted - edit the PKGBUILD, when installing is and add a 'gnuradio-git' to the provides.

nickoe commented on 2013-02-09 19:51

When trying to build qgrx-git I the the following error:

Project ERROR: Package gnuradio-core not found

So it the core not included in this?

lkoos commented on 2013-01-21 04:35

I think python2-lxml and python2-cheetah need to be added to the list of dependencies. They're needed for gnuradio-companion. Also see asdil12's comment about the PKGBUILD patch.

adampolski commented on 2013-01-20 17:36

I think cmake needs to be added to the list of dependencies for this package