Package Details: gnuradio-git v3.8.0.0.80.gd53136afd-1

Git Clone URL: https://aur.archlinux.org/gnuradio-git.git (read-only)
Package Base: gnuradio-git
Description: General purpose DSP and SDR toolkit, with drivers for usrp and fcd.
Upstream URL: https://github.com/gnuradio/gnuradio
Keywords: sdr
Licenses: GPL
Conflicts: gnuradio, gnuradio-companion
Provides: gnuradio, gnuradio-companion
Submitter: None
Maintainer: karel
Last Packager: karel
Votes: 24
Popularity: 0.000122
First Submitted: 2010-08-05 12:14
Last Updated: 2019-11-20 07:25

Required by (44)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

Anonymous comment on 2012-12-20 21:15

I believe python2-lxml needs adding to the dependencies!
It is in extra.

asdil12 commented on 2012-11-18 18:15

gnuradio-compantion and all other tools using the python-interface are currently broken, because of https://bbs.archlinux.org/viewtopic.php?id=147452

This can be fixed by using this cmake line in the PKGBUILD:
cmake -DPYTHON_EXECUTABLE=$(which python2) -DPYTHON_INCLUDE_DIR=$(echo /usr/include/python2*) DPYTHON_LIBRARY=$(echo /usr/lib/libpython2.*.so) -DCMAKE_INSTALL_PREFIX=/usr ../

rumpelsepp commented on 2012-10-22 14:05

Missing dependencies:
https://aur.archlinux.org/packages.php?ID=54924
https://www.archlinux.org/packages/extra/x86_64/cmake/

After installing it works.

Limoto commented on 2012-09-12 12:48

Missing dependency: -- Python checking for Cheetah >= 2.0.0
-- Python checking for Cheetah >= 2.0.0 - not found
CMake Error at volk/CMakeLists.txt:66 (message):
Cheetah templates required to build VOLK

(python2-cheetah

Malvineous commented on 2012-08-26 02:50

FYI it looks like this is a bug in the current git version. For the moment (until it is fixed in git) there is a workaround posted in the forum thread which involves changing the cmake command in the PKGBUILD. The issue stems from partially linking with Python3 instead of completely linking with Python2.

Malvineous commented on 2012-08-22 13:34

Has anyone gotten this to work recently? It seems to compile fine but won't run any more: https://bbs.archlinux.org/viewtopic.php?id=147452

int0x80 commented on 2012-08-04 04:41

Can we get an official package added to the repos? This is a pretty big/official project, and in the repos of many other distros(debian and gentoo come to mind.)

n17ikh commented on 2012-08-02 18:54

I was banging my head against the wall trying to get this to build, getting boost errors left and right.. However, I figured out my problem: the version of libboost I had installed had been linked against boost 1.49 and was now looking for .so files that don't exist anymore. Rebuilding libuhd from the AUR took care of my problems building gnuradio.

Gringo commented on 2012-07-26 13:32

GNU Radio's C++ manual at [1] supplies a list of the specific dependencies for each module. For the GNU Radio Companion (grc), you need to install Cheetah (python2-cheetah in AUR) and pygtk (available in the extra repository). The configure script will detect these dependencies and will build the grc module automatically.

[1] http://gnuradio.org/doc/doxygen/page_build.html

int0x80 commented on 2012-07-24 23:00

How did you get grc to work?