Package Details: gzdoom 2.3.2-1

Git Clone URL: https://aur.archlinux.org/gzdoom.git (read-only)
Package Base: gzdoom
Description: Advanced Doom source port with OpenGL support
Upstream URL: http://www.zdoom.org/
Licenses: BSD, LGPL, custom:dumb, custom:BUILD, custom:doom
Submitter: None
Maintainer: grubber
Last Packager: grubber
Votes: 73
Popularity: 6.331037
First Submitted: 2009-02-22 22:28
Last Updated: 2017-01-16 16:13

Dependencies (35)

Sources (2)

Latest Comments

narical commented on 2017-01-25 09:42

Every time I try to start new game (same error for quite a time)

Compile Shader 'shaders/glsl/lineardepth.fp':
0:7(21): error: syntax error, unexpected NEW_IDENTIFIER, expecting '{'

grubber commented on 2017-01-08 16:23

Updated to 2.3.0.

Also, I have disabled building with fmodex by default, it's not worth the hassle trying to make it work properly outside of makepkg. Everyone who had issues installing the package with your AUR frontends, it should be fixed now.

Retro_Gamer commented on 2017-01-03 04:05

@annoyingduck, correct you are! I've had zero issues building gzdoom. Installing the 4.44.58 fmodex version works just fine and is detected and used by gzdoom. As shown in these snippets cut from my build output:

==> gzdoom dependencies:
- fluidsynth (already installed)
- fmodex=4.44.58 (already installed)
<SNIP>
==> Continue building gzdoom ? [Y/n] Y
<SNIP>
-- Looking for FMOD_System_GetDriverCaps in /usr/lib/libfmodex-4.44.58.so
-- Looking for FMOD_System_GetDriverCaps in /usr/lib/libfmodex-4.44.58.so - found
-- Configuring done
-- Generating done

@GI_Jack, uninstall fmodex4.26.36 1st(it's too old to use for this now), install fmodex 4.44.58 or newer, then install or upgrade your gzoom. People are doing it this way and it's working. You can of course just as easily just comment out the fnodex dependency altogether.

ProfessorKaos64 commented on 2017-01-03 03:11

The regular fmodex will not work, as it only installs 4.44.58, not 4.44.62.

annoyingduck commented on 2017-01-02 16:33

I'm on Manjaro, I too got the fmodex dependency fail when attempting to update from previous release. The fix is simple: Install regular fmodex package from AUR, update Gzdoom, remove original fmodox4.26.36 package that previous release installed. Worked fine for me.

grubber commented on 2016-12-31 15:32

@GI_Jack, these are the correct dependencies. About the variables, please suggest a better way to a) deal with fmodex being incompatible between versions b) make parts of the build configurable.

GI_Jack commented on 2016-12-31 13:29

please fix the dependencies

Proceed with installation? [Y/n] y
error: package 'fmodex' was not found
Edit gzdoom PKGBUILD with $EDITOR? [Y/n] y
error: package 'fmodex' was not found
error: package 'fmodex' was not found


depends=('fluidsynth'
${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
'gtk2'
'libgl'
'libgme'
${_openal:+'libsndfile'}
${_openal:+'mpg123'}
${_openal}
'sdl2'
)

What the fuck is that happy horse shit?, there is no need for variablized deps.

grubber commented on 2016-12-29 14:48

@Flisk, the segfault should be fixed now that the last fmodex version is used by default.

@notuxius, works for me, try updating your fmodex package to 4.44.62.

Flisk commented on 2016-12-28 06:04

@grubber That's what I do already. I was wondering if other people were having problems with Fmod-enabled builds. If that were the case, it would make sense to disable it by default. Doesn't seem like anyone is having this problem (have you tried reproducing it?), and I'm not interested in pinpointing the exact cause when builds without Fmod work fine.

notuxius commented on 2016-12-27 18:35

@grubber error on build:
:: resolving dependencies...
:: no results found for fmodex=4.44.62

All comments