Package Details: klassy 6.1.breeze6.0.3-1

Git Clone URL: https://aur.archlinux.org/klassy.git (read-only, click to copy)
Package Base: klassy
Description: Highly customizable binary Window Decoration, Application Style and Global Theme plugin for recent versions of the KDE Plasma desktop.
Upstream URL: https://github.com/paulmcauley/klassy
Licenses: GPL-2.0-only AND GPL-3.0-only AND GPL-2.0-or-later AND LGPL-2.1-or-later AND MIT
Replaces: classik
Submitter: rocka
Maintainer: rocka (lilac)
Last Packager: lilac
Votes: 11
Popularity: 0.73
First Submitted: 2023-05-06 07:25 (UTC)
Last Updated: 2024-04-11 21:17 (UTC)

Latest Comments

1 2 Next › Last »

hippieben commented on 2024-03-16 00:16 (UTC) (edited on 2024-03-16 00:20 (UTC) by hippieben)

What's with all the -git dependencies? Pretty sure they were not required before, yet now when I try to update aur/klassy I'm prompted to likely break half my Plasma install.

Please fix.

Git page appears to recommend installing from OBS, I would recommend that alternative rather than the AUR package in its current form with the -git deps.

https://software.opensuse.org//download.html?project=home%3Apaul4us&package=klassy

leo_sk commented on 2024-03-13 22:02 (UTC)

checksum in pkgbuild is incorrect. change to e91e9a4695fa8bee0d7b53df59225f96fe1470d8afdc22a28baee5433b2fc0fc

hook commented on 2023-10-21 07:38 (UTC)

Removing it and then agreeing to a cleanBuild when re-installing it worked for me.

ZorinArch commented on 2023-10-20 11:46 (UTC)

Change the kwayland and frameworkintegration dependency to kwayland5 and frameworkintegration5

hook commented on 2023-10-20 09:28 (UTC)

It currently forces me to install the *-git versions of many KDE packages. Which is odd, because I seem to have all the deps (e.g. kcmutils5 installed).

AUR Explicit (1): klassy-4.3.breeze5.27.5-1
AUR Make Dependency (5): kcmutils-git-5.240.0_r731.g029d52a-1, plasma-wayland-protocols-git-r1019.314fb1c-1, kdoctools-git-5.240.0_r716.gb3e5202-1, ki18n-git-5.240.0_r666.ge91d3e7-1, extra-cmake-modules-git-5.240.0.r3626.319d0260-1
AUR Dependency (36): kwayland-git-5.240.0_r1215.gb1d2718-1, frameworkintegration-git-5.240.0_r674.g6d87885-1, kdeclarative-git-5.240.0_r1112.g834d8a0-1, knewstuff-git-5.240.0_r1495.ga6401e50-1, kio-git-5.240.0_r6124.g46a1d6df2-1, syndication-git-5.240.0_r901.gd69d294-1, kpackage-git-5.240.0_r822.g77e31fa-1, kded-git-5.240.0_r500.g7f36c3d-1, kjobwidgets-git-5.240.0_r499.gdf6715a-1, kwallet-git-r1241.45f1018-1, ktextwidgets-git-5.240.0_r508.g00796e7-1, kbookmarks-git-5.240.0_r511.g563e17a-1, solid-git-5.240.0_r866.gb865f92-1, knotifications-git-5.240.0_r811.gd0655e7-1, sonnet-git-5.240.0_r773.ge64d774-1, kservice-git-5.240.0_r1101.gf3bfda91-1, kcompletion-git-5.240.0_r582.g9fe1c0d-1, kxmlgui-git-5.240.0_r1004.gd27a8a92-1, upower-git-1.90.2.r6.g029651a-1, kiconthemes-git-5.240.0_r687.g707d386-1, kglobalaccel-git-5.240.0_r635.g4bf729c-1, attica-git-v5.102.0.r9.g2bab489-1, kcrash-git-5.240.0_r474.g33df047-1, kdbusaddons-git-5.240.0_r498.gd15677a-1, kitemviews-git-5.240.0_r453.gbfaecd8-1, kconfigwidgets-git-5.240.0_r945.ga78029ca-1, kcodecs-git-5.240.0_r491.g49a2729-1, kwindowsystem-git-5.240.0_r764.g132ec70-1, kcolorscheme-git-5.240.0_r121.g1fba09a-1, kwidgetsaddons-git-5.240.0_r1166.g649c8b2f-1, kauth-git-5.240.0_r584.g50836db-1, kconfig-git-5.240.0_r1151.g925c4955-1, polkit-qt6-git-v0.114.0.r13.g590e710-1, kguiaddons-git-5.240.0_r562.gc5ed05d-1, karchive-git-5.240.0_r612.g3c179ae-1, kcoreaddons-git-5.240.0_r1871.g9a8845d4-1
Sync Make Dependency (12): packagekit-qt6-1.1.1-1, qt6-doc-6.6.0-1, boost-1.83.0-2, aspell-0.60.8-3, gobject-introspection-1.78.1-1, gtk-doc-1.33.2-3, hspell-1.4-5, libvoikko-4.3.2-2, sip-6.7.12-1, plasma-wayland-protocols-1.10.0-1, qt6-wayland-6.6.0-1, python-sphinx-7.2.6-1
Sync Dependency (4): qca-qt6-2.3.7-2, libdbusmenu-qt6-0.9.3+16.04.20160218-6, qt6-speech-6.6.0-1, docbook-xsl-1.79.2-7

paulmcauley commented on 2022-08-09 04:21 (UTC)

Hello, I am the classik developer. Apologies again, but I have just renamed it klassy and released version 4.0.

Please could you move to "klassy" with a: replaces=('classikstyles' 'classik')

You will also need a "kirigami2" in depends

MountainX commented on 2022-06-20 23:54 (UTC)

There are a few related issues on GitHub. Here's one:

Failure to build from Source and AUR · Issue #31 · paulmcauley/classik

rocka commented on 2022-06-14 07:32 (UTC)

For those who came accross "incomplete type" errors: cherry pick this commit

https://github.com/paulmcauley/classik/commit/ecaa3b7b305974fd79d0ea9fedd8fa4b6eab1730

longstation commented on 2022-05-20 17:25 (UTC)

I also get an error building it:

/home/lee/Code/AUR/classik/src/classik-3.0.breeze5.23.80/kstyle/breezestyle.cpp:7650:17: note: here
 7650 |                 default:
      |                 ^~~~~~~
make[2]: *** [kstyle/CMakeFiles/classik.dir/build.make:589: kstyle/CMakeFiles/classik.dir/breezestyle.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:617: kstyle/CMakeFiles/classik.dir/all] Error 2
make: *** [Makefile:136: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...